Support » Fixing WordPress » 2.9.2 config file deletes sql 5 database contents

  • Resolved wendyhouse


    My question to you experts is
    How can I open a new-SQL V5 database using a WordPress config file that points to a restored old-SQL V4 database?

    My experience of trying to do this is that WordPress deletes the contents of the SQL V5 database when the config file is placed on the blo server.- Dataloss

    Here are the repro steps:

    1) create new-sql 5 database in GoDaddys UI
    2) restore old-sql 4 database backup to new-sql 5 through GoDaddy’s UI
    3) verify contents of sql 4 database are in sql 5 database through MyPhpAdmin (by looking at comments made in 2005) Example contents at:

    Then the problems occur when

    4) Update WordPress config file with new-sql 5 database detail
    5) navigate to blog – get this UI no matter what URL I use:
    6) Add blog title, email and click install button – get taken to new dashboard which does not include any of the blog posts or comments – except a standard welcome post
    7) Open MyPhpAdmin and look at the new-sql 5 database – it is now empty (assessment by looking at details of comments made in 2005) bar the one post.

    It looks like putting wordpress config details has wiped the database

    (note: I keep the blog pointing at a sql V5 database that was created from empty – currently I have been unable to point to my 5 years of backed-up history from my old sql V4 blog)

Viewing 6 replies - 1 through 6 (of 6 total)
  • You should have stopped as soon as you got to Step 5. The invitation to install was a sure sign that something was very, very, wrong.

    Does anyone have any constructive suggestions or could help me to troubleshoot by asking me to check aspects of my config file or sql database?

    Guys I’m not sure who to turn to – this clearly isnt a sql database provider problem, or a web hosting service problem, the problem arises when linking your config file to sql server V5 database which contains a database that was originally created using wordpress.

    Do you have a bug in your code or am I doing something wrong.

    Currently I’m at step 5 wondering whether to change the config file or to change something in the database so that WordPress 2.9.2 can acknowledge its contents rather than empty it.

    Please help

    Would converting the backup .sql text file into WXR then importing it into my working (relatively empty) 2.9.2 blog be a solution route to getting my blog history re-instated?

    If so, can you guys point me to a converter? I’ve not yet been able to find one using a web-search… …and I’m not even sure this approach will work.

    Expert opinion, guidance would be much appreciated 🙂

    I’ve solved the problem. If anyone else is experiencing the same thing feel free to contact me and I’ll walk you through the solution that worked for me.

    I’m having this same exact problem and would love a solution.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘2.9.2 config file deletes sql 5 database contents’ is closed to new replies.