Support » Installing WordPress » 2.9.2. 3.0 failure.

  • I have a serious failure guys… HELP!

    Upgraded to 3.0

    got this afterwards:

    Fatal error: Call to a member function add_rewrite_tag() on a non-object in /home/k8cpa/public_html/wp-includes/taxonomy.php on line 289

    What do I do?


Viewing 15 replies - 1 through 15 (of 28 total)
  • First try turning off plugins. If you can’t get in to the admin side, just rename the plugins folder.

    I can’t even run from the backend…

    If you can’t get in to the admin side, just rename the plugins folder.

    Like via SSH or FTP.

    Too late now, already trying to reftp old WordPress 2.9.2 and restore old WP_SQL…

    this sucks. You guys need to develop a system that checks plugs-ins an disables non-working one’s or something…

    I am not a happy camper with WordPress right now.. Matt sucks, I’m sorry.

    The problem is that there are more plugins than testers. 9,997 plugins. And some of them outright state they’ve not been tested with 3.0

    It’s on YOU to check that the plugins YOU want to use MIGHT work with the new version. At a guess, anything ‘Compatible up to:’ 2.9.2 SHOULD be okay. If it was last updated a year ago or more, probably not.

    Well, at this point, I’m offically screwed, If I cannot get my QSL database to restore to my last back up… I’m trying to upload the thing and it’s just sitting there. I am ftping too, so that might be problem. farking comcast… grrrr.

    Yeah, it’s always the users fault, WordPress never does anything wrong or never takes responsibility for their software and it’s shortcomings.

    Nothing ever changes.

    Ipstenu: Just wanted to say a quick thank you, I had a similar problem and renaming the plugins folder worked. But I don’t know where to go from here…. Should I do something from the back end before I change the plugins folder’s name back?

    @patirick – You should do one at a time. The DB one always loads slower to wait till that’s done and THEN copy back up the 2.9.2 files. Breathe deep. You’ll get there.

    If you try the upgrade again, turn off ALL your plugins first and then upgrade.

    @jyonah Make a new plugins folder and copy the plugins, one at a time, back into it. At some point, your site will break again, and you’ll know it’s that plugin 🙂 Or it’s just an issue with upgrading while the plugins are there.

    Just finished the restore of the 2.9.2 WordPress software. Now trying to get the SQL Database to restore. and I thought it restored once and now getting a blank White screen.

    This stinks.

    Patrick, you’re a nasty one aren’t you? Maybe you should take the common advice of testing on a subdomain before upgrading your main site. It’s open source software. Free. Stop whining!

    Moderator Andrew Nacin


    Lead Developer

    Fatal error: Call to a member function add_rewrite_tag() on a non-object in /home/k8cpa/public_html/wp-includes/taxonomy.php on line 289

    That shouldn’t have worked in 2.9 either, though you’d avoid the error. You have a plugin which is calling register_taxonomy() with URL rewriting, prior to us actually getting the rewriting module up and running. There’s a right way, and the plugin is doing it the wrong way.

    Moderator James Huff


    Fatal error: Call to a member function add_rewrite_tag() on a non-object in /public_html/wp-includes/taxonomy.php on line 289

    FYI, that error after upgrade is caused by the Podcasting Plugin by TSG. Reset your plugins, don’t reactivate it, and find an alternative plugin.

    Hey! This fixed the issue that I had: Sour plug-ins.

    Part of the manual upgrading process is to disable plugins. It would be nice to do that for the automatic process, but again: I appreciate that this information was here and readily available to deal with my blog. THANK YOU!

    I had the same problem.
    Renamed the Plugins folder to “plugins_0ld.” After doing so, all of the plugins were automatically deactivated. — COOL!

    Since all of the plugins were automatically deactivated, I went back in and renamed the plugins folder “plugins”

    I went through each plugin as prescribed here and reactivated.
    It worked.
    However, I’m not able to tell you which one of my plugins caused the problem as this actually gave me the chance to do some house keeping and I deleted a few.

    I understand your outrage, believe me, however, complaining here will usually only get you pushback.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘2.9.2. 3.0 failure.’ is closed to new replies.