WordPress.org

Forums

2.9 upgrade failed (39 posts)

  1. metalmd
    Member
    Posted 5 years ago #

    To upgrade automatically to a new wordpress version you simply have to go into your WP-settings.php file, and on line 13, change

    define ('WP_MEMORY_LIMIT', '8M') to define ('WP_MEMORY_LIMIT', '64M'), or to some even greater number.

    You will have to do this each time you upgrade, as the new WP-settings.php file is always at 8M

  2. agentsolutions
    Member
    Posted 5 years ago #

    I may have another solution that might resolve the issue of the memory limit. In our case, it was simply a matter of logging into our host cpanel and we were prompted to run a script update. After the script update was done, WP upgraded no problem.

    Hope this helps.

  3. sethmbaker
    Member
    Posted 5 years ago #

    I had this same problem, but after I updated all of my plugins (even the inactive ones) everything went smooth as butter. I didn't need to deactivate any plugins.

  4. doncampbell
    Member
    Posted 5 years ago #

    In case anyone is still struggling with the ERROR: WordPress 2.9 requires MySQL 4.1.2 or higher message.

    Here's what I did to do a successful WP 2.9 upgrade (1and1 was my hosting provider) -

    I used phpMyAdmin to export my database from MySQL4 and import it into a new MySQL5 database. Here's a step by step with screen shots of what I ended up doing to get a successful upgrade:

    What I learned upgrading to WordPress 2.9

    I hope that helps and can save someone the hassle that I went through when I took my blog offline!
    -Don

  5. jezzerisin
    Member
    Posted 5 years ago #

    What a shocking day, with no luck at all, I've tried to upgrade 5 times (I've just found 5 zip files on my sever as testament to this!) but it gets stuck at the line "Downloading update from http://wordpress.org/wordpress-2.9.zip." and nothing further happens.
    I didn't have an .htaccess file anywhere (yes I looked for hidden files etc..) so I created one and posted it, nothing changed, I checked I had the directory correct, permissions set to 777 etc, all done, still no update.
    I'm coincidentely get the HTTP error everytime I try to upload media. (Oddly the media does appear after a while, but I still get the error!) somebody suggested this was to do with .htaccess to, it wasn't solved by my new .htaccess file either.
    These an Amazon plugin that I'm totally unable to remove, and was contemplating removing it from the FTP server, but didn't want to upset anything! (it's not active FYG) I wondered if this was getting in the way of the update?
    Lastly, having totally destroyed my site, last time I tried to upgrade from 2.7 to 2.8 I'm feelig really tender about all this! I then had to spend about 2 weeks totally rebuilding everything (something I knew nothing about until now!) I reused my MySql database and a new install of WordPress (Several actually till I got it right!) and the results are back online at http://www.chi-gung.co.uk.
    Hosting at Oneandone with Php5
    Any suggestions as how to proceed would be deeply appreciated.

  6. Gabe Young
    Member
    Posted 5 years ago #

    I use GoDaddy for all my blogs and didn't have any problems upgrading to WP 2.9.

    As one person mentioned, just deactivate all plugins and the upgrade should work. If you don't want to use the new compatibility tool, then reactivate them one at a time to test for yourself.

  7. mlanger
    Member
    Posted 5 years ago #

    I also host on GoDaddy and didn't experience any serious problems. I did have to update my MySQL file -- it was an old blog running a version of MySQL 4. After creating a new database and "recovering" the backup from the old to the new, I also had a lot of garbage characters that need cleaning up.

    But what's worse is that my blog is now VERY slow, especially at administrative tasks such as deleting large bunches of spam comments.

    Any way to speed that up?

  8. sophiedog
    Member
    Posted 5 years ago #

    Is the 2.9 upgrade strictly for the WordPress hosted blogs?
    I have several personal websites (not hosted on the WordPress servers) and when I go into the dashboard it tells me that I have the most up to date version - 2.7.1

    What gives?

  9. BriarBunnie
    Member
    Posted 5 years ago #

    Did anyone come up with an answer for the stalling problem? My upgrade just sits and tells me that it is unpacking the update - but of course it's doing nothing of the sort. This is a new blog. I didn't bother with backing anything up because I'm still in the puttering to get it up and running stage.

    As an added feature, I can't install any new themes either. Same message - "unpacking the package" - but nothing happening.

    Anyone have any ideas that I could try?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags