WordPress.org

Support

Support » Installation » 2.9 upgrade failed

2.9 upgrade failed

  • I tried to upgrade to 2.9, but it failed saying mySQL needed to be version 4.1.2 or higher and my host is running 4.0.27. My host is GoDaddy. I would have thought they would run the latest version of everything. What can I do at this point to upgrade? Anything?

Viewing 15 replies - 1 through 15 (of 38 total)
  • @mrssquidley – Unfortunately you will need to have an higher DB as some features used for MySQL will not be available for earlier versions.

    You can either ask your web host to upgrade the database or switch to some other host which supports latest versions of PHP and MySQL

    Here the same: I try to install WordPress 2.9 automaticly but I have: ERROR: WordPress 2.9 requires MySQL 4.1.2 or higher What’s that? I can’t see my dashboard so I can’t do nothing anymore. Help!!
    How can I take it back to 2.8.6?

    My 2.9 installation also failed. I cannot get to Dashboard either… and no access to my blog from any method. Can I also get back to 2.8.6?
    I am getting this error message if I go to my home page or if I try to go to dashboard…HELP!!!!

    OK – so I went in through Filezilla and deleted the weather icon directory and I’m back up… I guess it is not compatible with 2.9?

    My all post schedule after upgrade to 2.9 are missing schedule

    My host use MySQL 5.0.81

    I got a failure on something about .js files? I don’t remember what exactly but that was mine!….. sigh.

    @mrssquidley – GoDaddy has MySql 5.0 support. You’ll need to backup your current WP databse then create a new 5.0 database and import the data. You’ll also need to reconfigure any settings in your wp-config.php file.

    I also got this error message when running an automatic update:

    The update cannot be installed because WordPress 2.9 requires MySQL
    version 4.1.2 or higher. You are running version 4.0.27.

    However, under phpinfo I show I am running PHP Version 5.2.11.

    @tdempsey, you need need to upgrade your MySQL

      not your PHP version. (close though!)

    I got an error message:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2515174 bytes) in /home/howtomak/public_html/wp-includes/http.php on line 1331

    Does anyone have any suggestions as to how to fix this problem?

    @manigaultgentile, you need to increase you PHP memory limit. This can be done in you php.ini file. If you are on a GoDaddy hosting account then here are some links to help with this:

    Can I add a PHP initialization file to my hosting account?
    What is the PHP upload limit on Linux Shared Hosting accounts?

    Thanks for the response, but I don’t have Go-Daddy. But will try to figure out. If not will just have to leave WP 2.86 thanks!

    I just upgraded to WP 2.9 from a MySQL 4.0X database. I use GoDaddy so here’s what I did. It took about 15 minutes.

    1. Back your WordPress directory AND your MySQL database. (search for how to do this or use a plugin). Do not delete anything!
    2. Login to your GoDaddy account and on the left side menu bar under My Products click on Hosting -> Manage Account (for blog host account) -> Databases -> MySQL.
    3. Create a new database and make sure you select MySQL Version 5.0. Write down your password!!!
    4. Once the database has been configured, click on the pencil to the right to view the details.
    5. Using FTP, retrieve your wp-config.php from the root directory of your WP installation. Using the information from step 4, update this file with the new database information.
    6. Upload the new wp-config.php to your WP root directory.
    7. Login in to your new 5.0 database and import the file created when you backed your database in step 1.
    8. Go to your blog and it should load fine. Now you can log in to your blog and run the upgrade to WP 2.9.

    Hope this helps for those using GoDaddy as your hosting service provider.

    I have three WP blogs. Two upgraded automatically just fine. A third let me click on the “automatic upgrade” button but didn’t get any further than the output line saying that it was downloading the .zip file. Why did the auto upgrade stall out? No error message. It doesn’t sound like the same issue.

    I’d say something got screwed on the putting-together of the version. It shouldn’t have to take all this to upgrade to a .9 version. I would understand if it were a whole version (ie 3.0). I’m staying with the current version until I can find a stable way of upgrading.

    I’m on 110mb.com. My database is currently using version 5.0.27. No success, and no returned information as to the error for me.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘2.9 upgrade failed’ is closed to new replies.
Skip to toolbar