2.9 Photo Edit (8 posts)

  1. zanfardinom
    Posted 5 years ago #


    Just upgraded to 2.9.2 and when I upload a image to the media library through a page post I can't edit the size. The only radio button that is selected if for full size (Thumbnail, Media, Large radio buttons are disabled).

    That's the first problem I see. Now, when I go back into my media library to use the new WP 2.9 photo editing options I can't. I go to media library and click on edit for one of my photos. This brings up additional info about the photo. Between the dimensions and title field should be a Edit Photo button, but is not there. Is there an option I have to turn on for this to work?

    Thanks in advance!


  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    - increasing your available memory?

  3. zanfardinom
    Posted 5 years ago #

    Thanks, esmi for the reply.

    Yes, I have tried all steps and nothing. I deleted the plugins folder completely, switched to the default theme and nothing.

    I will try re-uploading the wp-admin and wp-includes folder.

    I will keep all posted.


  4. zanfardinom
    Posted 5 years ago #


    I am working on my local machine...does this matter when it comes to photo editing?

    I switched to the default theme (no go). I am using a fresh copy of 2.9.2...the only thing I copied was my custom theme into the "themes" folder. Again, no go.

    The only thing I have in my plug-ins folder is what downloaded with WP 2.9.2.

    Do I have to activate this option somewhere...like in my functions.php file? Also, when I add media through creating a page I get a few additional options and some that are missing. I am missing the new thumbnail option.

    Additional options are:

    Full size (1024 × 768)

    I select a radio button for the alignment, but I can't change the size. Full size is the only one selected and the others are grayed out. Any thoughts on this?

    I greatly appreciate your time and help.


  5. esmi
    Forum Moderator
    Posted 5 years ago #

    You shouldn't need to activate any options in WordPress. My guess is that your local server doesn't include the necessary PHP image modules - the GD library, if I remember correctly..

  6. zanfardinom
    Posted 5 years ago #

    Thanks, esmi! How do I install the PHP image modules (GD library)? I tried to google it and can't find anything about this.

    Any ideas?


  7. mfogel
    Posted 5 years ago #

    I am having similar problems - if you cannot provide a fix I will pay someone to help me - using 2.9.2 with the painter theme I can upload and see photos fine when they are loaded via DW FTP and inserted in a Post - or when I insert in a post via URL or link - but not when I upload via WP. The images are there but with a red x on a white outline of the image. When I go to edit the image I can see it but then when I save it it has the red x in the Media file and in the post.

    Thank you very much for your help - If you need to provide paid consulting let me know and I will provide my e-mail address. Thank you.

  8. zanfardinom
    Posted 5 years ago #


    I found this link...have not tried it yet. Let me know if this works for you.



Topic Closed

This topic has been closed to new replies.

About this Topic