Support » Installing WordPress » 2.9 Installation Fails Everytime

  • I attempt to auto-update to 2.9 from 2.8.6. It doesn’t even try to update it before it just returns “Installation Failed” and that’s it. I’m not sure what else to do, and with all these other threads mentioning that when they do finally get theirs to install, it leaves them blank pages, I’m almost afraid to manually upload the version.


Viewing 12 replies - 1 through 12 (of 12 total)
  • Leave it alone is my advice, I have no idea what this is about.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator


    If you have a current file and database backup and rolled back to 2.8.6 already, try the upgrade again but this time disable all your plugins first. See if that works. If it does, put back your plugins one at a time.

    If that doesn’t work, can you check your web server’s error log? The log should have time stamps so narrowing down to the failure shouldn’t be too hard. If you can post some of the log errors (not the whole log), that might help.

    this is just ridiculous about the new version! I have done quite a few of the updates with no problems! Yesterday I saw there was a new version so did the automatic update (did my backups first) and got an installation failure relating to .js files…

    so today I tried again and this is what I got:

    Unable to locate WordPress Root directory.

    Installation Failed

    LOL well I should hope it’s there as my blog is up an running.

    What a joke this update is.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Yesterday I saw there was a new version so did the automatic update (did my backups first)

    I am always glad when someone starts with a backup. The automatic update might be the problem for you, have you tried the old method of extracting the new files onto the old?

    I’ve never tried the automated backup myself and always use a method that places/replaces the old files. I’ve never had a problem that way.

    As long as your file and database backups are current and you know how to do a restore of both, there is not much harm you can do.

    um, well I don’t know how to do a restore…or not sure if I do? LOL

    I’m just chicken to try it now. The automatic updates have always worked before. This is the first time I have encountered a problem like one.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Not sure how to do a restore? Hrm, no worries.

    The restore file portion is easy, just rename your existing WordPress directory and put the old files back in place with the same directory name.

    Restoring the database is not much harder. Give this a read:

    Thanks for the links jdembowski 🙂 I think I will hold off for awhile..I have an email in to a friend who helped me set the blog up so I will see if he can do it for me. Bummed that this new update is a bugger.

    This continues to be a problem for me, too, and, it appears, for many others. Let’s hope the 2.9.1 final release which is promised in a few days will solve the problem. Until then I’m only going to wait.

    Even with 2.9.1 now this is STILL a problem.
    Has anyone found a solution?

    WordPress 2.9.1 has arrived, but not for me. The automatic upgrade won’t work, though it always worked before.
    I’m sure there must be a simple answer to this, but it seems quite difficult to get any valid responses.

    Real easy troubleshooting first steps:

    1. Deactivate all your plugins
    2. Install 2.9/2.9.1
    3. Reactivate one plugin at a time to find the culprit

    If step 2 is successful, you may even use the plugin compatibility tool that comes with 2.9 to help you with reactivating.

    I had to install manually. Everything seems to be OK now. But very disappointing that the automatic install didn’t work. I’d still like to know why. It was certainly nothing to do with plugin incompatibility. That was one of the first things I checked.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘2.9 Installation Fails Everytime’ is closed to new replies.