Support » Plugin: Jetpack by WordPress.com » 2.9 blocking posts

  • Resolved galan05

    (@galan05)


    When I try to publish, the post merely shifts back and forth between “edit text” and “proofread” modes. Won’t publish under any circumstance. Unlike others, my text doesn’t disappear when I deactivate the plugin. Once Jetpack is deactivated, the post publishes as per normal. I love Jetpack, but I can’t use it anymore until this bug is fixed.

    https://wordpress.org/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 32 total)
  • Hi Galan05,
    I was having the same issue today, I was searching and didn’t find anything online. I was trying to schedule while I was in the Text tab. I decided to switch to the Visual tab and was able to schedule the post.

    Hope that works for you as well,
    Scott aka Wolverineguy7575

    Hi Scott–

    Tried that, no joy. The only thing that works here so far is deactivating the plugin completely.

    publicize is broken in 2.9 and I tried to go back to 2.8 and it still don’t work and no support either they dropped vers. 2.9 and now we can get any support on these issues. sad

    I had another issue, I was updating a page not a post and it wasn’t allowing me to save in the text screen, but would in the visual but then some of my code wasn’t saving so the page didn’t look right. I went into Jetpack setting and deactivated the Spelling and Grammar piece and then I could save and update from the text view

    for me this has been an issue since wp 3.8 I told them but they don’t listen there are times when I cant switch between the two tabs there stuck makes it hard to use wp for posting kinda ironic.

    Well, when enough users delete Jetpack altogether, maybe they’ll listen to that.

    I had this problem and fixed it by unchecking the automatic proofread settings in Users > Edit your settings. Automatic proofread when…

    I didn’t have to nuke jetpack.

    Plugin Contributor Brandon Kraft

    (@kraftbj)

    Happiness Engineer

    Howdy y’all,

    We’re tracking this issue and working to isolate the cause and fix.

    In the meantime, you can work around it two ways:
    * Switch to the Visual Editor before publishing or
    * Via Users->My Profile, deselect the option to proofread before publishing/updating (as noted by @geig3r above).

    Thanks for your patience. It isn’t happening for everyone (only one of my sites, personally, is seeing this) and seems to be inconsistent across browsers, so thanks again.

    Cheers!

    Switching to the Visual Editor before publishing did nothing to help me. Deselecting the proofread option in Edit My Profile did the trick, for now. Prior to that, I encountered this problem on Firefox, Safari and Google Chrome. I don’t use Internet Exploder, so I can’t speak to that.

    Glad it worked for you galan. Who doesn’t hate that sinking feeling of updating and having important stuff stop working.

    My “publish” button does not work after the update

    firefox web console says
    TypeError: window.wp.autosave.local.suspend is not a function
    upon failure to update a post.
    Disabling proofread makes updating posts work again.

    Plugin Contributor Brandon Kraft

    (@kraftbj)

    Happiness Engineer

    Thanks all for your patience.

    We have a fix that we’re finishing testing on and look to release an update very soon.

    Just so everyone is updated, a patch has gone into Jetpack to fix the issue and there will likely be a point release after some further testing.

    https://github.com/Automattic/jetpack/commit/7cdc9e10580631ca640ed872fcda2f666eb39bcd

    Until the update is released, I recommend disabling After The Deadline to automatically proofread posts before they are published.

    I applied the patch to my jetpack 2.9 installation. it fixes the bug. thank you.

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘2.9 blocking posts’ is closed to new replies.