2.9 beta 2 "Upgrade WordPress Database" Does Nothing (10 posts)

  1. war59312
    Posted 6 years ago #


    Just updated my WP 2.8.6 blog to 2.9 beta 2 and now I see the "Database Upgrade Required" screen:


    Yet after clicking the button it never happens. :(

    Ouch. And yes I created a backup and yes I can restore. But thought I'd check if simple solution first.



  2. @mercime
    Volunteer Moderator
    Posted 6 years ago #

    Did you upgrade WP via Admin auto-upgrade? Try FTP or cpanel upload - I have never encountered any problems ever with the "old-fashioned" upgrades :-)

  3. You can't do the auto-upgrade for a beta version (not from 2.8 at least)

    What happens when you click the upgrade link?

  4. war59312
    Posted 6 years ago #

    Loads the page just with the wp logo.

    Very odd.

  5. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    There were some changes to the options table update code, could you try downloading the latest trunk and see if it fixes that.

  6. war59312
    Posted 6 years ago #

    Nope, same. :(

  7. Raginwolf
    Posted 6 years ago #

    I upgraded automatically from 2.9 RC1 last night and now when I click uprade nothing happens. Downloaded nightly build but would rather upgrade auto.
    Any tips???

  8. Chris Harrison
    Posted 6 years ago #

    What version of MySQL are you running? 2.9 requires MySQL 4.1.2 or greater (old requirement was 4.0)

  9. Beasts
    Posted 6 years ago #

    cdharrison is quoting from http://codex.wordpress.org/Version_2.9 and I'm getting ready to try the upgrade myself, but... I would like to know what's changed. The page there says "and see the Changelog for 2.9." with a link to the changelog for 2.8, which doesn't exist, oops! No text on the page for 2.9, looks empty. Anyone know where to find the changelog? All I can find is the list of new features.

  10. war59312
    Posted 6 years ago #

    Ok happening with final version of 2.9 too :(

    Tried auto upgrade and manually downloading the zip file and extracting the files.

    Seems no way to upgrade to 2.9..

    I'm running MySQL 5.0.85 and PHP 5.2.11

    Update: ok changing database version worked:


Topic Closed

This topic has been closed to new replies.

About this Topic