Support » Fixing WordPress » 2.8.4 Unable to edit post timestamp

  • Has anyone found a fix for this? The ability to edit the post timestamp is not working since I upgraded to 2.8.4 (from 2.7.2). Everything else seems to be fine but I cannot schedule posts – clicking on the “edit” link next to “Publish Immediately” does nothing at all. I’ve tried on 2 different computers using 4 different browsers and nothing seems to work….

    Please help! I have a multi-author blog and need to schedule posts!


Viewing 5 replies - 1 through 5 (of 5 total)
  • esmi


    Forum Moderator

    Hi esmi – thanks so much for the response!

    I did try the suggestion to add the define statement to my wp-config.php file,
    define('ALTERNATE_WP_CRON', true);
    unfortunately it didn’t work. Still no response when I click on “edit” to change the post timestamp.

    I carefully checked all my plugins before upgrading to ensure compatibility, and those that weren’t, I ditched. What I have left are all critical plugins so I can’t try disabling them until late at night as the blog gets a good amount of traffic daily.

    But what seems odd is that this feature worked perfectly before upgrading, and now doesn’t – I’m sure my server configuration hasn’t changed, so I don’t really think it’s related to the cron process, and the Theme has been carefully checked also, although I don’t see what the Theme would have to do with a core function of the back end, that is scheduling posts, unless I’m missing something about the interaction of Themes with this feature of scheduling posts.

    Anything else I could try?

    P.S. I also enjoyed the long explanation by otto42 of the cron process – I guess that makes me a masochist too, but we are lucky to have him moderating these forums!



    Forum Moderator

    Themes can affect the backend in ever more surprising ways. The more complex the theme and the richer it’s functionality, the greater the likelihood for conflicts with other plugins or even core WP functionality.

    Plugins, however, remain the most common cause of conflicts. So, if possible, I’d suggest you start there.

    Oops I entered my update in the wrong thread!

    The gist of my update was that it turned out to be (for me anyway) the Podpress plugin from MightySeek – I was still using the older version (8.8) because I had heard that it was not compatible with 2.8, and the version I had was working fine (or seemed to be) with 2.8, so I decided to leave it alone.

    Since it was causing my problems with image uploading and editing the timestamp (to schedule posts), and I thought I’d have to replace it, I figured it wouldn’t hurt anything to try upgrading it….lo and behold the newest version of Podpress (8.8.1) seems to be fine with WP2.8 and no more problems at all!

    Thanks for your help!

    Hi Ppl.. I had the same problem.. but could solve it by logging into the admin interface using http instead of https as the latter for some strange reason disables javascript. Here is my site: Hostmonster Coupon

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘2.8.4 Unable to edit post timestamp’ is closed to new replies.