Support » Installing WordPress » 2.8.4 install.php failed to open stream wp-settings.php on line 329

  • Resolved cozmcc

    (@cozmcc)


    Argh! This is a clean install not an upgrade.
    FTP’d all the files, correct settings for db in wp-config.php
    When I go to execute wp-admin/install.php I’m getting the error:

    Warning: main(/var/www/vhosts/site-efx.com/httpdocs/wp/wp-includes/general-template.php): failed to open stream: No such file or directory in /var/www/vhosts/site-efx.com/httpdocs/wp/wp-settings.php on line 329

    the path is correct, the file is there. I tried changing permissions, no dice.

    HELP!

Viewing 11 replies - 1 through 11 (of 11 total)
  • I’m having the same problem, but with this error:

    Warning: main(.//wp-includes/classes.php) [function.main]: failed to open stream: No such file or directory in ./wp-load.php on line 46

    Anyone have a solution?

    With current versions of WP the wp-includes seems to have a nasty habbit of footsing around during upload via ftp – strange I know and havent figured it out why!

    What I tend to do is delete it and upload a fresh copy making sure my ftp is set to auto detect files between binary and ascii mmodes.

    Anyone other ideas?

    Wait, are we talking about includes in the wp-admin area?

    No not the includes in wp-admin, we are talking about wp-includes folder that is in the same location as the wp-admin folder.

    Hmmm,

    I’ve tried deleting that folder (the wp-includes in the root area) and then re-uploading a few times with no luck. as far as i can tell my ftp program is set to auto-detect between binary and ascii models.

    Do you know of any compatibly problems with using Fetch for uploading files? (I know there shouldn’t be any but I’m curious).

    I’m stumped, should I revert to an older version? I’m trying to figure this whole WP thing out.

    I’m looking at my error above and it says that it cannot find a certain file, do I have to change the way the directory works (or how the files are located?) when the website is in a subdomain?

    In reviewing my error message I found that general-template.php was the file that was missing. I was using ws_ftp pro to upload, I whacked the whole WP directory and FTP’d with gFTP on my linux box and everything works!

    Its just that, the file is either missing as the error suggests or it has been corrupted during upload or if it has been edited.

    The common problem is blank spaces before the opening <?php tag – so if the file in question is showing up in the location it is supposed to be in, I would check it for anything unusual (spaces or extra coding/characters).

    The other aproach to take is to re-upload both wp-admin and the wp-includes – failing that, a frsh install with the same databse details maybe the alternative solution. Just be sure to save your wp-config.php and the wp-content folder first together with a full database backup.

    If you have left your FTP client open (I am using FileZilla) check the Failed transfers queue. For some reasons both ../wp-admin/includes/”class-pclzip.php” and ../”class-wp-filesystem-ssh2.php” failed to transfer in my first upload.

    i known why! usually will happen on chinese version wordpress, that is cause by utf-8 encording probelm, dont edit wp-config-sample.php under windows OS, but edit under linux.

    Having the same problem with Admin access!!!!

    message –
    Warning: main(.//wp-includes/classes.php) [function.main]: failed to open stream: No such file or directory in ./wp-load.php on line 46

    Was working great yesterday, blew up today… go figure !

    Any ideas out of the obvious ones… have tried it all!!!!!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘2.8.4 install.php failed to open stream wp-settings.php on line 329’ is closed to new replies.