WordPress.org

Support

Support » Requests and Feedback » 2.8: WYSIWYG editor not working in Firefox 3.0.1

2.8: WYSIWYG editor not working in Firefox 3.0.1

  • Hey guys I just updated and the “Visual” editor stopped working. like its just not showing stuff lke [caption] and its also showing me all the tags its not supposed to show. help!

Viewing 15 replies - 16 through 30 (of 33 total)
  • My stuff stopping working too after the update and im running a magazine with heavy traffic, severely disappointed by the wordpress team

    Did any of you updated manually via FTP or did you all use the dashboard upgrade?

    If so: please update it manually, since I have the idea the dashboard-update and some plugins lead to this.

    Besides that, any webmaster should know that:

    a) always test upgrades before you go live
    b) never, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever, ever trust backups other than your own.

    deactivating plugins, a manual install and clearing all private data fixed it for me

    I upgraded to 2.8 last night and encountered the same problem with the visual editor being unavailable. After trying all the ideas listed here with no success, I thought I’d try to check the box in my user profile to ‘disable the visual editor when writing’. I did that, loaded the editor to confirm that it was in html mode. Then I went back into my profile and unchecked the box and tried again and the visual editor is now working in IE8 and Firefox 3.0.11.

    Don
    grapelog.com

    bjsmooths
    Member

    @bjsmooths

    Got everything to work finally. Here are the steps I took to get the visual editor to work:

    1. deactivate all plugins in your plugins menu

    2. manually upload wp 2.8 via ftp

    3. when I looked at the visual editor after manually upgrading, the default editor cam up.

    4. activate plugins with the exception of “Kimili Flash Embed” if you are using this plugin, I found that it is currently not working with 2.8. note: I also activated plugins one by one manually to see which plugins where causing issues. Each time I would activate a plug, I would check the visual editor to see if it was rendering the visual editor correctly.

    4a. Kimili Flash Embed and Sem-Wysiwyg (paid plugin from semilogic) are currently the plugins that are having problems w/ 2.8 disable these plugins until they have been upgraded.

    You may have some plugins that do not work with the current wp version, so I suggest to activate plugins manually and not do the bulk activation. Each time you activate manually, check your visual editor to see if it is rendering correctly.

    For step 5, I activated TinyMCE Advanced Last to ensure that everything was working before activating that particular plugin. The results was that it did work.

    5. if you want a more complete visual editor, I installed TinyMCE Advanced and it worked fine. One thing though. By default, this plugin will show your visual editor background dark gray. How to fix this is once the plugin is activated, go to the “Settings” tab on your sidebar (in admin panel), select TinyMCE Advanced and scroll down and uncheck the “Import the current css theme”. By default this is checked and it renders your visual editor background dark gray. By unchecking it, it will show your visual editor background white.

    bjsmooths
    Member

    @bjsmooths

    FYI… tested in both Firefox 3.011 and IE 7.5. Both work and render correctly in those browsers

    bjsmooths
    Member

    @bjsmooths

    also works in IE 6

    I did not deactivate any plugins, just uploaded the admin/includes folder and everything seems to be working fine now.

    I did not use the automatic upgrade feature in WP, but rather I used the automatic upgrade plugin that I’ve used for several upgrades. This is the first time I’ve had this issue.

    Everything is working now.

    cabridges
    Member

    @cabridges

    Same problem as everyone here. Did as suggested: deactivated all the plugins, deleted wp-admin and wp-includes, uploaded them manually, logged back in. I have a visual editor again! Woo!

    Now heading back in to activate plugins, carefully…

    Mariam Talakhadze
    Member

    @sweet_baby_girl

    same here same here!!!

    Didn’t work for me. Re-uploading wp-admin and wp-includes was a bust. I can use the html tab, but as soon as I shift to visual editor, that html code is stripped out except for code related to graphics.

    So, guess I’ll stick with the html post entry method.

    Mariam Talakhadze
    Member

    @sweet_baby_girl

    My posts are not saved from New Post section.
    when I press save it’s just all gone :(((

    But quick post on dashboard saves the text and pictures nicely.
    What is wrong?

    sigh. did the delete/reinstall and it worked. was a traumatic experience for me though, cos i deleted wp-content out of sheer noobness, and then o my sheer horror i found that the wordpress-upgrade-plugin-supplied backup folders dont backup wp-content for some weird reason. some files lost but wth.

    i know how n00b i sound, but seriously before this i did not have to mess around with wp-admin and wp-includes

    wp 2.8 is an improvement over 2.7, but damn the upgrade procedure was a serious, serious setback over previous ones.

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘2.8: WYSIWYG editor not working in Firefox 3.0.1’ is closed to new replies.