Support » Installing WordPress » 2.8 Won’t Upgrade Automatically

  • Despite numerous attempts, everytime I press the “Upgrade Automatically” to get 2.8, nothing happens. I wait for a long time then abandon. Any suggestions? If the answer is to install manually, where are the instructions on how to do that? I am self-hosting 2.7.1.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same here. No idea how to upgrade without doing a manual upgrade. And I really don’t want to do that.

    This could be an issue with the webhost being compatible with the core update functionality.

    Here is a link to manually upgrading WordPress

    I also wrote an easy to follow article on it

    How to Upgrade WordPress Manually

    I get a diff file name uploaded to my server when I use auto upgrade vs when I download manually I see others are having success w auto upload so it must be my server config?

    Same problem here. I’m with Hostpapa so shouldn’t be a problem. I know how to upgrade manually but I’d rather get to the bottom of this problem. Any ideas?

    Deactivating all my plugins first allowed me to upgrade automatically.

    Ok i will try to deactivate but i think i have server problem, my werver admin would love to set it up so it works, but you need to tell me what is needed for server to have this automaticaly update working.
    Please write requirements.

    I had the same problem as the rest of you, have tried to deactivate plugins and it’s worked a treat.

    I recommend trying that if you haven’t already.

    Good luck all!

    Yes this worked but now i cant upgrade any of plugins… why?

    Great – like you Christiaan, deactivating all the plugins allowed me to re-install the upgrade on one of my two websites. Now I have the toolbar icons working in Visual Edit – and things seem to work.

    After upgrading to 2.8 on my other website, all the Visual Edit toolbars appeared fine but when I tried to upload an image it did not appear.

    I have tried upgrading Auotomatically with this site, which is with Hostpapa and got a Fatal Error Message saying that the ‘Allowed memory of 33554432 bytes was exhausted. Tried to allocate 2348617 bytes in….’

    I can’t imagine that there should be a limit with Hostpapa.

    Any ideas anyone?

    What a nightmare – thank you so very much for all the help that’s flying around. I would have been totally lost without it.

    I’ve been puzzling over this for a long time, every so often trying a new idea. I must be brain damaged, though, because it never occurred to me, until just now, to selectively deactivate my plug-ins.

    After deactivating Backupify for WordPress (, the problem was fixed. I tried several other deactivations and so far I’ve only found that one plug-in to be a problem. However, in the future, I will try selective deactivation (up to total deactivation) of plug-ins before I throw in the towel and manually upgrade.

    Hope this helps.


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘2.8 Won’t Upgrade Automatically’ is closed to new replies.