WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] 2.8 upgrade killed visual editor

[Resolved] 2.8 upgrade killed visual editor

  • upgraded to 2.8, now the visual editor is not visible; the tool bar may briefly appear for less than a second then it’s gone and everything is in HTML

    same on 2 blogs, same host: Bluehost

    I’m on a Mac, OSX 10.5.6
    same on 3 browsers:
    Firefox 3.0.11
    Opera 9.62
    Safari 3.2.1 (5525.27.1)

    dumped cookies, personal history, flushed cache

    tried everything suggested in similar thread here, now ‘resolved’ because OP resolved even though many others on thread not resolved, so I started another thread because it is not resolved with this OP

Viewing 15 replies - 1 through 15 (of 71 total)
  • I upgraded to 2.8 last night and encountered the same problem with the visual editor being unavailable. After trying all the ideas listed here with no success, I thought I’d try to check the box in my user profile to ‘disable the visual editor when writing’. I did that, loaded the editor to confirm that it was in html mode. Then I went back into my profile and unchecked the box and tried again and the visual editor is now working in IE8 and Firefox 3.0.11.

    Don
    grapelog.com

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    If you add

    define( ‘CONCATENATE_SCRIPTS’, false );

    to wp-config.php does it work properly? (This can be added somewhere near the top or the middle but not at the bottom there). Also could you post a link to your site?

    did you already try to re-upload folder wp-includes?

    I tried unchecking “disabling the visual editor when writing” then rechecking – still not fixed. I tried automatic re-installing – still not fixed, that should have re-uploaded the wp-includes.

    adding “define( ‘CONCATENATE_SCRIPTS’, false ); ” seems to work.

    Thank you very much azaozz!

    the site are:
    http://rawmaterialsecon.com/
    http://test.willienelsonpri.com/

    Is this a fix or a test?

    I got the same problem here, the visual editor just went away after upgrading from 2.7.1 to 2.8 (thankfully this is not a production or even public site).
    I’ve done some reseach with firebug and the problem seems to be related with the version that is requested from wp-includes/js/tinymce/wp-tinymce.php , in my case, looking at the network traffic I see this request:

    wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=3241-1141

    which is returning nothing, but if I change that to be

    wp-includes/js/tinymce/wp-tinymce.php?c=2&ver=3241-1141

    then it returns the needed javascript for tinymce.

    I looked at the source for wp-admin/post-new.php and it’s using the wp_enqueue_script function to load the ‘editor’ scripts.

    Digging a bit, that function is defined on wp-includes/functions.wp-scripts.php….

    And there’s where I’m right now, I’ll let you know as soon as I know more.

    Now, it seems related to compression. In file wp-admin/includes/post.php there’s a line like this:

    $zip = $compress_scripts ? 1 : 0;

    Don’t ask me why, but if you change that line to look like this (Wich is a dirty way to disable script compression):

    $zip = $compress_scripts ? 0 : 1;

    then the visual editor starts working again 😉

    But remember that:

    • this will only fix the problem if you see in your firebug that the request to wp-tinymce.php has “c=1” in it
    • this is a dirty piece of shit, it is not a definitive solution, just a temporary workaround

    I also had issues with the visual editor, though for me it was the ‘Use Google Libraries’ plugin. It reports the actual version of WP, which is most likely the cause of the problems. They probably weren’t ready for 2.8 and didn’t have the libraries out or something.

    I don’t know if that will fix it for everyone, but I recommend you try to disable that if you have it installed.

    I do not use the ‘Use Google Libraries’ plugin but I do use other Google plugins:
    FeedBurner FeedSmith
    Google XML Sitemaps

    do they use Google Libraries?

    define( 'CONCATENATE_SCRIPTS', false );

    Worked for me too.

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    @jay Greathouse it’s both a test and a fix. Not sure why the first site fails, but the second seems to be missing files, in particular wp-includes/js/tinymce/wp-tinymce.js.gz.

    @opsidao adding $zip = 0; there will do the same and load the uncompressed file. Before changing it maybe make sure wp-tinymce.js.gz exists on your site too.

    @azaozz first site missing:
    tiny_mce_config.php
    tiny_mce_ext.js
    tiny_mce_gzip.php

    thank you so much, how do you know what I’m missing?

    perhaps more importantly, where is a list of files I should have so I can check all this out my self?

    I upgraded a third blog to 2.8, same problem, then looked in wp-includes/js/tinymce and discovered missing files, added missing files and problem went away

    so, can I assume no need to add: define( ‘CONCATENATE_SCRIPTS’, false );
    if all the files are there?

    and, even assuming that I now have all the files, I only compared between 3 installations and added files that were missing relative to other installations, but have no way to know if a file is actually missing in all three installations.

    I’m really trying to get this worked out before I upgrade my main, very important, blog

    Does a list of files for a complete installation actually exist anyplace?

    I add:

    define( ‘CONCATENATE_SCRIPTS’, false );

    and I get an error:

    Warning: Cannot modify header information – headers already sent by (output started at /home/jgibson/public_html/blog/wp-config.php:47) in /home/jgibson/public_html/blog/wp-includes/pluggable.php on line 865

    So far my visual editor isn’t working…

    downloaded 2.8 zip file directly from http://wordpress.org/download/ and checked tinymce directory and it is ‘missing’ files that I’ve now added to my blogs:
    tiny_mce_config.php
    tiny_mce_ext.js
    tiny_mce_gzip.php
    wordpress.css

    so what am I to think about this?

    can anyone else confirm that the official WP download is missing files?

    Yep I just downloaded 2.8 those files (tiny_mce_config.php
    tiny_mce_ext.js tiny_mce_gzip.php wordpress.css} are missing. S

    So where do you get them from?

Viewing 15 replies - 1 through 15 (of 71 total)
  • The topic ‘[Resolved] 2.8 upgrade killed visual editor’ is closed to new replies.
Skip to toolbar