Support » Alpha/Beta/RC » 2.8 RC1 Call to undefined function token_get_all()

  • I just upgraded my site to 2.8 RC1, and when I go to Admin -> Plugins -> Editor, I get Fatal error: Call to undefined function token_get_all() in /var/www/[wordpress-site]/htdocs/wp-admin/includes/misc.php on line 273

Viewing 15 replies - 1 through 15 (of 21 total)
  • same here. when i click on a file on the right side the error occurs

    I have the same problem but with the theme editor. My CSS file shows up fine, but any other file gives me that error. I tried deactivating my plugins but that didn’t resolve the problem. I’m using version 2.8.

    Yes ive noticed that problem too when i click Editor under Plugins tab
    i get that undefined function token_get_all() could be a bug since it was only released yestaday public so had to go back to 2.7 im glad i did a backup now could this be fixed a.s.a.p?

    This update really messed my site up now. now im gonna have to put my old backup on 🙁

    I’m getting the same error with the theme editor after upgrading to 2.8, happens when attempting to edit the .php theme files.

    Exact error: “Fatal error: Call to undefined function token_get_all() in /path/wp-admin/includes/misc.php on line 273”

    anyone found a fix yet?

    If this helps, my local wordpress site running on xampp does not result in that error after upgrading. I tested the release offline and upgraded live site only because everything seemed alright.

    id say its best to stick with 2.7 has wordpress team need to fix this problem out nd others that users are getting it was rushed out wordpress should of tested it completly before making it public.

    At least you have an old site to put back on, I only did a db backup because 2.8 worked great offline. In fact, the primary reason I upgraded is because of the performance improvement which is noticeable.

    I’m having this issue too in 2.8 final. What’s going on? I thought it was a plugin issue, but now, well, it’s pretty obvious it’s not. Agh.

    I switched back to 2.7.1, first time I’ve had to downgrade.

    Funny that 2.8 still listed as “The latest stable release of WordPress”.

    yep.. me too.

    this sucks 🙁

    I have the same problem :\, it appears to be because when php was installed on my server it was compiled with –disable-tokenizer. I am currently rebuilding php with tokenizer support and will report back with my findings after it is done (it takes a while to rebuild php.)

    Well, enabling the tokenizer did the trick, if you have the ability to do so on your server then I guess that’s the solution. I’m not to sure what you can do if you can’t rebuild/change php settings.

    I have this problem as well. You can edit the files the old fashioned way if you really need to. Just download them with FTP, make your changes then reupload.

    I really hope this problem is fixed soon.

    Not all of us have tokenizer enabled. My web host has a lot of stuff turned off so the server works better, including this. I can’t ask them to turn it on.

    Why couldn’t they make this optional? Ugh. 🙁

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘2.8 RC1 Call to undefined function token_get_all()’ is closed to new replies.