Support » How-To and Troubleshooting » 2.8 loading slow. Times out.

2.8 loading slow. Times out.

Viewing 15 replies - 1 through 15 (of 31 total)
  • YES. And it seems to be getting worse as time goes on. Today it’s taking me three or four refreshes to get any page to load at all, and admin/dashboard is agonizing as well.

    When I first upgraded, all seemed fine. It seems that as time progresses, however, this problem continues to get worse.

    I’ve also checked with my host to see if they’re having server issues, or whatever, that might affect the mySQL end of things, but I really don’t think so, as I’m seeing others report the same problem with 2.8.

    http://www.gazehound.com , should anyone like to check things from their own ISP.

    I’m experiencing this also. I “upgraded” to 2.8.1 beta2 and the problem persists. It gets only slightly alleviated when I turn off all plugins.

    I do get slow mysql errors, but I cannot find any particular pattern to them. My hosting company, bluehost.com, insists that the mysql server is running fine, and at this point, I find it difficult to refute their point.

    I have analyzed and optimized all tables, but both admin and the blog itself are still running very slowly.

    This started happening very suddenly last week, about three weeks after I upgraded to 2.8.

    I did the upgrade automatically via the dashboard. I upgraded to 2.8.1 b2 manually.

    For the past hour or so, in three different browsers, I’ve been disabling one plugin at a time. The only one that seems to have made SOME difference is WP-Stats-Dashboard. The pages are still slower than “normal” to load, but at least they are loading in all three browsers.

    Does anyone else have that plugin installed, and if so, do you find it makes any difference?

    Philonous, I also received a reply back from my host company that their mySQL platform is working fine. The tech who emailed me, in fact, has a WordPress 2.8 site running on the same server that is not having any speed problems.

    I have not tried either of the beta versions, I’m still running on “straight eight”. 🙂 It sounds like the bog-down happened right around the same time for both of us.

    I do not have WP-Stats_Dashboard installed. This seems to be totally independent of widgets at this point, frankly. After all, my admin pages are loading very slowly, too.

    I noticed that my wp_options table is rather large at 1.2 Mb. Examining it, I saw A LOT of option entries like this one:

    I have also noticed that the WordPress RSS feed entries on the dashboard front page are loading VERY slowly.

    Furthermore, the plugin edit page either fails to load or reports an error when I try to edit a plugin’s source.

    I should add that I also noticed that my dashboard reports 268 blog entries while phpmyadmin reports 795 entries in the wp_posts table. (I do not have 500 drafts.)

    I’ve also certainly got various issues playing against the site speed, but disabling that one plugin did seem to help “some”. It may be more because it calls out to post data from another server than anything. ??

    I’m also now getting “Error establishing a database connection” errors intermittently.

    I think I may be experiencing a double whammy — both something in WP 2.8 and something on my host server acting against each other.

    AND at around 3pm eastern time my site went down completely, the Error Establishing thing now appears complete.

    I’ve got a support ticket in to my host.

    Good luck, all!

    I upgraded to WordPress 2.8 and I am also experience extremely slow load times in the dashboard and on the web site.

    I disabled ALL plugins, but I really didn’t see a noticeable increase in speed.

    Seriously thinking about downgrading. Just wish I could fix this!

    Try increasing your memory_limit, changing your theme to the default theme, renaming your plugins folder, make sure you’re running PHP 5 and MySQL 5 as older versions of these can make WordPress run slow. (Do all of this at the same time, it won’t do to rename your plugins folder, and then rename it back, then change your theme, etc., your theme should be default and your plugins should be renamed at the same time, etc.)

    Also run a repair and optimization on each of your tables in your database(s): http://helpdesk.bluehost.com/kb/index.php/kb/article/000496

    Ways to increase your memory limit:
    1. Increase the memory limit setting in php.ini (e.g. memory_limit = 64M ;). Many hosts may not allow this.
    2. Increase the memory limit via .htaccess (e.g. php_value memory_limit 64M). Many hosts may not allow this.
    3. Increase the memory limit via wp-config.php (e.g. define(‘WP_MEMORY_LIMIT’, ’64MB’);)

    For any who haven’t looked into this: http://wordpress.org/support/topic/279132?replies=59 look into it.

    You can also try browsing these forums for what others who had this problem did.

    If all of the above fails, contact your host or revert back to 2.7 for the time being.

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    I should add that I also noticed that my dashboard reports 268 blog entries while phpmyadmin reports 795 entries in the wp_posts table. (I do not have 500 drafts.)

    Not unusual. Revisions take a post. So do any uploaded images or files (anything in the Media library). So do Pages.

    wp_posts holds lots of things that are not “posts”.

    None of the above worked for me. I tried increasing memory to 64 Mb, and the server refused it. (26 Mb is the limit allowed.)

    I am now almost certain that there is some detritus in either my .htaccess files or in my config file that is causing the problem. I am also wondering if this is a problem with the automatic upgrade feature introduced in 2.6. I have upgraded automatically from 2.6 to 2.7 and to 2.8.

    These are the slow mysql query logs that were generated yesterday:

    # Mon Jun 29 17:15:02 2009
    # Query_time: 2  Lock_time: 0  Rows_sent: 0  Rows_examined: 0
    use minoofar_wrdp1;
    UPDATE <code>wp_usermeta</code> SET <code>meta_value</code> = 'classic' WHERE <code>user_id</code> = 2 AND <code>meta_key</code> = 'admin_color'
    # Mon Jun 29 15:08:44 2009
    # Query_time: 2  Lock_time: 0  Rows_sent: 0  Rows_examined: 0
    use minoofar_wrdp1;
    SELECT post_modified_gmt FROM wp_posts WHERE post_status = 'publish' AND post_type = 'post' ORDER BY post_modified_gmt DESC LIMIT 1
    # Mon Jun 29 12:00:02 2009
    # Query_time: 2  Lock_time: 0  Rows_sent: 0  Rows_examined: 0
    use minoofar_wrdp1;
    SELECT post_id, meta_key, meta_value FROM wp_postmeta WHERE post_id IN (854,770,833,630,419,758,812,619,772,810,806,800,795,791,785,751$
    # Mon Jun 29 12:19:54 2009
    # Query_time: 18  Lock_time: 0  Rows_sent: 0  Rows_examined: 0
    use minoofar_wrdp1;
    SELECT *,
      <code>TABLE_SCHEMA</code>       AS <code>Db</code>,
      <code>TABLE_NAME</code>         AS <code>Name</code>,
      <code>ENGINE</code>             AS <code>Engine</code>,
      <code>ENGINE</code>             AS <code>Type</code>,
      <code>VERSION</code>            AS <code>Version</code>,
      <code>ROW_FORMAT</code>         AS <code>Row_format</code>,
      <code>TABLE_ROWS</code>         AS <code>Rows</code>,
      <code>AVG_ROW_LENGTH</code>     AS <code>Avg_row_length</code>,
      <code>DATA_LENGTH</code>        AS <code>Data_length</code>,
      <code>MAX_DATA_LENGTH</code>    AS <code>Max_data_length</code>,
      <code>INDEX_LENGTH</code>       AS <code>Index_length</code>,
      <code>DATA_FREE</code>          AS <code>Data_free</code>,
      <code>AUTO_INCREMENT</code>     AS <code>Auto_increment</code>,
      <code>CREATE_TIME</code>        AS <code>Create_time</code>,
      <code>UPDATE_TIME</code>        AS <code>Update_time</code>,
      <code>CHECK_TIME</code>         AS <code>Check_time</code>,
      <code>TABLE_COLLATION</code>    AS <code>Collation</code>,
      <code>CHECKSUM</code>           AS <code>Checksum</code>,
      <code>CREATE_OPTIONS</code>     AS <code>Create_options</code>,
      <code>TABLE_COMMENT</code>      AS <code>Comment</code>
      FROM <code>information_schema</code>.<code>TABLES</code>
      WHERE BINARY <code>TABLE_SCHEMA</code> IN ('minoofar_wrdp1')
      LIMIT 250 OFFSET 0

    Are there any clues in here? Or, should I just wipe it out and start from scratch? I have exported the blog as an xml file. I guess all I got to do is make sure that I keep the uploads folder.

    Bluehost will allow you to increase the memory_limit up to at least 128 last I heard (Which was about 2 weeks ago). If it isn’t updating, you may want to submit a help request to Bluehost support and see if they can help you figure out why. From my experience it has been a problem with the php.ini file not existing where it should be or, if you are using the single php.ini mode (Through PHPConfig in the cPanel), there is often a conflicting .htaccess file in a subdirectory.

    Well, I regenerated a php.ini file from the cpanel for fastcgi php configuration, I changed the memory limit to 64M, I copied the file to the root wp folder, but absolutely nothing changed. It’s still slow!

    This is today’s slow sql log:

    ‘# Tue Jun 30 12:00:16 2009
    # Query_time: 3 Lock_time: 0 Rows_sent: 0 Rows_examined: 0
    use minoofar_wrdp1;
    SELECT YEAR(post_date) AS year, MONTH(post_date) AS month, count(ID) as posts FROM wp_posts WHERE post_type = ‘post’ AND post_status = ‘publish’ GROUP BY YEAR(post_date), MONTH(post_date) ORDER BY post_date DESC’

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    Query_time: 3

    Why don’t you look for queries that are actually taking a long time? 3 seconds is nothing. If that is even in “seconds” there.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘2.8 loading slow. Times out.’ is closed to new replies.