WordPress.org

Support

Support » Installation » 2.8 fatal errors in wp-admin and wp-includes

2.8 fatal errors in wp-admin and wp-includes

  • I successfully rolled back to 2.7.1 after experiencing numerous errors upgrading to 2.8. I’m neither a newbie nor super-experienced, but I’d made backups and I had 2.7.1 on my hard drive still from the last upgrade. This experience got me thinking about what I dislike in WordPress.

    I have another blog in Textpattern, so I have some means of comparison–WordPress updates are so frequent (if I include the plugins that need to update periodically, etc) and can be so potentially devastating to a blog that I wonder why there’s an “Automatic Upgrade” button at all–the forum posts are filled with newbies who’ve not backed up, and who expected the button to work right. It has never worked correctly for me and I’ve always had to manually upgrade and if there are going to be problems, it sure would be better to go slower and step-by-step than just to push a button and hope.

    Secondly, there’s no way of knowing when an upgrade has had all the kinks worked out. I assume that when the upgrade is posted, it is out of beta and good to go. Not so, apparently.

    My problems had to do with the wp-admin and wp-includes folders. After upgrading manually, I still had error after error. At one point the blog loaded, but I couldn’t get into the Admin page. I kept getting errors that lines were missing or classes couldn’t be found. Perhaps this is a problem with my theme, but I can’t tell. 2.7.1 works and I’m back to it for now.

Viewing 15 replies - 1 through 15 (of 28 total)
  • You could be a candidate for following these upgrade procedures: Upgrading WordPress

    I follow those procedures each time, but this time I tried the Automatic Upgrade, just to see if it would work. It didn’t, so I started over with a manual upgrade. That didn’t work either–in fact that’s when I got the error messages (the Auto Upgrade didn’t even get as far as giving me errors–it froze halfway through).

    And you deactivated all plugins before doing the manual upgrade?

    Just tried again, following procedures. Yes, deactivated plugins. After manual upgrade, I get this error message:

    Fatal error: Class ‘WP_Widget’ not found in /usr/www/users/dhurst/englishandmore/blog/wp-includes/default-widgets.php on line 15

    Previous error messages have been different, but they all reference missing classes in either wp-admin or wp-includes and tell me on what line the failure occurred. One previous message had to do with Class ‘Translations’ not found and I reuploaded the specified php file, but then I got another fatal error message and so on. I’m following the procedures, but something isn’t working. I’ve been with WordPress for several years adn none of my upgrades have been this difficult.

    I’m not a techie, so always use the auto-upgrade. This is the error message I got:

    Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /home/crashing/public_html/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /home/crashing/public_html/wp-admin/includes/class-pclzip.php on line 5498

    Please advise.

    danceofvictory – suggesting you deactivate and delete the WordPress Automatic Upgrade Plugin.

    dhurst – what theme are you using? Tried the WordPress Default theme, at least temporarily?

    I have the same problem: Class ‘Translations’ not found

    And I am a techie… so feel free to speak that language. I did take a look at the detailed upgrade instructions and I followed them 100%. I also verified the wp-includes/pomo/translations.php exists. What could be the issue here? For whatever reason it cannot see that class?

    Same here… I get the:

    Fatal error: Class ‘Translations’ not found in wp-includes/l10n.php on line 408

    Tried the automatic upgrade and then did everything manually, I still get the error.

    Is my only option to roll back to 2.7?

    I rolled back…fairly lame

    I did too, I don’t see another option…

    I used the auto upgrade and I get the same error message as danceofvictory. Can’t access anything with the web interface. Strange because the auto upgrade to 2.8 worked fine on another blog I maintain.

    Any suggestions besides reverting?

    Please help…

    Yesterday I clicked on the automatic upgrade to 2.8 but had to discontinue and close the browser after clicking the “Automatic Upgrade” button.

    This morning, when I try to log in, after entering the password, it gives me this error:

    PHP Fatal error: Call to undefined function _cleanup_header_comment() in C:\websites\vistabella\blog\wp-admin\includes\plugin.php on line 89

    PLEASE help. Anyone?

    🙁

    butterfly1 –

    Have you tried a manual upgrade? It looks like your error is caused by one of your plugins. Here’s what I would do:

    – Disable all of your plugins – here’s how to do it without access to the admin page

    – Follow the manual upgrade steps here: Upgrading WordPress

    See if that works for you. Good luck!

    Strange because the auto upgrade to 2.8 worked fine on another blog I maintain.

    same here… I updated one blog with the Automatic Upgrade and had no problems. With the other one no matter what I do it gives me errors.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘2.8 fatal errors in wp-admin and wp-includes’ is closed to new replies.