Support » Fixing WordPress » 2.8 causes “redirect loop” – blog now not working

  • Resolved cperry


    when I upgraded several issues – but when you go to the blog – it gives you a redirect loop…..and error if you click on any posts, pages etc.

    Any clue how to fix this? I tried to manually upload the files after the auto update but still the same error

    I also lost all draft posts…..

    Yahoo hosted – and everything looks fine from that end…..and called yahoo support and they could not fix.

    Please help get blog back online…thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • I am not sure if this is the same problem, but I have a problem which causes me to get a blank page after updating any settings or trying to preview a blog. I think its related to the loop back coding because instead of looping back to a page with data I get a blank page…

    hmm – were you able to fix it? If so how?
    I am doing a manual ftp upload of 2.8 – again to see if that helps.

    Now I am getting the following error:
    Error establishing a database connection

    I have done 3 wordpress uploads of 2.8 – both auto and manual, I have also reimported my theme files…..did nothing to fix…

    I have to get my blog back up and running and nothing is working. I am at a loss

    I also upgraded and I also have issues.

    Internal server error, apparently when I try to access the site it’s continuously looping and my poor server is bailing because it’s trying to access the page 500 odd times.

    Never had this problem before upgrading.

    Miss Twist – glad to hear it is not just me – any thoughts on a fix? I have exhausted several tries….

    I have yahoo hosting – wonder if it is an issue there??

    I got it back up and running properly… But unfortunately I had to replace the whole site with clean files from the WP 2.8 upgrade, after deleting all my themes and plugins, and root files.
    Over writing the files did not seem to work, I had to delete them all from the server.
    Basically I re-installed everything but the database… now all systems are go.
    Oh and I did download and install each plugin manually instead of using the files in my plugins folder. It only took about 20 minutes so I wasted more time trying to find an “easy way” when I should have just deleted my old site and started fresh.

    hmmm – did you lose your old post/draft posts, etc when you started fresh?

    no everything linked up fine with my old content… I deleted my entire wp-admin folder, all of the loose files in my root folder except for my site maps, and wp-config file, and I deleted my plugins folder and all of my themes except for classic & default… THen I replaced all of that stuff with new clean files from a freshly downloaded version of WP2.8.
    then I logged in as admin and uploaded my same exact old theme and all my plugins.

    Note that I was not able to see any content on my blog until I re-installed the exact same theme that I had before. I can’t say it will work for you.. but it worked for me. you may need to type in your login site URL directly if you have no content on your blog homepage.

    YIKES – accidentally deleted my wp-config file it did a very bad thing.
    Any clue how I get it back?

    Got an error message… “There doesn’t seem to be a wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn’t work for all server setups. The safest way is to manually create the file.

    Create a Configuration File”
    Is this bad? This seems very bad…..

    you should have a copy of your wp-config file if you have a backup or old copy of your site… which you should have…

    Ok – yahoo support found the 2.8 upgrade error in the permalinks.
    Yahoo is recommending not to upgrade as they have not tested it yet…fyi

    ahh.. well I am hosted on Godaddy.. but perhaps that was the source of the issues as well…

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘2.8 causes “redirect loop” – blog now not working’ is closed to new replies.