Support » Installing WordPress » 2.8 Auto-Upgrade Deleted All Directories With a MySQL App

  • Resolved jgbutler

    (@jgbutler)


    We’re still diagnosing the problem, but somehow the auto-upgrade to 2.8 (from 2.7.1) ran amok and deleted files in any directory with a MySQL connection.

    After I ran the upgrade (which failed at the point of installing files), files in directories running other WordPress installations, as well as Joomla, MediaWiki and several home-brewed MySQL apps were deleted. Other directories were intact, but any directory with a connection to MySQL is gone.

    A few more details:

    I have 4 or 5 WP installations. I even have a disabled installation of WP-MU that I do not use.

    I was auto-upgrading a virtual-host site that is NOT the document root. It is in /srv/www/htdocs/jbutler/tvstylebook.

    I run SUSE Linux.

    Right now, we’re hoping our back-up system worked as it should so that we can back up to the system before the auto-upgrade.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Wow, mine happened a little differently.

    1. I couldn’t get the “core upgrade” to work soooo,

    2. I noticed the WordPress Automatic Upgrade [WPAU 1.2.5] plugin had been brought back to life and upgraded, so I installed the new 1.2.5 version.

    3. As soon as I activated the plugin (without even using it yet, all I did was activate it) and then my blog disappeared. Not only the tables in MySql database, but my whole directory folder is gone!

    4. So my whole WordPress install is wiped, database and WordPress directory, totally wiped! This is very weird! (unfortunately, stupidly I didn’t have a backup, but the site is in it’s infancy, so haven’t lost a lot, mostly just WordPress install and installed plugins.

    stupidly I didn’t have a backup

    ask your host – some do back ups on a weekly or more basis.

    I’ve tried the WP built in auto-upgrade twice and both times it failed. It just hangs at the “installing upgrade” (or something) step and after 15 minutes I break off and do the upgrade manually. Annoying, the plugin mentioned in this thread did an upgrade in two minutes including backups. What I mostly don’t like about the built in function, is that I can’t tell what it’s doing. I can see the damage from the attempts, folders emptied, plugins uploaded, but nothing like that during the process so it’s impossible to say if it’s doing anything and what it was doing when I broke off the process. I guess I’ll try the plugin again or continue the rest of the installations with manual upgrades. That’s a five minute job in most cases, much faster than the auto upgrade.

    Same bug hit me.

    I lost all files (across multiple domains and multiple wordpress installs) after clicking auto-upgrade within a single WordPress blog.

    Thankfully, my databases were spared.

    Same here. I am on Yahoo webhosting. Lost the files for a 2 or 3 blogs but surprisingly a few others were spared. The auto-upgrade also knocked out my subdomains and wrecked my access to Yahoo webhosting’s Control Panel. After a couple of sleepless nights and long-distance phone calls to technical support, I managed to reset my control panel and restored files from a snapshot backup that was done prior to the upgrade.

    I am holding back from doing an upgrade now till more reports come in.

    This has been fixed for 2.8.1

    https://core.trac.wordpress.org/ticket/10140

    So will not happen with the next upgrade. It says that you would only come across it if the upgrade had already failed for some reason and was re-started.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘2.8 Auto-Upgrade Deleted All Directories With a MySQL App’ is closed to new replies.