WordPress.org

Support

Support » How-To and Troubleshooting » 2.7.1 Theme Issue

2.7.1 Theme Issue

  • I recently upgraded to 2.7.1 of WordPress.

    However, this is an odd issue.

    Whenever i go in to: Appearance, and select a theme, the theme preview does not show. It’s just a blank white preview. It does this for some themes, and some themes do have a working preview?

    Any idea of what could be wrong?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The error is in the themes, not WordPress. Not sure what it is, though.

    Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    Do you have any of these themes in a subfolder of a subfolder?

    Normally, themes look like this:

    /wp-content/themes/default/
    /wp-content/themes/classic/
    /wp-content/themes/whatever/
    /wp-content/themes/other/

    and so on. But if you have them like this:

    /wp-content/themes/folder/other/
    /wp-content/themes/folder/whatever/

    Then the preview doesn’t show up properly. I discovered this recently when making some theme adjustments.

    Same error here. I discovered this error occur when the folders name contains the character “-“. Then you just have to change the name.

    bittermang
    Member

    @bittermang

    The problem, in my case, would occur with several theme:

    • mushblue-01
    • elegant-grunge
    • cosmos-plus

    But it would work with every other theme. These three themes were made by three different people, and didn’t appear to have anything in their folder to cause them not to work. The only thing these three themes had in common was a hyphen in their name.

    So I renamed the folders to take out the hyphen, suddenly they worked.

    Give it a shot.

    TVsJohnHansen
    Member

    @tvsjohnhansen

    That worked! Thanks everyone!

    I am having a possibly related issue. No matter what theme I choose in the viewer, I see my current theme. I have corrected those regexen in source, but it hasn’t fixed the issue.

    This problem persists even when previewing the WP Default and Classic themes. I’m open to ideas about fixes.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘2.7.1 Theme Issue’ is closed to new replies.