[resolved] 2.7.1 previous_post_link function fails but only on recent posts (8 posts)

  1. zeigen
    Posted 7 years ago #

    I have a blog using the default theme (http://www.zeigen.com/blog/ )

    In navigating single pages on my blog today, I saw that the customary previous post link was no longer working on recent posts.

    It worked fine previously.

    It broke on one post in particular. On that post, both previous and next links appear. After that post, the previous link no longer appears.

    Steps to reproduce:
    1. Go to http://www.zeigen.com/blog/2009/01/plinky-linky-another-time-sinky/
    2. Observe the previous post link is present.
    3. Click the next post link in the upper right.
    4. Observe this page does not have a previous post.

    The odd thing is that it was a different page that broke previously and after I edited that post's title, a whole bunch of posts that had a working previous link no longer did.

  2. zeigen
    Posted 7 years ago #

    For the record, I am using the default single.php template file; I haven't modified it.

  3. zeigen
    Posted 7 years ago #

    No one has heard of this before, eh? Should I file a bug?

  4. zeigen
    Posted 7 years ago #


  5. zeigen
    Posted 7 years ago #

    *crickets die*

  6. brainycat
    Posted 7 years ago #

    Does navigation work without permalinks? You may have broken some indexing in the database when you edited the post. I don't really have a solution, other than look at your database, specifically the broken posts, and look for any anomolies. I'd pay particluar attention to post.ID and post.post_name.

  7. zeigen
    Posted 7 years ago #

    Hmmm. I switched off permalinks to see if that fixed it, but no luck.

    I ended up downloading Lester Chan's WP-DBManager and ran repair options. That seems to have fixed it up.

    Thanks for your help!

  8. zeigen
    Posted 6 years ago #

    Saw today the issue happened again. Same symptoms -- at some random post, the link to the previous post just disappeared. Same solution -- hit "repair database" and problem went away.

    Bug somewhere?

Topic Closed

This topic has been closed to new replies.

About this Topic