Support » Fixing WordPress » 2.7 wp-admin not workin properly (buttons not functional etc)

  • Resolved musiconplay

    (@musiconplay)


    Hi there,

    Ive upgraded to WP 2.7 in 2 of my sites, and both have the same problems…

    the wp-admin is not workin properly, in the editor most of the buttons dont function.. such as changin the date, or changin the status of the post, or making it sticky, also when you press add meda, and you upload smth, then when you click on Insert in post, it doesnt function, nothing happens…
    how can this be fixed?!

    thanks in advance.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Getting any Javascript errors in the error console? Perhaps you didn’t upload all of the WordPress files properly?

    i uploaded all files man, I even tried doing an automatic upgrade… doesnt work…

    where can I check the error console?!

    In Firefox the error console can be found by clicking on ‘tools’ and then selecting ‘error console’. This will give you a list of errors and warnings.

    For the sound of it, your troubles are shared by a lot of people. Which means 2.7.1 should be out as soon as a lot of javascript errors are corrected. Themes will also need to be updated and corrected. Tons o’ fun.

    thanks a lot sir. 😀

    Which means 2.7.1 should be out as soon as a lot of javascript errors are corrected.

    There are not a lot of javascript errors in WordPress 2.7. There are, however, a lot of people using the old auto-upgrade plugin, which does not work in a large number of cases, and tends to miss files and things like that.

    Upgrading manually would likely fix these problems for most people.

    I just backed-up the posts etc of my wordpress blog Vivek’s diary (wp 2.6.3 and domain is diary.viveksanghi.com) and then deleted the whole thing and installed wordpress 2.7 (using a new database). I also have another blog by name vivek sanghi – tech blog (wp 2.7 and domain is techblog.viveksanghi.com).

    There is a problem with the installation of wordpress in
    diary.viveksanghi.com. Please see image1 (working bad) and image2 (working good) to know what I am saying.

    The wp interface is having errors as highlighted in the image1 compared with image2 which is fine. As this is a fresh new install, I am unable to understand why this is happening. I wrote to dreamhost and asked them as they pointed me to these forums. Please help.

    Vivek: I don’t see any error there. The arrow doesn’t appear unless the field is opened, or you mouseover it.

    Hello Otto42. If you look at the images carefully I am already in the comment section in both the cases. The situation in both images is the same. However just to be sure I have moved my mouse over the comment thing and its not working. I checked firefox error log i am getting lots of declaration dropped warnings. I tried reinstalling after doing a complete wipe of that folder on the ftp server. Still no solution. If you suggest i will provide you the login/passwd (on you email) for that page and you can check it out yourself

    viveksanghi, Otto means that until you click on ‘Comments’, there’s no drop down arrow.

    The sidebar arrows are independent of what page you’re on in the admin section. Basically, yes, the first screenshot is ‘missing’ the down arrow, but that feature is by design.

    grrrr. Please look at these images. In image1 I am already in the comments section. So the arrow must be displayed??
    Now see image3. I am in the pages section (the arrow displaying on pages buton/tab) while my mouse is hovering on the comments button/tab (see its slightly red in color).
    Now also see image4. I clicked on comments to enter that section and it displays neither the arrow nor any drop-down (I have not collapsed the drop-down, its completely absent). In image4 my mouse is hovering on the pages button/tab (see its slightly red in color) and its arrow is also showing. This is a problem!
    I have downloaded a fresh copy of wordpress2.7 and I am copying js and css folders from there on to my installed wp on my dreamhost account. I hope this will resolve the issue. what say?

    Oh, pardon me. There is no arrow for the comments sidebar. At all. For anyone. That’s okay.

    For the other sidebars, yes, arrows. There are none for the comments.

    Ipstenu: Then you should have a good hard look at image2. This pic is from my tech blog (wp 2.7) where I have arrows as well as a drop down. I did not modify the admin code to get that. It’s suppose to be there by design. If you dun have it, its a bug. Otto42 can you please have a look at my posts and *acknowledge* the problem here. Thanks.

    @viveksanghi,
    I don’t have this arrow on my comments section either… Just to add to the mix here!

    Do you have any comment plugins, viveksanghi? Like …

    Extended Comment Options

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘2.7 wp-admin not workin properly (buttons not functional etc)’ is closed to new replies.