Support » Installing WordPress » 2.7 with concentric hosting (XO communications)

  • Is there a way to use 2.7 with concentric hosting (XO communications)?
    They are currently set up with 2.2.

Viewing 15 replies - 1 through 15 (of 21 total)
  • If they meet the requirements you can following the instructions to install a more current version:

    http://wordpress.org/about/requirements/
    Installing WordPress

    I use XO and I needed to solve the problem with a new plugin. Create a file called:

    disable-canonical-redirects.php

    With the contents such:

    <?php
    /*
    Plugin Name: Disable Canonical URL Redirection
    Description: Disables the "Canonical URL Redirect" features of WordPress 2.3 and above.
    Version: 1.0
    Author: Mark Jaquith
    Author URI: http://markjaquith.com/
    */
    
    remove_filter('template_redirect', 'redirect_canonical');
    
    ?>

    Install 2.7 via ftp. Add this new file to the plugins directory and activate it.

    (WooT! Thanks to MichaelH and the creator of this script, Mark Jaquith, and to mrmist for the post!)

    Thanks but I’m not a programer!
    Can someone explain this in a more easy way?
    Can someone email me this file? yannsmail@gmail.com

    CGProg is telling you that you likely need that plugin if you install WordPress at XO.

    Just copy and paste that block into a Notepad file and save as disable-canonical.php.

    Then upload that to your wp-content/plugins folder and activate the plugin.

    Resources:
    Managing Plugins – read how to install plugins
    Installing WordPress
    Uploading WordPress to a remote host

    Thanks.
    Do I upload it to the new 2.7 files or the one already there?

    How do I activate the plugin?

    Administration > Plugins > Installed and click on Activate next to the plugin.

    What if you’re having the above problems, but can’t even get to the admin? Login doesn’t work; and then one gets the dreaded “redirect loop” error too.

    I’ve never had so many problems as I’ve had with XO.

    thank you, @cgprog, for posting that solution – a quick search brought me here and fixed the problem rather quickly. Greatly appreciated.

    I have been fighting with a wordpress install on their servers all day! Thank you sooooooo much for that plugin!

    Man am I having a problem with XO. I’m trying to do a manual install. They don’t seem to have phpmyadmin or anything like that so I had to create a database with a third party program and now when I run the install I get to create the admin user (on a screen without any css styling for some reason) and then when I try to log in I get this:

    501 Not Implemented
    We are sorry to be unable to perform the method POST at this time or to this document.

    Where might I have gone wrong? I uploaded that plugin but I can’t log in to activate it anyway.

    A little research has taught me this:

    The Web server (running the Web site) does not understand or does not support the HTTP method it finds in the HTTP data stream sent to it by the client (e.g. a Web browser or our CheckUpDown robot). The methods defined by the HTTP protocol are as follows:

    * POST: Submit data to the Web server such as 1) post a message to a bulletin board, newsgroup or mailing list, 2) provide input data – typically from a CGI form – to a data-handling process, 3) add a record directly to a database.

    Fixing 501 errors – general

    This error should be very rare in any Web browser. It is more likely if the client is not a Web browser – particularly if the Web server is old. In either case if the client has specified a valid request type, then the Web server is either responding incorrectly or simply needs to be upgraded.

    So is XO running some ancient servers? That makes sense with the ancient management tools they have. Has anyone installed successfully on XO? I don’t want to use the auto install (for version 2.2!) because I want it in a subdirectory and not all spread out in the main dir. Arg!

    I just talked to an XO support guy. He said they use cluster servers so it’s not a question of the server being old. He wasn’t much help and is going to have some professional services guys call me although they will charge a fee to fix it. At least I can maybe get an answer from them. This is silly. Why won’t it work?

    Moderator Mark Ratledge

    (@songdogtech)

    Forum Moderator

    It’s probably your end. First, clear your cache, cookies and history, and restart. And if you’re using IE, see Error Message: Error 501/505: Not Implemented or Not Supported to check an IE setting.

    Tried that but got the same message. Also the tech at Concentric tried to log in to WP and got the same message. I’m 99% sure the problem is on their end…

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘2.7 with concentric hosting (XO communications)’ is closed to new replies.