WordPress.org

Support

Support » Installation » [Resolved] 2.7 upgrade – Redirect Loop error

[Resolved] 2.7 upgrade – Redirect Loop error

  • I have just upgraded my blog at http://www.thesoulgirl.com and am receiving this error. My other blogs upgraded brilliantly…

    [quote]Redirect Loop
    Redirection limit for this URL exceeded. Unable to load the requested page. This may be caused by cookies that are blocked.

    The browser has stopped trying to retrieve the requested item. The site is

    redirecting the request in a way that will never complete.

    * Have you disabled or blocked cookies required by this site?

    * NOTE: If accepting the site’s cookies does not resolve the problem, it is probably a server configuration

    issue and not your computer.[/quote]

    I have tried turning off all the plugins to no avail. Any idea what’s gone wrong?

Viewing 15 replies - 1 through 15 (of 22 total)
  • As other upgrades went smoothly it may well be a permissions error with my host. I’ve contacted them and will update if I get it working.

    Incidentally, another upgrade failed due to a cron error… again, possible host permission problem.

    Karen x

    Update.. it was a permissions error. How great are Midphase for support! Sorted in 30 minutes! Go midphase :o)

    Karen x

    Did they tell you what permissions they fixed? I am getting a loop as well and my Hosting company is not as helpful.

    Thanks,
    James

    I have had this problem, too, with the fourth installation I upgraded (all on the same server, which makes it especially vexing), and am also waiting on very slow help from my host. Does anyone have any ideas how to fix it?

    Aside from deactivating plugins (tried) or flushing my .htaccess files (tried) or erasing and re-installing files (tried) or checking the blog url in my options table (just as it should be) or using default urls (already do).

    While waiting on your host, you could try this plugin, it helped for me

    Disable Canonical Redirection
    (save as php and upload it in your /wp-content/plugins directory, then activate it)

    Update: Apparently there was something in my .htaccess files that I could not edit with the interface I was using. I think the lesson here is to copy .htaccess files so as not to actually lose anything and then just delete the suckers. If it works, then rules can be added back in one at a time to make sure they’re not causing any problems.

    I was told it was a problem with my .htaccess file being renamed to .old although I can’t say I renamed it! That may well have been a wee fib… who knows *shrug*

    I’ve had the same problem!

    I contacted my host like Soulgirl had, but my host (Lycos) weren’t so helpful. Maybe it is something to do with them going out of business, i don’t know…

    ‘Please be informed that if the Word application is directly from WordPress, you would have to contact their support for further assistance.’

    Anyway, i tried the Disable ‘Canonical Redirection’ Plugin and that seems to have worked!

    Jaap

    @frostbite117

    Hello,

    I had the same problem. The ‘Disable Canonical Redirection’ plugin didn’t work for me but the following thing worked:

    I deactivated all my plugins and the problem was gone. So I activated plugin by plugin and tested where it went wrong.
    The plugin that I had installed called WP-lite caused the problem. When I activated and deactived it I could login again. So some plugins just aren’t ready for WP 2.7 I guess.

    I had a similar problem – my hand coded .htaccess file wouldn’t redirect to the www version of my domain, even though the coding was correct.

    I think there must be code written in version 2.7 that uses the setting information to create a canonical redirect (chooses whether to point to www or non-www version of your domain). I didn’t have the same problem with the prior version of WordPress.

    Once I went into Settings/General and added “www.” to the WordPress Address URL and the Blog address URL – the redirect stopped spinning in circles.

    I also upgraded to 2.7 and lost my main page to the redirect loop.

    My main page is a static page, but I get the redirect error message since the upgrade:
    http://segullah.org/

    when I chose front page to display lastest posts in settings>>reading, front page still goes into redirect feedback loop.

    Only the front page seems to be broken: My internal wordpress pages are all working, including my posts page.
    http://segullah.org/blog/

    I tried clearing and resetting my .htaccess but that’s not helping, or it takes more than an hour for .htaccess edits to become effective.

    I removed an old unused index.html file I had hanging out on the directory.

    my wp-recent-links plugin participates in the .htaccess, but I don’t understand why. I disabled it and removed the php code that calls it, but that didn’t fix the redirect loop problem.

    I tried add “www.” to Settings/General and that didn’t help my situation.

    Discovered this problem shortly after upgrading to WP 2.7. Tried the various solutions provided. The one that works was deactivate plugins and test each individually.

    The culprit for my installation was the WordPress Tweaks plugin.

    I’ve deactivated all my plugins. Then had wordpress reset .htaccess.
    Still getting redirect loop on main page.

    my .htaccess looks like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    The Disable Canonical Redirection plugin did it for me

    THANKS Bossy!

    I’ve just encountered the same issue after upgrading to 2.7. Disabling all plug-ins did not work. Installing that “disable canonical redirection” plugin worked in the sense that I can now get to the main page. However, the central pane is blank and it’s not pulling in one of the sidebars. So, I disabled that plug-in again.

    My .htaccess file is exactly like “justjohnna”‘s.

    Searching for the solution?? There must be SOME correction that can be made to the .htaccess file?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] 2.7 upgrade – Redirect Loop error’ is closed to new replies.