Support » How-To and Troubleshooting » 2.7 trouble: can’t upload images or edit timestamp

2.7 trouble: can’t upload images or edit timestamp

  • Hi! I updated to WP version 2.7 and am having a couple of problems with posts.

    Edit Timestamp:
    Clicking Edit to edit the timestamp does nothing.

    Upload Images:
    I can get to both the Flash and non-Flash image uploaders, and choose and image. But when I click the Insert button I get a blank screen.

    I’m using a Mac, latest OS, latest Flash and Javascript. This happens in both Firefox and Safari. I deleted the WP files from my host and reinstalled them from a fresh download.

    Any ideas? Thanks.

Viewing 15 replies - 1 through 15 (of 31 total)
  • I’m having the same image upload problem:
    I click to insert an image into a new post, then I’m sent to a new page:


    While I can successfully upload an image into my media library, when I click ‘insert into post’, I’m sent to this blank page:


    I understand that because I’ve yet to save the post, the id is 0 and perhaps that’s causing the issue, but I’ve tried to insert images into older posts that have assigned post ids, but I still come to the same blank screen at the end and am not able to insert the image in my gallery into posts.

    I too am on a mac, I’ve tried both Firefox and Safari, but no luck. Is there a bug that happens when I press the insert image button — shouldn’t I not be navigating away from the post I’m writing?

    Thanks in advance.

    I re-FTPed all the wordpress files, but to no avail. However, when I deactivated my plug ins, instead of sending me to a new page, the iFrame displayed properly and I was able to insert images into my posts!!!

    FYI — For me, deactivating the WP-Amazon plugin worked to allow me to Add Images.

    For those with blank admin pages after media and image uploads – I disabled all plugins, and the re-enabled all except the WP-Amazon plugin. All working well!

    (I did just deactivate MT_Amazon initially, but that didn’t seem to solve it – heance the drastic Disable All!)

    Wow so that kinda sucks if we’re wanting to use the WP-Amazon plugin huh? Any upgrades known? I like my amazon plug in lol.

    UGH I just disabled my wp-amazon plug in but I’m having the same problem. It’s taking me to a blank screen. I’m even getting an ID number and still no image uptake??


    I had been having the exact same error – uploader opens in a new tab and then goes to blank page when I attempted to input into a post – on my site and found that the “Position Yourself” plugin had been the culprit.

    I still can’t use the Flash uploader on one of my blogs (which is hosted on a different host) but it’s fine on another….

    I have the exact same issue (new page opening instead of the iframe on 2.7 with Mac, Firefox, and Safari), but I don’t have the Amazon Plugin.

    Here’s my “Sanford and son” list: http://editweapon.com/?attachment_id=131

    Guess I’ll just start disabling and see what happens.

    Same issues here for me.

    Timestamp edit does nothing.

    Media upload goes to a new tab, will not insert media into post.

    All plugins are deactivated.

    I’ve tried Firefox, Safari, Camino, and Opera on the mac. All behave exactly the same on this issue. All no go.

    On Vista I’ve tried IE and chrome… exact same result.

    This does not appear to be a mac issue. 🙂

    I trust this is being looked into, lots of posts on this subject but no answer given had worked for me.


    I am using the wp remix theme for this particular site.

    Because I had made edits to so many files, I chose to try to do a partial update to wp remix 2.3 (which is supposed to be compatible with wp 2.7).

    BUT… Upon doing a FULL replacement of the wp remix theme with 2.3 and then going through and updating with my altered files, (took a while)… all works fine.

    I suspect that for many users, if it’s not a plugin causing the problem, it may be an incompatible theme.

    Same image upload problem here. Image loads to Media Library, but when I click “Insert in Post” I get redirected to a blank screen. The image never gets inserted into the post. Desperately searching for a solution! (Using WordPress 2.7)

    I am also experiencing this, and I don’t have any of the plugins or themes so mentioned. (I’m using the default admin theme and the Royale theme in public) In fact, if I deactivate ALL my plugins, I don’t see any difference in the behavior. So, I checked what my theme did to the source of the New Post page, and found that it does include extra JavaScript to every admin page. In Royale’s case it needs this for its color picker. I was able to fix this with a patch to Royale. I have a patch for the file backend/theme_options.php here.

    For whatever is worth, I’m having similar problems. When I click to edit the time, it doesn’t do anything and I’m having quirky issues with uploads as well. This happened to me with the default theme.

    After I read some of the other responses up here, I tried disabling plugins one at a time. I know this was working a few days ago so I deactivated plugins one at a time until it got fixed. I reactivated the plugin and the problem came back.

    So for now I’ve kept it disabled but I don’t think *it* is the problem, I think it may be conflicting with something else.

    The plugin that I had to deactivate was Simple Tags by Amaury BALMER.

    For me, it turned out to be a Theme issue. I was using the WPRemix2 theme. I had to delete the code calling for the WPRemix2 Advanced Editor. After I did that, media uploads worked correctly.

    I can’t upload or do anything with images, video, etc. whether it’s in a post or on a page. When I click on the insert image button a new screen opens and this is what appears

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘media_admin_css’ was given in /data/17/1/143/133/1632785/user/1760064/htdocs/bookblog/wp-includes/plugin.php on line 339

    I am a dummie so I have no idea how to fix this. I think it first started when I attempted to use the poopy caca WP remix theme templates which cost a lot (close to $200 is what I spent) and don’t come with support, despite claims otherwise. These templates were so terrible that I had to delete the theme files from my file manager just to switch my theme back to the original. If anyone out there has spent good money on these templates beware! They not only don’t work and seem to be constantly filled with bugs and major problems, they will screw up your files and you will never hear from Mr. Bhavesh, ever.

    If anyone can help identify what problem is with inserting or uploading images and how to fix it, I would be very grateful. Bearing in mind that any explanation has to be written for a complete dummy.

    Thank you.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘2.7 trouble: can’t upload images or edit timestamp’ is closed to new replies.