Support » Fixing WordPress » 2.7 to 2.8.2 no flash uploader in FF or Safari

  • sacredpath


    On my site ( ) I have not had the flash uploader since 2.7 (now on 2.8.2). I’ve lived with it, but today I got a bug up my… you know, and decided to fix it. It now appears my expectations might have been a little lofty.

    Host: A Small Orange (Linux, Apache 1.3.41, PHP 5.2.10, MySQL 4.1.22-standard)

    Mac 10.5.7, flash player (up to date)

    Firefox 3.5 No flash uploader
    Safari 4 No flash uploader

    Windows XP SP3 (up to date)

    Firefox 3.5 No flash uploader
    Safari 4 No flash uploader
    Internet Explorer 8 YES we have flash uploader

    On my local install of wordpress 2.8.2 using MAMP (PHP 4.4.7)

    Firefox 3.5 YES we have flash uploader
    Safari 4 YES we have flash uploader

    What I’ve tried:

    1. Reinstalled the complete 2.8.2 package from scratch dumping everything except for .htaccess, wp-config.php, robots.txt, sitemap.xml, my specific plugins and my theme.

    2. Checked at settings > miscellaneous to make sure my “store uploads in this folder” was set to wp-content/uploads – and it is.

    3. Reuploaded the swfupload folder to /wp-includes/js/swfupload – again. Results: no change

    4. Reuploaded the entire wp-includes and wp-admin folders – again. Results: no change

    5. Created .htaccess file with the following code in it and uploaded it to wp-admin folder.

    IfModule mod_security.c>
    SecFilterInheritance Off

    Results: could not access the dashboard at all and blog did not display any posts

    6. With Safari and FF, I disabled all of my plugins, logged out, cleared browser caches and cookies, restarted browsers and tried again. Results: no change

    7. In FF, I turned off all add-ons in FF, logged out of FF, cleared browser cache and cookies, restarted browser and tried again. Results: no change

    8. Contacted A Small Orange Technical support and they went in and verified they they were unable to get the flash uploader either, and then did some snooping around and said that they could find no reported errors. They offered to make any changes to my account necessary, but said that I would have to get those changes from WordPress, and it would depend on the nature of the change as they would not make any change which would jeopardize others on the same server, which brings us to #9.

    9. Over 4 hours plowing through forum posts with every possible search term I could think of and the apparent result is that no one knows what is really causing this, or a real solution. A handful of solutions have apparently worked for a couple handfuls of people, but none of them have worked for everyone.

    10. This site offers a mod_security addition for the .htaccess file, but it is aimed at a different issue really, and I was wondering if there is another file other than async-upload.php that might possibly benefit from this addition to .htaccess?

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Any thought on this anyone?

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘2.7 to 2.8.2 no flash uploader in FF or Safari’ is closed to new replies.