Support » Alpha/Beta/RC » 2.7 RC1 and Windows Live Writer

  • I recently upgraded to 2.7 RC1. I have the latest version of Windows Live Writer which i use to post to my blog. When I setup my account in WLW initially for my blog, I get an error that the theme used for editing your weblog post could not be downloaded. I continue past that and it lets me edit a new post but my theme is not there. Just a white text window.

    I then try to save my test post. I get:
    An unexpected error has occurred while attempting to log in:
    Network connection error – Error attempting to connect to web log at:
    https://radialmonster.co/blog/xmlrpc.php
    The underlying connection was closed: an unexpected error occured on send

    I googled for the error and someone said to simply close out of WLW and go back in. Which of course didnt help. I googled again and found that someone said the prob was because it said https://www.radialmonster.com/blog/xmlrpc.php when it should not have said https. It should have said http. I deleted my blog account in WLW and reset it back up. I was sure to not type in https and to type in http. I still had the same error. So on a hunch i went in and edited xmlrpc.php in the root of my wordpress. I searched for https and changed 2 top instances of https to http. I saved my file and tried WLW and did not have the issue again. Also, if i delete my account in WLW and rest it back up it does download the theme correctly and my theme is shown on my window in WLW when making a post.

    The below 2 lines are where i changed https to http in xmlrpc.php

    line 1774
    $filename = preg_replace(‘#https?://.+?/#’, $_SERVER[‘DOCUMENT_ROOT’].’/’, $filename);

    and 1817
    $filename = preg_replace(‘#https?://.+?/#’, $_SERVER[‘DOCUMENT_ROOT’].’/’, $filename);

Viewing 16 replies (of 16 total)
  • Matt Harris

    (@matt-harris)

    I just installed Live Writer, and got this problem as well.

    I fixed it by doing the following:

    1) When I initially created the account, I used WordPress.com (as opposed to WordPress 2.2+). I changed the account setting to WordPress 2.2+

    2) I made sure that the path to my WordPress directory was correctly capitalized. The back-end host is Linux and is case sensitive.

    Either one or both of these changes fixed my problem.

Viewing 16 replies (of 16 total)
  • The topic ‘2.7 RC1 and Windows Live Writer’ is closed to new replies.