Support » Alpha/Beta/RC » 2.7 RC1 and Windows Live Writer

  • I recently upgraded to 2.7 RC1. I have the latest version of Windows Live Writer which i use to post to my blog. When I setup my account in WLW initially for my blog, I get an error that the theme used for editing your weblog post could not be downloaded. I continue past that and it lets me edit a new post but my theme is not there. Just a white text window.

    I then try to save my test post. I get:
    An unexpected error has occurred while attempting to log in:
    Network connection error – Error attempting to connect to web log at:
    The underlying connection was closed: an unexpected error occured on send

    I googled for the error and someone said to simply close out of WLW and go back in. Which of course didnt help. I googled again and found that someone said the prob was because it said when it should not have said https. It should have said http. I deleted my blog account in WLW and reset it back up. I was sure to not type in https and to type in http. I still had the same error. So on a hunch i went in and edited xmlrpc.php in the root of my wordpress. I searched for https and changed 2 top instances of https to http. I saved my file and tried WLW and did not have the issue again. Also, if i delete my account in WLW and rest it back up it does download the theme correctly and my theme is shown on my window in WLW when making a post.

    The below 2 lines are where i changed https to http in xmlrpc.php

    line 1774
    $filename = preg_replace(‘#https?://.+?/#’, $_SERVER[‘DOCUMENT_ROOT’].’/’, $filename);

    and 1817
    $filename = preg_replace(‘#https?://.+?/#’, $_SERVER[‘DOCUMENT_ROOT’].’/’, $filename);

Viewing 15 replies - 1 through 15 (of 16 total)
  • Is there anything else about your blog, server or setup that might have trigger the switch to https? I’ve been trying to re-create this problem using -trunk (bleeding edge 2.7) and have been unsuccessful so far.

    Thanks for your reply!
    I did not change a thing except modify the xmlrpc file. I am using RC1 and not the bleeding edge svn version.
    During the course of writing the above post I changed the file back to include the https so that I could write down all the errors. I recreated the issue just fine. I changed the file back after i was done and the problem went away.

    I am ok, my blog works and my live writer works. but it’s an odd thing to have to do. Just wanted to share in case anyone else had the issue. but if its a problem that needs to be resolved in the code then hope this helps some.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    That’s not a bug. Do you have https on your Settings->General screen? If so, then it will force https there too.

    No, under settings, general I have:
    WordPress address (URL) I have
    Blog address (URL) I have

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    What’s more, upon closer inspection, those two line you refer to only happen for the get and set Template functions. They don’t have anything to do with writing a post.

    Your changes don’t make any sense.

    Edit: Oh, I see. WLW downloads your template so it looks similar in the editor. Got it.

    The problem is that this line:
    $filename = preg_replace('#https?://.+?/#', $_SERVER['DOCUMENT_ROOT'].'/', $filename);

    Is correct. That question mark after the s in https makes it optional. So it should work just fine.

    In order to come up with the right fix we really need to be able reliably reproduce this problem.

    If you find any other details that might help I’m happy to get the problem tracked down.

    Oh I see. Well I will try some things and see if I can come up with any other clue then. I assumed this was the cause as when I performed the steps mentioned it seemed to work just fine. But if I find any other pattern to it I will certainly update. Thank you!

    I also am having this issue. Tried the above and deleted the “s” and even deleted my live writer blog account and started again.

    I can upload a post to live writer, edit and publish but I get this “Network connection error” as above. The post gets published and looks as intended but I still have this error message displayed every time.

    I did not have a problem until I changed templates. Tried to revert back to old template but error appears again. Very annoying!!

    Happy to work with someone on this because it is driving me nuts!! It posts via Live Writer but I get this error message everytime which always puts the doubt in my mind whether it published ok.

    I’m getting the same problem, Windows Live Writer works perfect on previous versions of WordPress but not the latest, any ideas on a fix?

    My Error Message is:

    An unexpected error has occured while attemptime to log in:

    Network Connection Error – Error attempting to connect to blog at:

    The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure Channel.

    What’s the URL of your blog?

    I have the same error and it is with my blogs hosted on wordpress and on my own server?

    What’s are the URLs for the blogs that you are having problems with?



    Hi, I am having the same problem. The URL of my blog is I am willing to help in any way to get this fixed.



    Oh yes, and removing the ‘s’ in the ‘https’ did not help me.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘2.7 RC1 and Windows Live Writer’ is closed to new replies.