Support » Fixing WordPress » 2.7 Image Upload Not Working

  • Just installed 2.7 yesterday. When creating a new post I am clicking the image icon to select an image from my gallery or upload a new one. The image admin screen jumps out of WP altogether and it is page by itself.

    Anyone else have this happening? Can’t upload and insert an image at all. 🙁

Viewing 3 replies - 46 through 48 (of 48 total)
  • Hey eibhlin,

    Thank you for solving my problem with the image issue. I read your instructions and that helped me! http://www.flipstips.com

    First, I had to fix the problems created by rolling back to 2.6.5.

    2.6.5 files had changed the database Uploads path to the full path (myusername/root/domainname.com/wp-content/uploads/…) so I had to go into pHpMyAdmin and change it back to /wp-content/uploads in the Options section.

    My existing images reappeared on my website. Whew!

    But, retrying 2.7, I was still reaching the error message when I tried to upload new images through WordPress.

    An overnight conversation with tech support ensued, and they found the problem.

    In my case, the new (2.7) wp-content/uploads folder had automatically uploaded with CHMOD 777. Apparently, my hosting service (Hostgator) won’t allow 777, only 755.

    So, switching all folders back to CHMOD 755 solved the problem.

    salaknib

    (@salaknib)

    @euphonywho

    Changing the folder to wp-contents/images worked!!! thank you!

    I have been using 2.7 for awhile and had no problems with image uploads until today (Nov 8, 2009) After all the great suggestions provide here the only thing that worked was disabling my S3 plugin. Never used it anyway.

    Keep up the great work. I am avoiding 2.8 even though it is supposed to be bullet proof. Yeah, sure. And I am a internet millionaire.

    Rick

Viewing 3 replies - 46 through 48 (of 48 total)
  • The topic ‘2.7 Image Upload Not Working’ is closed to new replies.