Support » Fixing WordPress » 2.7 Image Upload Not Working

  • Just installed 2.7 yesterday. When creating a new post I am clicking the image icon to select an image from my gallery or upload a new one. The image admin screen jumps out of WP altogether and it is page by itself.

    Anyone else have this happening? Can’t upload and insert an image at all. 🙁

Viewing 15 replies - 16 through 30 (of 48 total)
  • For those with blank admin pages after media and image uploads – I disabled all plugins, and the re-enabled all except the WP-Amazon plugin. All working well!

    (I did just deactivate MT_Amazon initially, but that didn’t seem to solve it – heance the drastic Disable All!)

    I’ve tried chmoding the upload directory (and subs) as well as deactivating all plugins and am still getting the problem where I can’t upload media, images in particular. Anyone have any other bright ideas?

    having the same problems here:
    – all plugins disabled
    – permissions on uploads dir seem to be okay

    still, image uploading fails to actually upload the image into the uploads dir

    help?

    I had the same problem with permissions on uploads after upgrading from 2.7 beta to 2.7. I got an error message telling that it couldn’t upload to /wp-content/uploads/2008/12/ because permission was denied. All folders was there, the folders “2008” and “12” was created by WP and given permission 777. However, I did not have permission to change the permission on these folders myself. I then delete those two and created them again with permission 777 and everything worked.
    I hope this gets solved however, since I don’t want to do this manually for every month of the year.

    @eibhlin and all those who are facing the following error
    “unable to create directory XXX is it a parent directory writable by server ?”

    i fixed it using the following solution,
    NO NEED FOR ANY CHMOD to 777
    just edit the store uploads directory in settings>miscellaneous to the default value (shown there)

    A more detailed solution is given here, how to solve image upload error in wordpress 2.7

    hope this helps guys there

    I found a simple fix here

    jeffs

    but now I have a report that the image still does not show in the RSS feeds (sigh)

    I don’t know if this is truly related or not, but I was having the same problem. I wasn’t using the WP Amazon plugin, but I did still have the Automatic Upgrade plugin activated, which might have been a conflict with WP’s new automatic upgrade feature. I disabled the plugin and it seems to be working fairly well.

    Thanks for the help on this one! It was driving me crazy.

    I deactivated the Amazon plugin and everything with my images returned to normal!

    If only I could get my tags to start working again…

    Thanks folks! You gave me the idea to do the same. I disabled all my active plugins and started to reactivate them one-by-one!

    CommentLv is another plugin that stops the image uploader from working also!

    Thank you so much! Next time, I’ll try disabling the plugins like that again! Lesson learned.

    Prasad Thombre

    (@prasadthombre)

    I tried every possible way to get this image upload error resolved includes…

    1) CHMOD 777
    2) De-activating all plugins
    3) tried path other than default wp-content/uploads to wp-content/userdata
    4) edited database table entry…
    5) Tried Installing fresh copy of WordPress 2.7
    6) using .htaccess file

    all this wasted… and i am still facing issues with media/photo uploads.

    Waiting for some accurate solution…

    Team
    MyLoversWish.com

    Samuel Jesse

    (@samueljesse)

    It worked for me, I manually mad a new folder called “uploads” and then changed the permissions higher and higher until it worked. It may have been 777 in the end…

    Then I tried uploading again and presto! Perhaps those who are changing permissions and not getting results on 2.7 are not manually creating the uploads folder to start with?

    harjeetsg

    (@harjeetsg)

    Solution for the error

    Step 1: Log into your admin panel

    Step 2: Go to Settings>>Miscellaneous

    You will see two options,

    Store uploads in this folder
    Full URL path to files
    Most probably you will see

    /home/.boogee/XXXXX/XXXXXXX/wp-content/uploads

    in the first field.

    Step 3: Edit that to just

    wp-contents/uploads

    PS: Please take a backup of what you are editing, incase this trick didnt work, you can restore the old URL.

    This should do the trick.

    fredmiller

    (@fredmiller)

    Do you mean wp-content
    or
    wp-contents?

    krisdevito

    (@krisdevito)

    Thanks harjeetsg
    Your suggestion worked for me. The path was wp-content and I updated it to wp-content/uploads (although it says on the side that default is wp-content/uploads – I guess a mistake in 2.7) and it works when I use the browser uploader.
    Thanks so much I was really struggling with this.

Viewing 15 replies - 16 through 30 (of 48 total)
  • The topic ‘2.7 Image Upload Not Working’ is closed to new replies.