Support » Fixing WordPress » 2.7 Image Upload Not Working

  • Just installed 2.7 yesterday. When creating a new post I am clicking the image icon to select an image from my gallery or upload a new one. The image admin screen jumps out of WP altogether and it is page by itself.

    Anyone else have this happening? Can’t upload and insert an image at all. 🙁

Viewing 15 replies - 1 through 15 (of 48 total)
  • Thanks for asking that one! I’m having the same problem. It navigates away from the page and then when I try to use the browser upload, it uploads but clicking insert into post just gives me a blank page. Can’t even get back to the original post and when I do, image is not there anyway.

    I’m looking forward to the response on this! Thanks for asking!
    Debbie

    At least you’re able to get it uploaded all I get is “Missing a temporary folder.”

    I am having a similar problem. When I try to upload through the media library using browser, it appears to download (and there is no error message), but no images appear in the library.

    I am having a possibly related problem. It is trying to upload the images to a completely different domain on my server and I have no idea where it is getting this information from.

    Ditto for me (at first). Clicking the upload button took me to the Media Library after a short wait (as if something was being uploaded). Nothing was uploaded.

    Then I noticed my upload folder had 755 permissions and when I changed it to 777, the uploader worked and the image showed up in the library.

    Just did what pcmt suggested and no luck. Still getting the blank page after upload.

    Just create /tmp folder in your wordpress directory and it should be fine – works for me 🙂

    Okay I tried that too. No go. I keep clicking on the insert into post and I get a page like this:
    http://mysite.com/wp-admin/media-upload.php?type=image&tab=library&post_id=519

    That is totally blank! Nothing, zip, zero, nada.

    got the same problem. Had to install 2.6.5 to post with photos. Can’t wait to see the solution on this one.

    I had to disable my wp-amazon plugin, because it was affecting the java scripts on the dashboard.

    I tried changing the permissions on the upload file,but it didn’t help. The photos upload, but they won’t display in the post. I get a box with a broken icon in it. This also happened with wp 2.5.1, I think. There was a plug-in that fixed the problem, but I had to take it off because it was messing up my blogs. My webhosting service said it was causing an error of some kind. Why don’t they check to see if you can upload pictures before they release a new version?

    I am facing the same issues with my website after upgrading to 2.7 Please help me to resolve this.

    Error: Permission Denied.

    …/media-upload.php?

    i tried everything… i also tried changing media upload folder path… but nothing worked….

    Please sugggest.

    Me too. Mine is telling me
    “Unable to create directory /wp-content/uploads/2008/12. Is its parent directory writable by the server?”

    The first odd note was that there’s no button for me to click for Flash upload. So, I’m using the browser upload… or trying to, anyway.

    I checked permissions and changed everything to 777, up through wp-contents.

    No luck.

    I manually created the 2008/12/ directory with CHMOD 777. That didn’t help, either.

    I tried manually uploading the image to my 2008/11/ directory. (Hey, it was worth a try.) The Media Files don’t show the image.

    I tried uploading the image through the Media Files tab, not through the Post. I didn’t get an error message, but after it appeared to upload, the image didn’t show up in my files. (I also checked through FTP, just in case.)

    I deactivated every plugin. Nope, it still won’t upload images.

    The site was working fine before the 2.7 upgrade. I hadn’t uploaded new images since November, and I can still use the old images but I can’t add new ones.

    Weirdly, several of my other WP 2.7 upgrades are working fine on the same server (HostGator) with the same theme (Branford Magazine) and same plugins.

    Any other ideas?

    30 MINUTES LATER: I manually upgraded 2.7, just to be sure it’s working. The Flash button has returned to my “Add an Image” screen in Post. However, I’m still unable to upload images. Same error message, no matter what I try. Help…?

    After my previous post, I tried the .htaccess file addition in wp-admin. I’d used that with success at WP 2.5.

    That didn’t help 2.7.

    I also tried the fixes recommended at the Installations section of the forum. I double-checked my swfupload folder in wp-admin/js and I cleared my cache.

    Still no luck. I’m going back to 2.6.5 for now.

    UPDATE: Now it’s not working in 2.6.5, either. I’m contacting my hosting service in case I’ve mangled the database.

    Solved!

    First, I had to fix the problems created by rolling back to 2.6.5.

    2.6.5 files had changed the database Uploads path to the full path (myusername/root/domainname.com/wp-content/uploads/…) so I had to go into pHpMyAdmin and change it back to /wp-content/uploads in the Options section.

    My existing images reappeared on my website. Whew!

    But, retrying 2.7, I was still reaching the error message when I tried to upload new images through WordPress.

    An overnight conversation with tech support ensued, and they found the problem.

    In my case, the new (2.7) wp-content/uploads folder had automatically uploaded with CHMOD 777. Apparently, my hosting service (Hostgator) won’t allow 777, only 755.

    So, switching all folders back to CHMOD 755 solved the problem.

Viewing 15 replies - 1 through 15 (of 48 total)
  • The topic ‘2.7 Image Upload Not Working’ is closed to new replies.