WordPress.org

Support

Support » How-To and Troubleshooting » 2.7 has not resolved WP image upload problems

2.7 has not resolved WP image upload problems

  • I just upgraded to 2.7. The upload was easy. The new interface looks interesting.

    However, I’m MOST disappointed to see the image upload problem is not resolved. I’m managing 4-5 blogs, ranging in versions from 2.3 to 2.7. Only the 2.3 is without image upload problems. The others I have resolved only by changing the security permissions to 777, which I really hate doing.

    Now, with 2.7 even that is not working. What to do? PLEASE?!!! Why must this continuously be an issue?

    BTW, I am both a MAC and PC user, also a Safari, Firefox, and I.E. I have problems with all of them.

Viewing 15 replies - 1 through 15 (of 32 total)
  • I can’t upload anything without getting “Missing a temporary folder.”

    Any response on this issue? Can you direct me to a thread that has a resolution? Perhaps a sticky could be made? Please!!!

    I’m getting the same old error message as in previous versions:

    Unable to create directory /UnixWeb/home/l/…….Is its parent directory writable by the server?

    Use your FTP client to change the file permissions of wp-content, NOT wp-content/upload to 777.

    I’ve reuploaded all the new files, deactivated all my plugins, double checked my settings and file permissions, and still…I get the same error that adunate is getting.

    Unable to create directory /home/.franc/mellysue/romancefan.org/wp-content/uploads/2009/01. Is its parent directory writable by the server?

    I look at my settings and discovered that don’t have the first forward slash, that’s why changing file permissions to 777 works for me and some people.

    1. Login to your admin page
    2. Go to settings
    3. Go to Miscellaneous
    4. Find Store uploads in this folder
    5. if it says “/wp-content/uploads” just remove the first forward slash so that it reads plain ol: wp-content/uploads

    Hey all!!! I fixed the problem by doing the simple wp-content/uploads fix.

    BUT……

    …. the next time I tried to upload an image it wouldn’t wrap the text around it. I tried another image – same thing. I checked all the code etc and there was no reason for it not to wrap the text.

    I checked in my control panel and discovered WordPress had created a folder named for the year 2004 and stuck my newly uploaded pics in there!!!! What the?? Not sure how that relates to the thing not wrapping text but it was a wierd thing anyway.

    Not only that, but only one of the images was in there. I still cant find any of the other images I uploaded.

    In addition, I can never get the media manager to show indicate any more than ONE image is contained in the uploads.

    THe whole thing has driven me completely insane so I suggest anyone else still having problems do what I’ve just done. Install something like Nextgen Gallery and ditch the core image manager altogether. Once I started using NextGen I had no problems and all the images are sitting properly in wrapped text.

    What a waste of many MANY hours of my time.

    Ridiculous really but that’s my best solution for all the issues with the core image manager: Don’t use it.

    >>the next time I tried to upload an image it wouldn’t wrap the text around it. I tried another image – same thing. I checked all the code etc and there was no reason for it not to wrap the text.<<

    How about the stylesheet? Do you have floating set for “alignleft” and “alignright”?

    >>I checked in my control panel and discovered WordPress had created a folder named for the year 2004 and stuck my newly uploaded pics in there!!!! What the??<<

    That’s done from your Settings panel, under “Miscellaneous.” If you don’t want it to do that, then make sure “Organize my uploads into month- and year-based folders” is unchecked.

    As for the rest, have you FTPed into your server to see if the images are actually there? Are you sure the files aren’t corrupted?

    when i try to upload a photo into wordpress, i get an error saying “http error.” after that, it shows up in my gallery anyway. when i then try to insert it into a post, i can’t change the size to thumbnail or anything else. it just comes up as a large image. help?

    i also can’t seem to get the captions to come up when i insert a photo into a post. suggestions?

    hello all,

    I have the same problem too, I just tried uploading an image to my weblog and it shows this below:

    pimg height=337 alt=Water lilies src=http://nairabytes.com/wp-content/uploads/2009/01/waterlilies.jpg width=450 //p
    pnbsp;/p
    pLorem Ipsum is simply dummy text of the printing and typesetting

    I checked via FTp and yes the image/s are there, but it doesnt display on the weblog.

    pls help

    doodlebee

    Thanks for your response and ideas BUT

    1. Yes I know it automatically sets year etc BUT this is 2009 NOT 2004. It suddenly created a folder for a year that has passed ages ago. That is bizarre to say the least.

    2. None of the themes I have on these sites have css that effects this but I think this was my mistake and it’s possibly the NextGen Gallery that’s causing problems with alignment. I will check there for support.

    3. As I said, I checked in the control panel and several images were missing. I also checked via ftp – again, no images.

    They’re not corrupted. We’re talking about a lot of images in different websites. They all worked fine on my previous installations using a different cms.

    But thanks again for your suggestions! I appreciate the feedback.

    I just went into a website to edit a page and discovered the image I had uploaded there a while ago has disappeared. This time it IS on the server and the url to it in the code is correct. I tried setting everything to 777 EXCEPT the /wp_content folder and that didn’t help. When I open the media manager several files that are on the server don’t appear there.

    The next thing I’m going to try is setting up my own images folder and using the option to get the image from a url – don’t know if that will make any difference tho LOL

    I bet there is something really obvious that I’m missing 🙂

    Me again – this might help others.

    I found the reason for ONE of my image handling problems:

    The disappearing images and similar issues were actually related to a conflict with a theme I’m using on one of my sites – which stores uploaded images in it’s own image folder.

    The system was getting confused and dropping files all over the place. My fault for not setting things properly.

    the problem I am having is that I am using the browser uploader and the images upload to the site, but:

    1) I can only upload full size images. Options for thumbs and medium etc will not function.

    2) When you hover over the image he cursor does not change to a little hand put stays and arrow. Must open menu box and select choose image. this is only for images I have downloaded since installing 2.7.

    3) My lightbox media viewer will not work on any images installed after the upgrade.

    This is a real hassle and I would even like to go back to 2.6 and have my files backed up but I am not skilled enough to do all that.

    If this matter is ever resolved with a patch or upgrade I will never upgrade again. My problem and all the others on this page seem like such obvious issues to resolve before releasing an upgrade.

    There seems to be no one solution and people with moderate skills are left totally int he dark when we read people at higher levels struggling day after day.

    Is anyone having the same or similar issues? Not just with the uploader but with lightbox type programs not working any longer or images installed after 2.7 upgrade not responding when hovered over?

    Bill
    uranium.cafe@yahoo.com

    Hi again and sorry if my last comment was so sour. I have been here all day and tried all I can try and I suppose I am just tired, but it looks like some people have it worse than me so sorry.

    There is one nail in my coffin I had not noticed until now and that is my flash uploaded does not work at all. I typically use the browser uploader and have the new flash one deactivated as the browser is a little faster on my system. but the flash uploader was an option until 2.7.

    Does anyone else have this issue as well suddenly?

    I think my philosophy right now is misery loves company.

    Thanks
    Bill
    uranium.cafe@yahoo.com

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘2.7 has not resolved WP image upload problems’ is closed to new replies.
Skip to toolbar