Support » Installation » [Resolved] 2.7 Flash Uploader Problem

[Resolved] 2.7 Flash Uploader Problem

  • Just upgraded all wordpress versions to 2.7. Unfotunately there’s one problem, no flash uploader. Uploading 1 image at a time sucks.

    Here’s the details:
    + Erased cache and cookies
    + installed flash player 10
    + tried on both safari 3.1.2 and firefox 3.1b2 browsers
    + only allowed browser uploads

    Screenshot Below

    any help would be greatly appreciated.

Viewing 15 replies - 16 through 30 (of 48 total)
  • You’re welcome! Glad it worked.

    I was going to try fryewiles’ solution, and when I opened my site with my FTP client, I noticed that a file called “swfupload.swf” was not in the /wp-includes/js/swfupload/ directory (everything else in that folder was the same on my server, however). I copied only the “swfupload.swf” file to my site, and now everything’s aces again!

    Thanks, everyone (especially fryewiles).


    Yeah, that fixed it for me too. I upgraded using the automatic upgrade plugin and for some reason this file was missed. A manual upload of “swfupload.swf” fixed it right up.

    reading all the above tips (great tips!), I downloaded the complete 2.7 version and checked on my server. Actually a second file was missing that nobody mentions: swfupload_f9.swf. I also uploaded it. Any comments on this? I also used the Automatic Upgrade plugin, so how is it possible those files were not uploaded?

    happy to report that after uploading the two missing files, it WORKS! I am using MAC OSX and FF 3.0.4. Thanks to all!

    It worked for me too. Thanks fryewiles

    I used the automatic upgrade and it missed swfupload.swf for me too. That fixed the flash problem but it didn’t fix the other problem I have. I cannot choose a different size for images. It forces me to choose full size. I cannot change to medium, small, or thumbnail.

    Is anyone else experiencing that problem?

    BTW, I am on OSX and WP 2.7 is working pretty well all in all.

    Now I get to finish my WWI and WWII naval post on my blog the CWF Game Cast.

    I found the issue was mod_security in my case. Still working on tracking down the exact rule.

    I don’t find that this works. The button is there, but clicking on it does absolutely nothing. It just sits there.

    However, I did find that the file mentioned above was missing. I added, cleared cache, etc etc … still nothing.

    This is still 2.6.5. I don’t want to even think about upgrading to 2.7 until most of these big bugs are worked out.

    Edit: Erp! IE7/FF3 and Vista (if that makes a difference)

    Wow, same issue here. I can see the upload files button, I can upload an image but I can’t choose the size. Have you found a fix for that yet?

    I found the issue was mod_security in my case. Still working on tracking down the exact rule.

    What was the mod_security a fix for? The original problem or being unable to set the size of the images? And, if it is for the inability to set the size, how do you go about editing or fixing that?

    The button is there, but clicking on it does absolutely nothing. It just sits there.

    This is still 2.6.5.

    The version of the swfupload in 2.6.5 did not work with Flash 10. 2.7 has the workaround for that.

    Same here. Reuploaded and checked the browser cache and permissions. Still only a “Select files” button. Using Flash 10. WP 2.7, Firefox 3.0.4 and Safari.

    Reinstalled with the latest Flash. No luck.

    Could it have something to do with the size of the image? Perhaps when I tried it out before, it was with a smaller image and therefore, the only size option available was FULL SIZE as it was already close to or smaller than the THUMBNAIL size. I tried it with a little bit larger image and I had the thumbnail and medium and fullsize option availabe but not large. So, it may be working, it just doesn’t give you any option if that particular option doesn’t make sense.

    Hi, I have the same problem – clicking on click to upload files in flash uploader does not do anything. I have checked directory /wp-includes/js/swfupload/ and it has only swfupload_f9.swf file, does not have swfupload.swf. I have downloaded WP installation and it does not have swfupload.swf either!! Where can I get this file?
    Please help!!
    thanks, Irina

Viewing 15 replies - 16 through 30 (of 48 total)
  • The topic ‘[Resolved] 2.7 Flash Uploader Problem’ is closed to new replies.
Skip to toolbar