WordPress.org

Support

Support » How-To and Troubleshooting » 2.7 Dashboard: RSS Feed not loading

2.7 Dashboard: RSS Feed not loading

  • Since upgrading to WP 2.7, the Other WordPress News RSS feed (widget) in the Admin Dashboard refuses to load.

    When checking the widget’s Configure link, the default http://planet.wordpress.org/feed/ url is replaced with a Error: could not find an RSS or ATOM feed at that URL. error message. The planet.wordpress.org feed loads fine directly in my browser, and I can load other feeds in that same Other WordPress News widget. Other Dashboard feeds continue to work as well. But whenever trying to use the feed from planet.wordpress.org (and variations of that feed’s url), it doesn’t work. The feed worked fine in previous versions of WP.

    Any ideas?

    Appreciate any help/info.

Viewing 15 replies - 16 through 30 (of 52 total)
  • CesarQuinterox
    Member

    @cesarquinterox

    I found I had the same problem last night. I agree it might be the new WP version. However I also noticed that if you turn on WP-Cache and you go to your RSS link you get XML output but without the standard feed format. After refreshing, it fixes itself. The two things are totally unrelated but somehow work (?). It really confuses me but at least gets your feeds kinda working. Anyone have any idea why this is?

    CesarQuinterox
    Member

    @cesarquinterox

    Another silly thing. I found the error occurred even less with the super cache. Makes no sense to me but I thought people would like to know.

    RoarinRow
    Member

    @roarinrow

    Using the above feed URLs don’t work for me. When I submit the URLs I still get nothing. When I go in to look at the URL I see this – Error: could not find an RSS or ATOM feed at that URL.

    grassrootspa
    Member

    @grassrootspa

    Frenetik, you are my hero.

    WORKED!!!

    Same problem, no RSS feed exists any more? And Frenetik just pointed to a different URL – not really sure how to go about fixing this, yet. Also don’t see the option to disable caching anywhere in my dashboard?

    NuAngel

    I started another thread earlier — not only am I not getting any dashboard feed, my del.icio.us widget and flickr widget feeds have stopped working and I can no longer automatic update plugins. It all seems to have started yesterday. I have cleared my cache, I think.

    Something has gone wonky.

    Some of your plugins simply need to be moved to the root “wp-content” folder, rather than in subfolders OF wp-content. That might help some of those. Though I still can’t get “TwitterUpdater” to work, either.

    But still, the RSS is my biggest issue at this time. 🙁 It’s not a 3rd party plugin, it’s part of WordPress.

    NuAngel

    I don’t think that’s it. I deactivated everything but :

    Akismet
    Bad Behavior
    del.icio.us for WordPress
    Executable PHP widget
    flickrRSS
    My Custom Widgets
    runPHP

    I still don’t have any dashboard feeds and the del.icio.us and flickr feeds in my sidebar (http://jlynne.exit-23.net) are coming up empty.

    However, the deactivation of Google XML Sitemaps did correct the issue with the built-in auto-upgrade.

    Other things I deactivated:

    Amazon Reloaded for WordPress
    Amazon Showcase
    Angsuman’s Feed Copyrighter
    Autorelated
    Blog Copyright
    commentluv
    Contact Form ][
    DashBar
    Do Follow
    Post-Plugin Library
    Similar Posts
    Simple Trackback Validation
    Subscribe me
    Subscribe To Comments
    Tag Managing Thing
    Tiny Link
    TinyMCE Advanced
    Trackback List
    WP Super Cache

    OK This definitely has something to do with the embedded WP rss functionality. I may not be familiar with the inner-workings of WP but I’ve looked at everything else and if the dashboard RSS doesn’t work and the widget RSS isn’t working, that seems like 1+1=2 to me.

    worldview
    Member

    @worldview

    my issue is

    I op;en the config and submit ANY working feed url and click submit which produces he dreaded white page and does not update.

    I have the same issue. Tried adding the extra /feed/ but still getting the error message.Error: could not find an RSS or ATOM feed at that URL.
    Has anyone had a resolution to this issue?

    Thanks David

    I am in the same boat. My rss feed works fine, but my comments feed doesn’t work. Don’t know what to do. Can anyone help me?

    Kimberly
    http://blog.go-for-your-dream.com

    I have the same problem…

    well… everyone with the same problem and nobody appears to fix this 🙂

    michelle3duk
    Member

    @michelle3duk

    I have this problem too.
    RSS feed not working.

    I’m fairly new to blogging, just moved mine from wordpress.com.
    url is: http://www.michelle-reader.co.uk/Blog
    I spent ages yesterday taking all the blank spaces from beginning and end of my php files, but to no avail…

    I’m using inove theme – the rss-related code in sidebar.php doesn’t look like the support documentation example, but I’m not sure if or how I can change it. Sounds like that’s not the problem anyway.

    Any solutions yet?
    Michelle

    michelle3duk
    Member

    @michelle3duk

    Hello again,

    Searched around a bit more and found this:
    http://www.brightcherry.co.uk/scribbles/2008/07/22/wordpress-rss-feed-is-empty-bug-fix/

    This solution worked for me – it involves a simple change to rewrite.php, and reinstall of 2.7, to allow for the fact that my blog is in a subdirectory of my website.

    RSS now up and running – hooray!

    Michelle

Viewing 15 replies - 16 through 30 (of 52 total)
  • The topic ‘2.7 Dashboard: RSS Feed not loading’ is closed to new replies.