2.7 Dashboard: RSS Feed not loading (53 posts)

  1. michelle3duk
    Posted 7 years ago #

    Hello again,

    Searched around a bit more and found this:

    This solution worked for me - it involves a simple change to rewrite.php, and reinstall of 2.7, to allow for the fact that my blog is in a subdirectory of my website.

    RSS now up and running - hooray!


  2. ageorgegal
    Posted 7 years ago #

    Michelle, can you tell me exactly whre to make the change and what the change is?

    The text in the post your linked to is cut off and impossible to read fully.


  3. michelle3duk
    Posted 7 years ago #


    Download WordPress 2.7.
    In file rewrite.php, which is in folder wp-includes, find the following script and change it


    $default_feeds = array(

    '.*wp-atom.php$'=>$this->index .'?feed=atom',

    '.*wp-rdf.php$' => $this->index .'?feed=rdf',

    '.*wp-rss.php$' => $this->index .'?feed=rss',

    '.*wp-rss2.php$' => $this->index .'?feed=rss2',

    '.*wp-feed.php$' => $this->index .'?feed=feed',

    '.*wp-commentsrss2.php$' => $this->index . '?feed=rss2&withcomments=1');



    $default_feeds = array(

    '.*/wp-atom.php$'=>$this->index .'?feed=atom',

    '.*/wp-rdf.php$' => $this->index .'?feed=rdf',

    '.*/wp-rss.php$' => $this->index .'?feed=rss',

    '.*/wp-rss2.php$' => $this->index .'?feed=rss2',

    '.*/wp-feed.php$' => $this->index .'?feed=feed',

    '.*/wp-commentsrss2.php$' => $this->index . '?feed=rss2&withcomments=1');


    The only change was the forward slash (/) after the * on each line. See it? Not sure how to check what line it's on, but it's quie a long way into the file (Bright Cherry says it's 809-814).

    After saving that, I uploaded all the WordPress 2.7 files again (including the newly modified rewrite.php file). I didn't re-upload wp-content folder though, as it would have affected my plugins I think.

    Then run /wp-admin/upgrade.php

    It might not seem to have worked straight away, so keep checking for a little while before you look for a different solution.

    Hope that helps,

  4. ageorgegal
    Posted 7 years ago #

    Thanks Michelle, you're great!

    I am sure that will help others.

    An additional solution I found was this:

    I was able to resolve this error with help from my host Bluehost (I think their customer service is great!):

    Disable all of your plugins and reactivate them one by one. That way you will see which plugin is causing the problem.


  5. skitzarella
    Posted 7 years ago #

    This worked for me- http://core.trac.wordpress.org/ticket/8784
    When you click cannonical.php the download for it is at the very bottom of the page.
    Also When he says to add is_feed() to line 42 don't it's already in the download. So don't worry about it.

    This works with 7.2.1 too.

    Don't forget to clear your browsers cache when your done or it will keep loading the old version for a while.

  6. jonboldendesign
    Posted 7 years ago #

    I am having the same issue. I tried Skitzarella's cannonical.php solution and michelle's rewrite.php solution. Neither of which worked for me.

    I can't get Flickrss or any equivalent to work. I get an error when it tries to connect to a feed. Same with the dashboard news feeds. I get a white screen when trying to configure. Any other possibilities so far?

  7. skitzarella
    Posted 7 years ago #

    Another thing I noticed was every time I turned on my feedburner plugin the RSS on my blog stopped working.This started happening after I upgraded wordpress. I ended up uninstalling my feedburner plugin. And everything has been working fine.

  8. ftv3000
    Posted 7 years ago #

    Another solution that worked for me:

    Go to Settings>Permalinks and click in Save Changes

    Hope this work for somebody else;)

  9. jonboldendesign
    Posted 7 years ago #

    In response to my issue, our PHP server (on gentoo) doesn't install XML, but my friend figured it out. So maybe if nothing else is working (for example NO XML FEEDS work) then it might be your PHP server. Mine was on a linux server. I know nothing about that stuff. It helps to be friend with awesome developers :-)

  10. Saurus
    Posted 7 years ago #

    AGAIN ... Feedburner no longer exists as of last week. If you are using it your feed will not work.

  11. bl968
    Posted 7 years ago #

    Edit wp-includes/rss.php

    go to line 657 or search for define('MAGPIE_FETCH_TIME_OUT', 2); // 2 second timeout

    change it to a higher number I used 10 as recommended in another post. Problem solved.

  12. martianrobot
    Posted 7 years ago #

    Several people seem to have inadvertantly hijacked this thread with discussions regarding different issues... and people seem to be posting solutions to those instead of that posed by the original poster and confusing the issue!

    To clarify: this thread is not about problems with your blog outputting an RSS feed of the content you have written, but with problems associated with the two panels in the admin Dashboard of WordPress 2.7.1 not displaying the (otherwise working) RSS feeds from WordPress. These are the WordPress Development Blog and Other WordPress News panels, both of which are reporting an error that there is no feed at that feed address.

    I've tried configuring other working feeds but the panels still spit out the error.

    Having read through all the postings here I'm still none the wiser, and the one relevant support ticket that someone linked to only sorts out the issue of how the error is reported, rather than the error itself. And I tried that out and it doesn't help a bit!

    Sorry to get stroppy, but I'm keen to get this working as I want to re-configure one of these Dashboard panels to display an RSS feed of a 'hidden' category of the actual WordPress blog that it is the Dashboard for, one that is only meant to be viewed by our 10 blog authors when they log in.

    (Just in case you are wondering about how I've hidden the category, I have produced a theme from scratch that has its 10 publicly viewable main category links hardcoded as large graphical buttons in a grid on the homepage, and all the pages as hardcoded links across the top. Blog authors can only post to their assigned category, thanks to the 'Bind user to category' plugin)

    EDIT.... I'm now starting to think it might actually be a webhost settings issue as I have just tested a mirror install on my personal space at another host and the RSS in the panels works fine there. Perhaps I need to speak to my organisation's web host admin!

  13. propower
    Posted 7 years ago #

    Hey gang, we can add another one to the list, my rss is not functional either. The thing is most of the plugins I have installed are not functioning properly either and I am wondering if it is because I automatically had wp-2.7.1 installed through my host(any thoughts on this are appreciated). As for the rss, I will attempt using the above url's first and let everyone know if they worked in my case or not.

    One thing is certain- what was suppose to be easy has become a very frustrating experience.

    Best of luck all...

  14. Romik84
    Posted 7 years ago #

    It's really sad here is no one real solution yet. I have also got this error when I copied the same files from one server to another one. It's frustrating when someone has a blog based on the feeds. When will we get real answer how to fix this? Is it a webhost bug? Let's hope!

  15. noelinfo
    Posted 7 years ago #

    Hi everyone:

    I had the same problem. So I downloaded the 2.7.1 file... opened it... uploade the wp_admin... put this url in:
    http://planet.wordpress.org/?feed=rss2 and now it works...

    hope this solves your problem... if it does, wp should install a script that auto reinstalls the wp_admin file every time a plugin is installed.

    of coarse it is to soon to tell as I get this at:
    http://www.yourtrafficmanager.com and it says this...
    An error has occurred; the feed is probably down. Try again later.

    but the rss url is still there and no error message

    good luck...

  16. noelinfo
    Posted 7 years ago #

    tried these two urls

    and got the white page... had to put this one back in...

    and it's still working...

    looking for a more reliable feed...

  17. noelinfo
    Posted 7 years ago #

    I tried this url:
    http://www.improvingtheweb.com/feed/ and it works great with no problems...

    now I have my original rss and the one above working with no problems...

    just had to replace the wp-admin folder....

  18. noelinfo
    Posted 7 years ago #

    on last point to make...

    everytime I update the theme widgets I have to reinstall the wp-admin...

    wp listen up... This is getting old... auto upgrade the wp-admin when the theme widgets are updated... lol

  19. L S
    Posted 7 years ago #


    Thank you for posting all this. Since you seem like a really nice guy, can I ask: could you please provide the step-by-step on reinstalling the wp-admin? I don't even remember where this wretched little bugger lives.

    I would never have dreamed that anything as clunky and fractured as WordPress would ever come into such wide use.

    "Short description: WordPress is a blogging software with a focus on ease of use, elegance, performance, and standards with a huge selection of themes and plugins."

    BWAAaaaaaaHAAAAAAhaaaaaaaaaHAAAAAAAA, she says, losing it completely after a day of staring at arcane bits of unintelligible gibberish and visiting 16,000 different sites.

  20. noelinfo
    Posted 7 years ago #

    L S

    The upgrade option is under Tools in your blog dashboard. It is a good idea to keep current with new WP releases as they fix security vulnerabilities also.

    If this doesn't work you can download 2.7.1 at http://wordpress.org/download/ ... you can then upload the files via your domain control panel or with an ftp program.

    Unzip the files and upload them via ftp to the directory or folder on your domain that your wordpress is located, but before you do this... check to make sure the quicktags.js located in the \wordpress\wp-includes\js doesn't have 0 for the file size. It should read... size 16.5 kbs.

    Having problem with download of ver 2.7.1 - everything unzips fine EXCEPT quicktags.js. The solution is to download the quicktags.js which is loacated in \wordpress\wp-includes\js before you upload the files.

    This will replace the quicktags.js which reads 0 kbs with the new downloaded quicktags.js which is 16.5 kbs as stated above.

    For some unknown reason all the plugins do not work toggether. Some times when you activate a plugin, the plugin on the plugin page disappear.

    If you have problems with your plugins page disappearing when your logged into your dashboard, you can fix this by removing the last widget plugin via your domain login by clicking on your file manager.

    NOTE:[[Just remember the plugin you activated before the plugins disappeared. This will make it easier to delete this plugin to bring back the plugin list on your plugin page.]]

    On the left site menu, scroll down to public_html and click on the folder and scroll down to the folder where your wordpress is loacated.

    Click the folder icon and it will show the folders for your wordpress blog. Now click on the wp-content icon and then click on the word plugins. Now all your plugins will be in the right side window. Click or check the plugin you need to remove and at the top of the page click delete. Now the plugin is deleted and the plugins in your dashboard should be back.

    Good Luck... Steve... Owner Your Traffic Manager dot com http://yourtrafficmanager.com

  21. L S
    Posted 7 years ago #

    Steve, thanks so much.

    Very shortly after my previous post here, I noticed there was an upgrade to 2.7.1. I clicked on the upgrade link and it worked. After a reboot I was suddenly able to get RSS feeds to 'take' - mostly, not 100% of the time.

    Have been meaning to get back here and post that that was the solution, at least for me.

    I'll be copying your advice above and saving it for reference.

    There's still an issue that sometimes, without warning results in this error message:
    Warning: Attempt to assign property of non-object in /home/--username--/public_html/wp-includes/rss.php on line 449
    This happened yesterday with a feed that was previously working fine.

    Because it displays the blog owner's webhost username, it's a security risk - I have no idea how many hours my webhost username was out there for the world to see.

    See post on this subject here:

    Regards, L

  22. gfyd
    Posted 7 years ago #


    Still no luck for me with my Comments RSS feed. My RSS is fine, problem is with the comments feed only. Cannot get it to display the comments in the feed in either FF or IE.

    Here is what is in my sidebar.php

  23. " title="<?php _e('The latest comments to all posts in RSS'); ?>"><?php _e('Comments <abbr title="Really Simple Syndication">RSS</abbr>'); ?>
  24. Here is what is in my footer.php

    " title="<?php _e('The latest comments to all posts in RSS'); ?>" class="rss">Comments <?php _e('<abbr title="Really Simple Syndication">RSS</abbr>'); ?>

    My blog is here...


    Any help would be deeply appreciated!


  • gfyd
    Posted 7 years ago #

    See if I can get this right this time so it's not a link...

    Comments RSS feed still not working. RSS feed is fine.

    Here is what I have in sidebar.php

    <>a href="<?php bloginfo('comments_rss2_url'); ?>" title="<?php _e('The latest comments to all posts in RSS'); ?>"><?php _e('Comments <abbr title="Really Simple Syndication">RSS</abbr>'); ?> <>

    and in footer.php

    <>a href="<?php bloginfo('comments_rss2_url'); ?>" title="<?php _e('The latest comments to all posts in RSS'); ?>" class="rss">Comments <?php _e('<abbr title="Really Simple Syndication">RSS</abbr>'); ?><>

    My blog is here...


    Thanks, again.

  • 12

    Topic Closed

    This topic has been closed to new replies.

    About this Topic