Support » Fixing WordPress » 2.7 Can no longer view ‘visual’ on posts – html only

  • I searched around and saw that this happened before 2.7 but that isn’t the case for me.

    When I click “edit” on a post it will be in html mode. When I click on “visual” all of the text will disappear. I can click and drag and see that the text is still there but it remains in html mode.

    Again I see there are similar issues to this pre-2.7 but nothing exaxtly like this, and this only started happening today after I upgraded.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator Andrew Ozz

    (@azaozz)


    Sounds like your browser is still trying to use the old js from cache. Can you try another browser/computer to see if it works ok?

    same problem here !
    i’m using opera and have the same problem .

    either it’s the cache problem or browser problem.

    it worked fine in firefox.

    I get this from Chrome, IE, Safari, and FF. When I add or edit posts, I’m stuck in HTML edit mode with no graphics to add media, video, etc, nor does the tab for visual appears. It was this way on 2.6.5 and now on 2.7.

    Any ideas?

    2.6.5 was perfectly fine !!
    2.7 has a lot of problems.

    I’m having this same problem, in Firefox, and I’ve cleared my cache. I just tried it in IE and it does the same thing. The text is there, and I can see it if I highlight it, so it appears that the text color in the Visual Editing box is set to white, on a white background. Obviously, that’s problematic. I could be wrong, but that’s my understanding of it. However, I have no idea on how to fix it. I tried changing the color scheme of the admin and it didn’t have any effect (on the text color issue, that is).

    If you have cleared the cache and it is still acting up. It is most likely a plugin related issue. I had the same problem with an older version of Ninja Affiliate plugin.

    Try turning off all you plugin, then turn them on one at a time and see if the problem is cleared up. You might have to clear you cache after each turn on to check correctly.

    If you find the plugin that is causing the problem look for an update.

    OH, I should have said make sure all your plugins are up to date.

    Moderator Andrew Ozz

    (@azaozz)


    Suppose you’ve checked and then unchecked the checkbox in your profile. Do you have a firewall/antivirus/proxy that is filtering Javascript out… Can you try another computer preferably on different Internet connection.

    FYI, thanks to the comments above about deactivating plugins (which I’d only partially done) to solve the problem, I did deactivate most of my plugins to the point where I had fixed the problem. Then I reactivated them one at a time, just like it was suggested, and found that RB Internal Links was the culprit. Definitely try this and see if it works for you!

    WP 2.7

    I have NO plugins enabled. In all four browsers, mentioned above, I get the same thing…NO ability to edit in ‘visual’ mode. No uploading images, media, nothing. Stuck in HTML mode.

    Same here. None of my browsers or computers work. I have no plugins activated. Very annoying.

    Moderator Andrew Ozz

    (@azaozz)


    Can you try the troubleshooting steps here and post any js errors you see if it still doesn’t work.

    Troubleshooting TinyMCE in WordPress 2.7

    I can’t even find where step one is. I must be blind.

    There’s no checkbox in my profile.

    Moderator Andrew Ozz

    (@azaozz)


    This usually means that the editor’s files are missing. Perhaps try deleting wp-admin and wp-includes and upload fresh copies.

    I’m completely stumped. I bombed my database (deleted), reinstalled wordpress 2.6.5 and my visual editor is still gone. Base install.

    What in the!!!!!!!

    I started over.

    Installed a brand spankin new fresh as can be blog using 2.7. Copied my custom theme over, uploaded plugins…got my visuals back. Game on!

    Bummer the upgrade process totally barfed though.

    HOPEFULLY, the ‘automagic’ upgrade process built into 2.7 will not cause these wonky problems.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘2.7 Can no longer view ‘visual’ on posts – html only’ is closed to new replies.