Support » Alpha/Beta/RC » 2.7 add new plugin FTP settings

  • Hi,
    I am having problems using the plugin installer in 2.7; I have a self hosted server using dyndns and I cannot get plugins->add new to work, I get

    Error: There was an error connecting to the server, Please verify the settings are correct.

    whatever settings I use. The correction works fine in a ftp client (nautilus). Nether standard ftp or sftp work in wordpress.
    Could someone tell me how I should format the options (hostname is a bit ambiguous) or whether this is a setup thing (or just a bug)?

Viewing 14 replies - 1 through 14 (of 14 total)
  • it seems to have just started working randomly now 🙂

    Can you please explain what parameters you included ?

    I cannot make it work … I tried the hots name, localhost, etc …

    If you don’t know your FTP server, FTP login, or FTP password, please call your host and they might be able to point you where to get that information.

    just trying to set up a second wordpress install and having the same problems :-(. I know all of the settings (it is my own server) but it is just not working.

    I have a VPS and four WordPress blogs installed… two of them upload and upgrade just fine, two of them don’t. And I’m pretty confused as to why two do not. The permissions are all set the same.

    I don’t have FTP installed on my VPS and I don’t want to install it. And since two work without http://FTP... I don’t think I need it.

    When I click to upgrade the plugins on the two that work.. they just work and do it automatically. The other two ask for FTP information. But since I don’t have FTP on the VPS, entering the information will be pointless!

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    If you have a telnet userid/password, try putting that in, Cynthia.

    In setting up client sites using 2.7 the upload and install process works as I have come to expect from using the beta and RC’s of 2.7. What is new is the requirement of inputting the host/user/pw FTP settings.

    Is there a way to hardcode these into the admin so the clients (that I trust) can add their own plugins?

    The Plugin Installer did not work at all for me until my hosting company enabled php5 for my account. Now it seems to be working fine.

    I tried my telnet login but that didn’t work.. I do not have SSH enabled on my VPS either. 🙂

    I did end up getting the automatic plugin upgrader to work, but I cannot install a new plugin on any of my blogs, it steems. Hrm.

    I am already running PHP5.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Here’s how it checks to see if it can update files directly (without FTP):

    if( function_exists('getmyuid') && function_exists('fileowner') ){
    		$temp_file = wp_tempnam();
    		if ( getmyuid() == fileowner($temp_file) )
    			$method = 'direct';

    For the non-PHP people:
    1. It checks to see if the getmyuid() and fileowner() functions are available and activated.
    2. It calls wp_tempnam(). This function gets the PHP-defined temporary directory and creates a temporary empty file in it.
    3. It checks to see if the owner of the just-created temp file is the same user as the owner of the update script itself. This would indicate that WordPress is running with the same credentials as the person who installed it. In other words, it checks to see if you’re running suPHP.
    – Before it’s done, it deletes the temp file.

    If any of these three checks fail, then you have to put in FTP credentials. This is because, in these cases, WordPress does not have enough local rights to be able to correctly overwrite its own files. So it has to get FTP info in order to FTP back to itself, as you, and thus obtain those rights. It can’t escalate its own privileges.

    Short version:
    1. You need to have PHP configured to allow getmyuid and fileowner to work.
    2. You need to be running suPHP.
    3. Your temporary file directory needs to be defined correctly.

    Most normal hosting setups do this by default. Use of suPHP is fairly standard, as it’s safer from a security standpoint.

    @otto42: since I’m a “non-PHP person,” I’m not sure how to take advantage of this information. How can I tell if PHP has been configured as specified, whether I’m running suPHP, and where my temporary file directory has been set? “php -i” dumps lots of info, but none that appears to be directly relevant to the questions.


    I had a similar situation with the automatic upgrade and plug in installation. I contacted my host and explained the problem.

    They suggested that WordPress doesn’t like running with PHP in FastCGI mode, which is recommended for Windows servers.

    So they took it out of FastCGI mode and when I ran the automatic upgrade again it worked fine. I don’t know what the consequence are of not running FastCGI. I guess I’ll find out.

    I thought I’d mention it here as another possible solution.



    I’m new to WordPress and host the installed software on my own server – seemingly successfully. But like everyone else, nor I can access my server via FTP to change Themes or update to the latest version of WordPress (running 2.8.5). I CAN, however, post blog entries without problem using the dashboard and CAN access the server using my everyday FTP client. But when I use the same FTP Hostname/Username/PW information to make changes using my WP dashboard I too get the error “Cannot connect to server. Please check FTP information and try again.”

    So I just sent an email to my hosting service ( and here’s their reply (although it didn’t help me):

    PHP5 is the default PHP for all pair accounts (so if you have a page with a .php extension, it would use PHP5 unless you have some custom configuration to override the default).

    If WordPress is trying to perform FTP functions, the problem could be that our PHP is not configured with FTP support. This could potentially require you to compile a custom PHP binary for your account (which is unfortunately not something for which we provide direct support). You may need to consult the WordPress developers about the problem.

    Any solution to this problem? Is it a bug afterall? And how do we upgrade to a new version with the bug-fix if we can’t connect to the server to do so? Or is a total re-install the answer? (insert rolling-eyes graemlin here)



    If you have a telnet userid/password, try putting that in, Cynthia.
    thong tin ngan hang | dongabank | Vietcombank | Vietinbank | acbbank

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘2.7 add new plugin FTP settings’ is closed to new replies.