Support » Fixing WordPress » 2.6.3 destroyed Permalinks…

  • Resolved opencomputing


    Hi all,

    I am using WordPress 2.6 and just upgraded to 2.6.3, but my problem is after i upgraded i cant use Permalinks like before /%postname%/ now i can only use the default
    This is kind of a big problem since i have 333 posts and 8 pages, which all are like and suchs…..But now will be turned into some thing like, which means all the 1500+ backlinks i have is going to point to empty posts….. 🙁
    A whole other thing is that more search engines likes the simple url better….
    Does anyone here know how to switch back to the /%postname%/ kind of permalinks?



Viewing 9 replies - 1 through 9 (of 9 total)
  • Besides the fact that having only postname is not a smart thing to do, upgrading itself can have nothing to do with your problem. You’re sure you didn’t delete (or CHMOD’ed) the htaccess or accidentally deactivated mod_rewrite or something?
    If I were you, I’d have a look at my htaccess, if there’s nothing else in it than the permalinks, delete it (otherwise delete the permalinks part) and have WP create a new one (by changing permalink settings in the admin area) and see if that works.

    I’m sure you did, but, the permalinks options under the settings menu is all correct?

    When you try and change your permalink settings there (just try one of the other options). Does it say “Permalink structure updated” or something about needing to update your .htaccess file?

    Have you checked to make sure you have a writable .htaccess file present in the root of your wordpress install?

    Are you on an IIS server or Apache?

    I tried all of the above but it does not work, under settings it says: “Permalink structure updated” every time but the websites and posts dont work….The odd part is it happen while i was making a page (changes to a page). I am on a Apache Server…

    I even tried deleting the .htaccess file, as Gangleri said, but it still does not work it just creates a empty one…

    Assuming your WordPress blog is installed at your domain’s root and not in a sub-folder you may want try adding this to your .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Ok, no, sorry, the reason why this happened to me was simply that the .htaccess file was not properly set up on my development server.

    original but errorneous message:
    The very same thing (as described by opencomputing) has now happened to me: * I was running WordPress 2.6.2, using /%postname%/ as permalink structure. I chose this structure because I thought these links were the most human-friendly, and I did not know I had to add numerical data. * I have now upgraded to WordPress 2.6.3 by overwriting my wordpress installation with the files from the file. Luckily, I only tried it on my local development server! I now find the permalinks do not work anymore.
    I conclude from my and opencomputing’s experience that the wordpress 2.6.3 update does indeed change some permalink-related stuff.

    Interesting as I have never had a problem using just the Postname in my permalink setup and the .htaccess file has never screwed up after an upgrade. Last I checked, 2.6.3 modified three files, all of which have nothing to do with the .htaccess file.

    I tried doing what you said churchthemer but i can only create a empty .htaccess file, my ftp program does not let me make a file with the text. Every time i upload it and its finished uploading its a empty file again….If i try to open the txt file on the server with the ftp program it tells me it can not open that kind of files…

    Typically, you can’t FTP an htacesss since it’s a hidden file. If you have no htaccess, you can make a htacces.txt, upload it and change the name of the file to .htaccess.
    What could be easier is to use your control panel / PHPmyAdmin / whatever ‘s file manager. Most of them can show you the content of a file and edit it.

    Okay, i found out what is wrong is my website host that says: “Disk quota exceeded” and dont allow any new .htaccess files to be created (unless they are empty).

    The funny part is that is wrong, i have 750 mb and should have plenty of space yet….But this is second time they do that, so i did send them a e-mail with a complaint…

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘2.6.3 destroyed Permalinks…’ is closed to new replies.