Support » Installing WordPress » 2.6 Woes — Nothing coming up!

  • Hi.

    I had 2.3 working. Now I had to go to 2.6. When my upgrade didn’t work on a live site, I panicked, and backed up my DB and my wp-config, then deleted the WP entirely, and then reinstalled the 2.6 afresh.

    But now when it is installed, I see messages like these:

    [Wed Jul 16 11:46:05 2008] [error] [client 182.1.14.74] PHP Fatal error:  Call to undefined method wpdb::set_prefix() in /home/MYDOMAIN/public_html/cms/wp-settings.php on line 211
    [Wed Jul 16 11:45:57 2008] [error] [client 182.1.14.74] PHP Fatal error:  Call to undefined method wpdb::set_prefix() in /home/MYDOMAIN/public_html/cms/wp-settings.php on line 211, referer: http://MYDOMAIN.com/cms/wp-admin/options-permalink.php
    [Wed Jul 16 11:45:52 2008] [error] [client 182.1.14.74] PHP Fatal error:  Call to undefined method wpdb::set_prefix() in /home/MYDOMAIN/public_html/cms/wp-settings.php on line 211
    [Wed Jul 16 11:45:50 2008] [error] [client 182.1.14.74] PHP Fatal error:  Call to undefined method wpdb::set_prefix() in /home/MYDOMAIN/public_html/cms/wp-settings.php on line 211
    [Wed Jul 16 09:54:52 2008] [error] [client 182.1.14.74] PHP Warning:  include_once() [<a href='function.include'>function.include</a>]: Failed opening 'WP_PLUGIN_DIR/tinymce-advanced/tadv_admin.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/MYDOMAIN/public_html/cms/wp-content/plugins/tinymce-advanced/tinymce-advanced.php on line 217, referer: http://MYDOMAIN.com/cms/wp-admin/admin.php?page=backupwordpress/backupwordpress.php
    [Wed Jul 16 09:54:52 2008] [error] [client 182.1.14.74] PHP Warning:  include_once(WP_PLUGIN_DIR/tinymce-advanced/tadv_admin.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory in /home/MYDOMAIN/public_html/cms/wp-content/plugins/tinymce-advanced/tinymce-advanced.php on line 217, referer: http://MYDOMAIN.com/cms/wp-admin/admin.php?page=backupwordpress/backupwordpress.php
    [Tue Jul 15 06:26:04 2008] [error] [client 182.1.14.74] PHP Fatal error:  Maximum execution time of 90 seconds exceeded in /home/MYDOMAIN/public_html/cms/wp-includes/streams.php on line 68
    [Tue Jul 15 06:24:33 2008] [error] [client 182.1.14.74] PHP Warning:  unpack() [<a href='function.unpack'>function.unpack</a>]: Type V: not enough input, need 4, have 0 in /home/MYDOMAIN/public_html/cms/wp-includes/gettext.php on line 85
    [Tue Jul 15 06:24:33 2008] [error] [client 182.1.14.74] PHP Warning:  unpack() [<a href='function.unpack'>function.unpack</a>]: Type V: not enough input, need 4, have 0 in /home/MYDOMAIN/public_html/cms/wp-includes/gettext.php on line 85
    [Tue Jul 15 05:40:47 2008] [error] [client 182.1.14.74] PHP Fatal error:  Maximum execution time of 90 seconds exceeded in /home/MYDOMAIN/public_html/cms/wp-includes/streams.php on line 58
    [Tue Jul 15 05:39:17 2008] [error] [client 182.1.14.74] PHP Warning:  unpack() [<a href='function.unpack'>function.unpack</a>]: Type V: not enough input, need 4, have 0 in /home/MYDOMAIN/public_html/cms/wp-includes/gettext.php on line 85
    [Tue Jul 15 05:39:17 2008] [error] [client 182.1.14.74] PHP Warning:  unpack() [<a href='function.unpack'>function.unpack</a>]: Type V: not enough input, need 4, have 0 in /home/MYDOMAIN/public_html/cms/wp-includes/gettext.php on line 85
    [Tue Jul 15 05:32:00 2008] [error] [client 182.1.14.74] PHP Fatal error:  Maximum execution time of 90 seconds exceeded in /home/MYDOMAIN/public_html/cms/wp-includes/streams.php on line 60
    [Tue Jul 15 05:30:29 2008] [error] [client 182.1.14.74] PHP Warning:  unpack() [<a href='function.unpack'>function.unpack</a>]: Type V: not enough input, need 4, have 0 in /home/MYDOMAIN/public_html/cms/wp-includes/gettext.php on line 85
    [Tue Jul 15 05:30:29 2008] [error] [client 182.1.14.74] PHP Wa....

    Any thoughts on what I can do now? Please advise!!

    THANKS! :O

Viewing 10 replies - 1 through 10 (of 10 total)
  • PHP Fatal error: Call to undefined method wpdb::set_prefix() in /home/MYDOMAIN/public_html/cms/wp-settings.php on line 211

    This is a dead giveaway of an incomplete upgrade.

    You have to upload EVERY FILE. All the files in the WordPress ZIP file must be put onto the site. And that means ALL. Every single one. If any are left out, you have problems.

    In your case, it seems that some of the files in wp-includes did not get upgraded.

    Wel I updated through “SVN sw” command. Is the svn repository not fully completely updated?

    Anyway, I have now downloaded WP from the main page of this site, extracted, and carefully and meticulously uploaded each and every file.

    The admin interface is working. I have used this chance to disable ALL plugins. Nothing is on.

    But my site is not coming up at all 🙁 I try to check into Apache error log but it is not picking up anything either

    Now, my apache error says this:

    Warning: require(/home/MYDOMAIN/public_html/cms/wp-includes/compat.php) [function.require]: failed to open stream: No such file or directory in /home/MYDOMAIN/public_html/cms/wp-settings.php on line 203
    
    Fatal error: require() [function.require]: Failed opening required '/home/MYDOMAIN/public_html/cms/wp-includes/compat.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/MYDOMAIN/public_html/cms/wp-settings.php on line 203

    But both wp-settings.php and compat.php have been uploaded! I just finished FTPing them for the third time!

    Well, if the files are indeed there, then it could be some kind of permissions issue.

    Ok, I changed my php.ini and set “display errors = On”.

    For some reason, my FTP software was not properly uploading files. Now they’re all in there. (PHP errors told me which files were needed or missing and I uploaded them all one by one).

    Now the site is completely blank. Not even an error message. The “display setting” in PHP.INI is set to “E_ALL”, so I doubt this is a PHP error at this stage. What else could it be?

    My site is now coming up, basically, but it is very slow. Is this 2.6 code dramatically slower than versions before it?

    Also, the SVN stuff from WP is completely broken. When I do an SVN SW to upgrade to 2.6, it simply does not work. And now, despite everything working, when I do an svn up it just does NOT work. It tells me:

    svn: Working copy '/home/MYDOMAIN/www/wp/wp-admin' is missing or not locked

    What is this about?

    I am getting this error, can anyone help?

    Fatal error: main() [function.require]: Failed opening required ‘../wp-load.php’ (include_path=’.:/usr/lib/php’) in /homepages/7/d187081345/htdocs/blog/wp-admin/upgrade.php on line 4

    Not sure what to do?

    Damn seeing all you guys, I am afraid to upgrade…

    Will the blog work on the front end at least if I do the upgrade and ran into troubles?

    I just was able to fix the database update, but then when I hit continue it goes to a blank screen. Still get an error on my log in

    @erick_paper – are you using Transmit for ftp? I do, and I had that same problem. It seems to time out when it gets to the includes files. I had to go in a bunch of times and make sure all the files are there – especially in the folders. I’m still having trouble with tinymce, but everything else is working.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘2.6 Woes — Nothing coming up!’ is closed to new replies.