Support » Fixing WordPress » 2.6 – Press This bookmarklet photo insert failure

  • The Press This bookmarklet in WP 2.6 has a major flaw for photo insertion. The bookmarklet window appears when I click on the link, and clicking on the Photo tab displays available images on the web page to be inserted. Clicking on images to insert launches the thickbox viewer with the image and Description field. Neither clicking on ‘Insert Image’ or the image itself, however, will insert the image into the post. Any thoughts on why this particular operation just completely fails? All the other tabs seem to work perfectly.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Just submitted this as an update to Trac – http://trac.wordpress.org/ticket/7310

    Same thing happens to me, and it’s with Firefox 3.0.1

    It inserts no image into the post. Very frustrating. Can you add this to your ticket, as they seem to think it’s just IE7 ?

    Cheers

    If you feel comfortable editing PHP files, try the change shown here. It fixed the photo hotlinking for me.
    http://trac.wordpress.org/changeset/8477

    Thanks rhartong – I tried that a few days ago; all it does it stop any images appearing at all in the photo tab. My problem isn’t having no images appearing to choose from – it’s just that when I choose one and click ‘Insert image’, it doesn’t insert it into the post.

    It doesn’t look like this has been updated for a month, but I’ve just done a fresh install of 2.6.1 and have this identical problem with the Press This bookmarklet. I’m running Firefox 3.01 on Mac OSX 10.5.4. Like goo-mason, I see the images, I can select one of them and then add a caption – but the image is never added to the post. I’ve tried the new press-this.php file with the trailing backslash removed, but it makes no difference at all.

    bradfitz

    (@bradfitz)

    The issue, I believe, is due to the post writing preference. Placing photos with Press This works fine for me with rich text editing turned on, but does not work when editing in plain text.

    I still can’t figure out this annoying hot linking issue though.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘2.6 – Press This bookmarklet photo insert failure’ is closed to new replies.