Support » How-To and Troubleshooting » 2.6 Image Uploader – Will Upload But Not Insert

2.6 Image Uploader – Will Upload But Not Insert

  • I have no option to use the flash uploader even after I updated my flash player. Using the browser uploader, I can upload an image but then the “Show” link doesn’t work. I upload the images but I cannot edit them or insert them into a post.

    I’ve tried all the solutions to the other problems I’ve seen on the support here, but nothing worked.

Viewing 15 replies - 1 through 15 (of 17 total)
  • By the way, it will not work with Safari, IE 7, or FF 2.x.

    If you look (via ftp) in the wp-content/2008 directory, are the files there?

    For whatever reason “my” uploader makes links to the wp-content/uploads directory (or rather a wp-content/uploads/2008 directory which doesn’t exist)

    The advice here may also be of interest


    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    JacobChristensen: If you have a custom upload directory on the Settings->Misc screen, then you must put in the URL to that directory below that, so it knows where those images are.

    No, my uploads are definitely in wp-content/uploads. I’ve been through the post you linked to and I’ve done it all. Nothing worked. I haven’t even found anyone else with the same problem yet. I’ve re-uploaded all of the 2.6 files just to make sure but the problem remains.

    Otto42 – solution works for me. With custom image directory, the uploader gets the path wrong.

    After adding the url setting it started to work again.

    Do think its misleading the text for that option reads “Full URL path to files (optional)” – Clearly its not optional if you have a custom directory.

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    Actually, I think that might be a code regression problem/bug. I’m pretty sure that it used to be capable of figuring it out. Anyway, setting that works for now.

    @jsarber: You mention Safari… using a Mac? The Flash Uploader is auto-disabled for users using Macs if the server is also running mod_security. That combo does not work. Mac/Flash/mod_security thing.

    No, I’m on a PC. I just have the Safari browser downloaded.

    Maybe this is relevant…I had no problems at all with the media uploader in the last version of WP.

    Thanks, Otto! That did the trick!

    My image uploader is still not working after upgrading to 2.6. I have read this thread and various other things, but no help. I have tried it in Firefox, Safari, Opera and IE too.

    thanks alot! that solve my problem. 🙂

    I’ve had exactly the same problem — I’m on a Mac and, after upgrading from 2.51 to 2.6 I could upload but no longer insert pics, no matter which browser (I-Cab, Safari or Firefox) I used. The browser pop-up uploader would work right up to the point I clicked “Insert Pic” at which point the pop-up would go blank. Following forum tips, deleting pics, disabling all browser filters, completely reinstalling the browsers, completely reinstalling WordPress, etc, made no difference. For clarity, I omit several days of stupefied disbelief and hitting things.

    Astoundingly, the answer to my problem turned out to be capital letters. For style purposes, I had the site name in Dashboard > Settings > WordPress Address (URL) as ThisIsTheSiteName.com, which had previously caused exactly no problems at all. Changing this to thisisthesitename.com fixed it.

    Might I politely suggest that the 2.6 pop-up uploader be twiddled to flatten any URLs, or at least to feature a warning rather than going blank and hanging? Thanks.

    (NB. Also posted in http://wordpress.org/support/topic/189738 , just in case.)

    Yes I have this exact problem as well.

    I’ve changed the directory of the uploading path though.

    Store uploads in this folder : images/

    It cleverly stores whatever media I uploaded there

    Full URL path to files (optional) : http://www.myurl.com/images

    Works wonderful as well.

    My gallery has all the pictures and I can view them from the Gallery or Media Library, I can even edit their captions and stuff. But what I CANNOT DO is INSERT them into my post, which is kind of discouraging.

    Ze Fontainhas



    I was having a similar problem, but then found out (automatic translation, be warned…) that there could be a problem with PHP’s Security Module.

    I tried this on my WP’s directory .htaccess file, and everything’s back to normal:

    <IfModule mod_security.c>
    SecFilterScanPOST Off
    SecFilterEngine Off
    SecFilterInheritance Off

    I have the issue of the image uploads but when I insert it I get a blank page. This happened on OSX Leopard, PPC and intel, Firefox and Safari.

    I opened up Parallels running XP and Firefox and the problem DID NOT exist.

    (I have the latest Flash 9)

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘2.6 Image Uploader – Will Upload But Not Insert’ is closed to new replies.