2.5.1 Image/Media Uploader problems (50 posts)

  1. AndrewRH
    Posted 8 years ago #

    Just upgraded to 2.5.1 and get the "HTTP Error" (see this picture) after uploading an image using Firefox There is a "Dismiss" button partially obscuring the "Crunching" field.

    The media gallery does show the picture - so it was uploaded. But no thumbnail was created.

    I tried all things in the sticky "2.5 Image/Media Uploader problems" to no avail.

    My website is hosted on 1&1 (USA).


  2. AndrewRH
    Posted 8 years ago #

    Someone else has just posted here about another upload problem in 2.5.1.

    And a follow-up: the no-flash-plugin doesn't fix things. Instead, I now see "Internal server error!" after clicking the upload button. I have emailed 1&1 tech support to see if there is any other details on the server about the error...


  3. davepoobond
    Posted 8 years ago #

    sounds like it could be the mod_security thing.

    i had that problem and then did the fix that was in the stickied post. try it out.

  4. kelotter
    Posted 8 years ago #

    Where is the stickied post? I just upgraded to 2.5.1 and have same issue trying to upload an image - says HTTP error.

  5. Where is the stickied post?


  6. shownomercy
    Posted 8 years ago #

    I am having a different error with 2.5.1 only. I also (re) tried everything in the sticky post (which was quite helpful for 2.5.0)

    The issue is that images are not being uploaded after browsing for the local file. They do not show up in the gallery either.

    No error messages either.

  7. kreatyve
    Posted 8 years ago #

    Same problem!
    I installed the 2.5.1 version and I haven't got any error during the upload but the blog doesn't make any thumbs just show the full size picture!! :-(

    Just tried anything on this sticky post:
    The result is the same....

    Anybody found a solution? I have to stop the blog for this trouble....
    It seems impossible there is no fix!

  8. terrybugs
    Posted 8 years ago #

    Exact same Problem here!
    At least in 2.5, I could use Windows Explorer to download the pics to the Gallery...although it said the pic didn't process correctly and wouldn't let me attach it to my page. But I could then open Foxfire and open the Draft and would have access to the gallery and the pic?
    Since I upgraded to 2.5.1 I can't do that either?

    I've been lurking here for a long time looking for a fix? I sure wish I hadn't upgraded 3 of my sites to 2.5...
    BTW i'm using Windows XP...don't know if that matters...
    Waiting Patiently ;)

  9. Waiting Patiently ;)

    Waiting accomplishes nothing. You have to find and fix your own problems.

    Have you tried any of the solutions given here?

    What was the results of each step? Just saying "it doesn't work" is not helpful, we need information on which we can come up with ideas and solutions.

  10. kreatyve
    Posted 8 years ago #

    That post don't solve the problem. After upgrading my 2.5 version to 2.5.1 I tried to delete the 2 folder including cache as stated but anything changed.

    In another post, people suggested to install this plugin flexible-upload but it may create other alignment troubles (it depends of them you're using) and it's not able to upload multiple images.
    So...the situation is that there's no any fix for this BIG trouble at moment...

    I'm just wondering if this wordpress version it's been correctly tested. Please let's try again all together with ideas...I'd really like to go online.

  11. terrybugs
    Posted 8 years ago #

    Actually, I've spent many hours trying to fix the problem as well as checking here for a fix by someone who might know more than I do.
    And yes, I've done all the fixes in the sticky posts over and over again.
    And I am still working on it...if I find a fix, i'll gladly pass it along...
    I would suggest a YES/NO poll be put up in a sticky post to see how many people are actually having this problem..

  12. I would suggest a YES/NO poll be put up in a sticky post to see how many people are actually having this problem..

    This is a support forum. Everybody here has problems of some kind, more or less by definition. People without problems don't come here. So such a poll would be a little bit biased, no? ;)

    And yes, I've done all the fixes in the sticky posts over and over again.

    And the results? Was there any change at all?

    Basically, we cannot solve problems that we cannot reproduce. I've been unable to duplicate any upload issues on any of my installations. The installs I've fixed for other people have always been one of the problems I give the solution for in the sticky post.

    If I had another answer for you, then it would be in the sticky. I've updated it like a dozen times. So basically, anybody who still has the issue has something that I have not seen.

    We're doing our best here, but problems cannot be solved in a vacuum.

    If you're willing to give me access to your site (passwords and such), then email me and I'll try to help you more directly.

  13. kreatyve
    Posted 8 years ago #

    Hi Otto42, I sent you an email, I really really hope you can help me.
    Many thanks

  14. kreatyve: Got your email, took a look. Your problem was with the images themselves. I'm posting here in case this helps anybody else.

    What I did:
    1. Disabled the no-flash uploader plugin.
    2. Disabled the "Flexible Uploader" plugin.
    3. Grabbed the images that you said were not generating thumbnails, deleted them from your site, then reuploaded them myself. I did have the same problem, it uploaded them fine, but didn't make thumbnails.
    4. Examined the images using IrfanView, noticed that they were 256 color images (8BPP) and grayscale. Selected the "Image->Increase Color Depth" in IrfanView to up them to 16 million colors (24BPP) instead.
    5. Resaved the images.
    6. Reuploaded the images. This time, it generated thumbnails perfectly, and you get what you expect to get.

    Moral of the story: Grayscale images are bad. PHP and GD cannot cope with them. Don't use them, always up them to full color images.

    Note that WordPress versions previous to 2.5 had the same issue. They couldn't generate proper thumbnails for grayscale images either. However, now, in 2.5, if it can't generate a thumbnail, it uses the original image instead of having a broken image link instead.

  15. chiggins
    Posted 8 years ago #

    Hi all,

    Here's the thing. The bug I have with it, I'm reasonably sure, is related to my version of flash rather than any bug with WordPress.

    Now, given, I'm on Ubuntu, and I know that's not a huge share of the platforms/browsers out there. But if you check the Ubuntu forums for problems with flash (especially if you're running the 64-bit version), you see that the supported flash package is usually a little behind the newest linux version, but it doesn't always matter. Fixing flash for us just isn't as high a priority for them, which is fine.

    But it does raise an issue, namely: why doesn't WP have an option, perhaps next to the one that shuts off the annoying wysiwig editor (why, yes, I gots 'pinions, heh), that allows you to just shut off the flash uploader if you don't want it? Why does this require a 4 line plugin?

    Thanks for listening, cheers, and keep up the great work everyone :)

  16. chiggins: The idea, in general, is to make it auto-detect whether the browser has flash or not. Having an option for it is not the preferred approach unless an option is deemed necessary for a large number of users.

    In the special case of Ubuntu, this was brought up here: http://trac.wordpress.org/ticket/6406 and that's where the plugin came from.

    Note that it WILL work on Ubuntu if you simply upgrade your version of Flash. The latest flash is available for all platforms and has been shown to work in that case.

  17. alda
    Posted 8 years ago #


    I'm new to WordPress and have been having the same problems as everyone else with uploading images - despite not having upgraded to 2.5.1.

    I understand that uploading the no-flash plugin will fix the problem, but will that prevent me from uploading flash images to my site in the future? I want to offer ads, so that solution would not work for me.

    Grateful for any help. Thanks.

  18. chiggins
    Posted 8 years ago #


    In this case, the auto-detect finds flash, but the flash I have evidently isn't the super newest where the uploader actually works. Thing is, I'm not willing to short circuit my package manager to get it, that's kinda the point of the package manager.

    I'm not a big fan of using flash where standards-based html/js/css will do the trick, and it sure seems like making this functionality dependent on an app that you guys have no control over is risky.

    So, I'd argue philosophically that browser-detection and auto-enabling is great and unobtrusive, but not giving me the ability to manually shut it off is kinda lame, especially considering that I am given the option of robustitude over convenience with editors.

    That's just my opinion, and I can totally see the other side of argument. My own solution was just to go into includes/media.php and set the damn thing to false :)

  19. Yes, well, my opinion is that Ubuntu needs to get their act together. Feisty still installs 9.0.48, while 9.0.124 has been out for 3 weeks already. And 9.0.115 would work too, and it's been around for months.

    Also, using the plugin is better than manually editing the core files. Nobody likes having to reedit core files after an upgrade.

  20. danixx
    Posted 8 years ago #

    Dear Otto:

    I have the same problem with the uploader.
    I had tried everything and still having the same error !
    (update to 2.5.1, put the .htaccess into wp-admin, install no flahs loader plugin, and still appears the flash, check the version of the flash, delete and put again all wp-admin and wp-includes from the downloaded version of WordPress 2.5.1)
    I´m desesperated !!
    Can you help me please?
    The blog is in http://www.hectorscerbo.com.ar/blog
    Thanks in advance

    Daniela Werkalec
    PDTA: sorry for my english, but I´m spanish native....

  21. Geoserv
    Posted 8 years ago #

    For me it uploads the image, I can see it in the Gallery tab, but it doesn't add it to the post.

    I need to manually enter the HTML myself.

    I tried the items listed in the sticky but didn't do any good.

    Is anyone having the same issue as me?

  22. install no flahs loader plugin, and still appears the flash

    That's not possible. Or, at least, it should not be.

    The "flash uploader" is the one button that says "Choose files to upload". The non flash uploader is the box where the filename goes, along with a Browse and Submit button.

  23. DonSchaal
    Posted 8 years ago #

    I too have tried all the fixes in the "sticky" and am still experiencing difficulties. I can upload images with flash okay and they show up in the media library, but attempting to insert them into posts produces no results. All I get are little boxes that only appear in the editor, but not in the published posts. I previously used 2.3.3 and had no problem uploading and inserting the same images into the posts with that version. I roo hope there is a fix soon. Don Schaal

  24. GregSki
    Posted 8 years ago #

    Hi, I noticed it wqorks fine with my 64 bit internet explorer, but not the 32 bit or firefox. In firefox and 32bit explorer I get a window with a button, "choose file to upload", but with the xp 64bit I get a browse button with upload button next to it. On my old computer that has xp 32bit with 32bit explorer 7 but no updatres for explorer or flash in few months, everything works Ok as well. I am beggining to think it is a flash issue.
    (see this picture)

  25. The "HTTP error" is usually a mod_security issue. See step 6 of the sticky.

    However, it can also be a flash issue. Update Flash to the latest version and see if that helps.

  26. slicksno
    Posted 8 years ago #

    My problem seems to be that there are hundreds of autosave jquery.js requests that are awaiting responses and are hosing up the process. Some of them are not getting a response for approx 140000ms. Is that normal? Doesn't seem like it. The image loader is coming up but is so slow and I am not sure if it is really working. I have been waiting for about 15 mins to upload 2 images that are only about 44K each...

    Anyway it seems like the jquery is out control, at least by what I can see in Firebug.

  27. slicksno
    Posted 8 years ago #

    And the requests from jquery start piling up before I even try to upload files... Sorry this may be a separate issue from the uploader, but didn't start until upgrade to 2.5.1...

  28. slicksno
    Posted 8 years ago #

    I have created a post about my problem with jquery - http://wordpress.org/support/topic/174877 - since it seems as if it is not related to the image uploader but jquery it self.

  29. JoeWebHog
    Posted 8 years ago #

    Otto Rocks! I read this thread and did all of the suggestions as he detailed, however, I still could not get it. I sent Otto an email and within a few hours, the issue was resolved.

    The fix is this straight from the mouth of Otto:

    "The problem was mod_security. Adding the .htaccess fix as described in
    the sticky fixed it."

    I tried to make the htaccess file but didn't do it correctly. I now know how and want to share it with everyone.

    Simply create the .htaccess file just like Otto says. Use a text editor or Dreamweaver and put this code in:

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Save the doc as .htaccess and upload to your server in the wp-admin folder. Simple as that!!

    Thanks again Otto, you are the best!


  30. AndrewRH
    Posted 8 years ago #


    The sticky has this, which is the closest to my problem:

    8. Q: It uploads without any errors, but it does not generate thumbnails! The images show up full size on the page, or they are scaled in a really ugly manner.
    A: In all cases I have seen this, the problem turned out to be with the image itself. WordPress uses the normal PHP functions for working with images, which are in the "GD" library.

    In case it matters, I always resize my images to 1024x768 using the Windows XP "Image Resizer" Power Toy.

    I then use the WP2.5.1 media uploader (tried with and without the "no flash uploader" plug-in; and with the .htaccess changes).

    The pictures always upload fine, but more often than not the thumbnail version is not created - making it next to useless for my blog entries (don't want huge pictures in my blogs).

    When I disable the flash system (using "no flash uploader" plugin); I see: "Error 500 - Internal server error An internal server error has occured! Please try again later."

    I have asked 1&1 (USA) to give me their server error logs but they have refused.

    The properties of a typical resized picture that doesn't have a thumbnail created is:
    Width=1024; Height=683; Resolution=72dpi; bit depth=24; frame count=1

    The WP-ServerInfo plugin says that my host has GD "bundled (2.0.28 compatible)".

Topic Closed

This topic has been closed to new replies.

About this Topic