WordPress.org

Support

Support » Alpha/Beta » 2.5 no Thumbnails in Post

2.5 no Thumbnails in Post

  • Images in Post are alway included in full-size instead of thumb or medium-size. Upload an resizing works fine, there are thumbs and medium-sized images in uploads-folder. The same happens when I insert a Gallery into the post. The post shows full-size images.

    Any idea why i can’t place thumbs in the post!?

Viewing 15 replies - 1 through 15 (of 16 total)
  • It’s silly, but if you go allllllllll the way over to the super tiny Setting link you can go to Miscellaneous and set up your thumbnail sizes there. At that point, I think you should be able to insert thumbnails in your posts, but I still can’t even upload images to my posts, so don’t count on me.

    hi faboomama, the settings are allright (150px for thumbs, 300px for medium). Sizes are created after upload, but within the wordpress-editor onlny large images appear…

    I have the same problem. When the link to image is inserted into the post, it doesn’t add the filename append for thumbnail size. You can do it manually after link insertion by adding in the img src portion of the link the thumb appending addition to your img filename: change yourimage.jpg to yourimage-150×150.jpg or whatever your custom thumbnail size happens to be.

    @slodaddy, yes, but that ain’t an option. When inserting a gellery this is not possible …

    Any advice?

    I have this same problem, too…

    C’mon, nobody knows how to fix it?

    []’s!

    Ok, at last – found other people with this problem :-(. I have this exact same problem also…! Posted in help forum before, but got no answer so far.

    nothin’ new from my side as well. I will report back here in case I find a solution…

    I had the same problem – thumbnails were generated, but not inserted into the WP gallery. Disabling other gallery plugins (I use awsom) did the trick for me…

    But sorry to say: The whole new gallery thingy is very disappointing, no documentation to speak of, very confusing logic behind it. I stick with awsom…

    Greetings from Germany – Gabi

    Sorry, I have to correct myself: The issue is not between the built-in WP gallery and awsom. The plug-ins that cause trouble are contactform7 and podpress – at least in my case.

    Greetings, Gabi

    Ditto on the podpress

    thanks, all for the info in this post. I found the same problem as gfra. I wasn’t able to insert thumbnails until i disabled “podpress”.

    Wow, are you serious? Podpress is the issue? I have been using NextGen Gallery only because I couldn’t find any answers as to why the built in gallery wasn’t working.

    Frankly, I like podpress, but it’s been constant issues. Maybe time for a replacement since I run WAY more images than podcasts or video.

    Here’s a fix for the podpress I found on their site

    podpress.php

    Beginning at line 423:

    function podPress_wp_get_attachment_metadata($data, $id=”) {
    if(is_feed()) {
    return ”;
    } else {
    return $file;
    }
    }

    Change to:

    function podPress_wp_get_attachment_metadata($data, $id=”) {
    if(is_feed()) {
    return ”;
    } else {
    return $data;
    }
    }

    the podpress fix works.

    I was able to upload but no thumbnail generation whatsoever. Changed the code mentioned above and it worked perfectly. Now all thumbnails not generated are generated, and new uploads are generated.

    Now if there was a cleanup script for the uploaded files, since the person I made this site for loves uploading 3MB photos, and I have the max width set at 1024. An automatic cleanup script that removes the original photos and keeps the newly generated ones would rock, but I guess that is discussion for elsewhere.

    what about those without podpress? anybody know of a fix?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘2.5 no Thumbnails in Post’ is closed to new replies.