Support » Fixing WordPress » 2.5 No longer sending comment email notification

  • Basically, I am no longer receiving the email notifcation when anyone leaves an email on my blog.

    I setup my blog last year with Word Press 2.1 (or .2, I forget) and everything was fine; I was using the default Theme and emails were being received regularly.

    About a month ago I changed my Theme to Dipdolt V1 and upgraded to 2.3. Since then, nothing.

    With the release of 2.5 I upgraded again, keeping the same Theme, and still no emails.

    I have searched and browsed for answers, with most of my attempts to patch things up being summed up in this thread: http://wordpress.org/support/topic/142163?replies=12#post-669263

    So in summary, I have:

    – removed “228 $phpmailer->Sender = apply_filters( ‘wp_mail_from’, $from_email );” from pluggable.php
    – made sure I have both wordpress@domain.com and admin-user@domain.com
    – installed the Comments Notifier pluggin
    – made sure that the general notification check box is ticked so I receive it for all comments

    Does anyone else have any ideas?

Viewing 15 replies - 46 through 60 (of 113 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    You’d think you’d recognise it as a problem if so many people are complaining about it.

    These are support forums. By definition, people only tend to come here when they have issues.

    Also, this thread is maybe 40 posts long with 30 or so people commenting. Thousands of people use WordPress. So, a bit of perspective is in order.

    If no emails at all were getting through, maybe, but my email server is specifically choosing which emails?

    Yes, absolutely. Email is more complex than you seem to understand, and modern email systems have hellishly complex rulesets.

    The most common email issue with WordPress involves the use of the “From:” header. Some servers don’t like it, some do. In particular, comments get a “From:” of the commenter name and wordpress @ yoursite.com as an email, with a reply-to of the commenter’s email, so that you can reply to them. Some email servers reject this, they don’t like the “wordpress@” address. Moderation emails don’t have that same header setup.

    One of the most common fixes for this on some systems is to create a “wordpress” email address on your host. Another is to blank out the Sender address using code like this in a plugin:

    add_action('phpmailer_init','my_phpmailer_init');
    function my_phpmailer_init($php_mailer)
    {
        $php_mailer->Sender = '';
    }

    But both of these fixes are just workarounds for problems with your email server’s overly strict rules.

    In your opinion, what is the parameter which is responsible of this send mail problem on a host ?

    I’m not buying that this is a SERVER PROBLEM. I’ve spent hours on the phone with my host — YAHOO — and they are assuring me it is nothing on their end after checking and re-checking.

    Furthermore, wordpress is PARTNERED with yahoo now with the “one step easy install” garbage.

    Moderator, your attitude is really disheartening to me, and to the thousands of other people having this problem. Sure, perspective is order, but I don’t really believe there’s nothing WordPress can do on their end to help figure this mess out. They just can’t be bothered. Maybe there are only 40 people in this thread, but I’ve found MANY threads on this website, along with many blogs, all over the internet with people having this same issue. It spans far beyond 40 people.

    Having similar problems, though undoubtedly unique. I’ve followed the work around suggestions by Otto and I’m able to receive email notifications at my gmail account, but not at my domain’s info@mydomain.com.

    It sounds like support isn’t real interested in offering some helpful solutions on this, but wanted to register the issue.

    Please forgive me if I missed some critical information. I’m pretty new to this, and I read the thread, but I don’t recall seeing any information from httpd logs anywhere. Has anyone any detailed mail-log or httpd log error information?

    If this is a php (ergo a possible WordPress) error, and you have php error logging turned on for httpd, wouldn’t your apache log show a PHP Parse error, or PHP Warning?

    I also saw g-mail mentioned. Assuming that you are using a plugin to access your g-mail account, (which I think you might have to), and I think that httpd has to connect to the network using a script in that case. If it encountered an error, would it not leave an error message in your log? There seems to be so many variables from user to user… what plugins you use, what server OS you use, what restrictions your ISP has in regard to port 25. None of that information is available to anyone else.

    Anyone have any logged error? Like I say, I’m pretty new to this, so I could be talking out my arse… maybe nothing I am thinking is relevant to the issue. I’m not sure.

    I have made a wordpress email on my host, did nothing. I’ve also tried switching my email address to ones hosted on different servers… and also to a yahoo email account… still no emails.

    I have changed nothing else. This problem started with my upgrade to 2.5.1.

    Moderator, as you’ve so eloquently pointed out, I’m clearly not as schooled as you are at all of this. I don’t understand your suggestion to blank out the Sender address using code in a plugin. I have no clue how to make my own plugin. Any more advice on that suggestion?

    I don’t understand your suggestion to blank out the Sender address using code in a plugin

    Could this be of any help in attempting to change the “from” field via a plugin method? I have not tried it myself, but it appears to be relevant.

    http://wordpress.org/extend/plugins/mail-from/

    ..or perhaps something similar from a more thorough search would prove more on point.

    Yet another that appears very promising as a possible solution.

    http://wordpress.org/extend/plugins/wp-mail-smtp/

    If anyone tries this one, I would be very interested to know the results.

    I tried the WP-Mail-Smtp. It sent me a TEST EMAIL when configured to use SMTP… but again, no email when a comment is left (yes, the notification boxes are all checked). When I configured it to send PHP, it gave me this error message….. does anyone know what this means?

    SMTP -> ERROR: Failed to connect to server: No route to host (65)

    bool(false)

    The full debugging output is shown below:

    object(phpmailer)(39) {
    [“Priority”]=>
    int(3)
    [“CharSet”]=>
    string(5) “UTF-8”
    [“ContentType”]=>
    string(10) “text/plain”
    [“Encoding”]=>
    string(4) “8bit”
    [“ErrorInfo”]=>
    string(44) “Language string failed to load: connect_host”
    [“From”]=>
    string(25) “myemail@myhost.com”
    [“FromName”]=>
    string(8) “COMMENTS”
    [“Sender”]=>
    string(0) “”
    [“Subject”]=>
    string(52) “WP Mail SMTP: Test mail to myemail@myhost.com
    [“Body”]=>
    string(68) “This is a test email generated by the WP Mail SMTP WordPress plugin.”
    [“AltBody”]=>
    string(0) “”
    [“WordWrap”]=>
    int(0)
    [“Mailer”]=>
    string(4) “smtp”
    [“Sendmail”]=>
    string(18) “/usr/sbin/sendmail”
    [“PluginDir”]=>
    string(0) “”
    [“Version”]=>
    string(4) “1.73”
    [“ConfirmReadingTo”]=>
    string(0) “”
    [“Hostname”]=>
    string(0) “”
    [“Host”]=>
    string(18) “mysmtp.net”
    [“Port”]=>
    int(25)
    [“Helo”]=>
    string(0) “”
    [“SMTPAuth”]=>
    bool(false)
    [“Username”]=>
    string(0) “”
    [“Password”]=>
    string(0) “”
    [“Timeout”]=>
    int(10)
    [“SMTPDebug”]=>
    int(2)
    [“SMTPKeepAlive”]=>
    bool(false)
    [“smtp”]=>
    &object(smtp)(6) {
    [“SMTP_PORT”]=>
    int(25)
    [“CRLF”]=>
    string(2) “

    [“do_debug”]=>
    int(2)
    [“smtp_conn”]=>
    bool(false)
    [“error”]=>
    array(3) {
    [“error”]=>
    string(27) “Failed to connect to server”
    [“errno”]=>
    int(65)
    [“errstr”]=>
    string(16) “No route to host”
    }
    [“helo_rply”]=>
    NULL
    }
    [“to”]=>
    array(1) {
    [0]=>
    array(2) {
    [0]=>
    string(25) “myemail@myhost.com”
    [1]=>
    string(0) “”
    }
    }
    [“cc”]=>
    array(0) {
    }
    [“bcc”]=>
    array(0) {
    }
    [“ReplyTo”]=>
    array(0) {
    }
    [“attachment”]=>
    array(0) {
    }
    [“CustomHeader”]=>
    array(0) {
    }
    [“message_type”]=>
    string(5) “plain”
    [“boundary”]=>
    array(2) {
    [1]=>
    string(35) “b1_7622bca7b4c9caf8b9185b7e6e7924dd”
    [2]=>
    string(35) “b2_7622bca7b4c9caf8b9185b7e6e7924dd”
    }
    [“language”]=>
    array(0) {
    }
    [“error_count”]=>
    int(2)
    [“LE”]=>
    string(1) “

    }

    I think this may be the same as smtp error 10065, or EHOSTUNREACH which as indicated, is saying that the host is not reachable.”No route to host, or a socket operation was attempted to an unreachable host”. Do you get a response from the server/host if you ping it, and are there any ISP port 25 retrictions or router/network issues that could be interfering? I’m really hoping someone with a more critical eye will spot something and jump in. I’m getting out of my depth on this one.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    I’m not buying that this is a SERVER PROBLEM. I’ve spent hours on the phone with my host — YAHOO — and they are assuring me it is nothing on their end after checking and re-checking.

    Yahoo is, by far, the worst web host I know of. They’re worse than GoDaddy (which is saying a lot, believe me). Their systems are strange, their PHP is broken most of the time due to the overly restrictive security, and their prices are high to boot.

    My advice would be to switch hosts. I use GoDaddy hosting because it’s cheap, but I can’t recommend them either, really. I’ve heard good things about A Small Orange, and some people like DreamHost.

    Furthermore, wordpress is PARTNERED with yahoo now with the “one step easy install” garbage.

    I have no idea what the “one step easy install” is, but I’m fairly certain that nobody from WordPress is involved with it. WordPress has been adapted to many “simple” install programs on several different hosts. WordPress didn’t make any of those. WordPress is free software, anybody can adapt it for anything they like.

    Here on these forums, we generally recommend not using those installer systems and doing a manual installation yourself.

    I don’t understand your suggestion to blank out the Sender address using code in a plugin. I have no clue how to make my own plugin. Any more advice on that suggestion?

    Here’s a plugin for just that: No-Sender Plugin

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Possible alternate fix, add this line to your wp-config.php file, right after all the define lines:
    ini_set("sendmail_from", 'your.email@example.com');
    Substitute your real working email address there, obviously.

    1. I did do a manual install. I have 10 different wordpress blogs set up and running off of my main domain. Again, everything worked fine with comment notification until my upgrade to 2.5.1

    2. Otto, tried your no-sender plugin. It did not work. I also tried adding the lines to my wp-config.php file — again, with no success.

    3. I do not receive emails when comments are held for moderation, either. I do however, get a notification when a suspicious comment is held in the “moderation queue.” How that makes sense, I do not understand.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Again, everything worked fine with comment notification until my upgrade to 2.5.1

    What version did you have before you upgraded? Telling me what doesn’t work is useless unless I know what did work too.

    2. Otto, tried your no-sender plugin. It did not work. I also tried adding the lines to my wp-config.php file — again, with no success.

    Make sure you try both of those things separately. One or the other. If you do both at the same time, it will not work.

    3. I do not receive emails when comments are held for moderation, either. I do however, get a notification when a suspicious comment is held in the “moderation queue.” How that makes sense, I do not understand.

    … I don’t understand the difference. What’s the difference between those two emails that you’re talking about?

    WordPress can send email with these subjects:
    Password Reset
    Your new password
    Password Lost/Changed
    New WordPress Blog
    Comment/Trackback/Pingback
    Please moderate:
    New User Registration
    Your username and password

    Only two of those deal with comments. The notification and the “Please Moderate” one.

    1. I upgraded from whatever was right before 2.5.1 (i guess that’d be 2.5.0)

    2. I did try them both independently – it did not work.

    3. The difference between the two emails…

    Under Options – Settings – Discussion
    E-mail me whenever:
    Anyone posts a comment — BOX CHECKED
    A comment is held for moderation — BOX CHECKED

    I am getting emails when a suspicious looking comment is held for moderation. The email tells me to log in and approve it, etc.

    HOWEVER, if I turn on comment moderation (as in check the box that says “An administrator must always approve the comment before the comment appears” I do NOT get an email.

    Makes no sense to me.

Viewing 15 replies - 46 through 60 (of 113 total)
  • The topic ‘2.5 No longer sending comment email notification’ is closed to new replies.