Support » Alpha/Beta/RC » 2.5 image upload

  • ok i have chmod’d my directories and blah blah. anytime i try and upload an image from my computer to insert in a post i get this error.

    “http error”

    and then it says in the image uploader “An error occurred in the upload. Please try again later.”

    i am lost as to why this is happening. i have been using wordpress since the early days of 1 and i have never had this problem. it is also a fresh install of 2.5.

Viewing 10 replies - 136 through 145 (of 145 total)
  • I agree with cantonbecker.
    I got the http error only with password-protected .htaccess file.

    But I got the error only when using Ubuntu/Firefox (or Epiphany or Opera)/Flash player 9.
    I have no error with Windows XP/IE7 (or IE6 or Firefox)/Flash player 9.

    Is there still no fix that makes an end to all the image upload problems? I have one site which is working fine in firefox, but IE6 is giving problems with sendig images to the post. I can go to media library, click show on one of the images and when i click Send to post, it just send the image that was last added, not the image that was selected. This problem is nog accuring in firefox. In IE7 I just don’t know which image it will send to the post, because it’s stuck on the white popupwindow after sending the image to the post.
    It would be so nice if everything was working in all of the browsers.
    At this moment I don’t know where to look voor THE fix, there are so many threads about this subject that I’m really longing for 1 place with the answer.

    Turned out the problem I was having was caused by a Javascript security precaution — the update frame was trying to access the main frame, which was coming from a different domain/protocol.

    The protocol was different because I’ve been trying to make sure my WordPress login is secure, using SSL. It appears that this might be “done properly” in 2.6 (about time! – but thanks), removing the necessity for me to bodge around it, so that problem should be gone then.

    The domain was different because we are lazy and like typing just “blog” in our browsers’ location bars, allowing our DNS resolver to complete the name from our default search domains. This meant that the original page was coming from something like “blog” while the upload frame was from “blog.example.com” (coming from the settings for “wordpress location”).

    To fix this, just make sure that “UseCanonicalName On” is present in the apache config for your virtual host.

    The “NoFlashUpload” plugin appears to have almost exactly zero effect on this system at the moment, by the way. Not sure why, and since the normal upload is now working I’ll probably not bother to work it out.

    The FlexibleUpload plugin also won’t work, as I have symlinked wp-content/* to somewhere outside of /usr, as it’s a bad idea to start editing files inside /usr any more than you absolutely have to on a system with a half-decent package manager. There are other reasons too, but that one will do for now.

    If every other plugin I’ve tried so far can manage without “require ../../../../whatever”, I’m not about to change for one that can’t.

    Hi,
    Friends i don’t know how to upload my image.Can you give me information regarding that.

    aylen
    orkut

    Here is a solution to the password protected install/admin directory problem. I am using it in 2.6.1. I have added this to my .htaccess file to allow the flash uploader to function. It reverses the require [user] directive.

    # allow flash uploader to work in a password protected directory
    <Files async-upload.php>
    Order Deny,Allow
    Allow from all
    Satisfy any
    </Files>

    Hi folks,
    I’m new to WordPress, and have actually the 2.6.2 version.
    I had the same problem as yours and tried everything from this post.

    Finally I tried to move the upload directory from /wp-content/uploads to /uploads, and it solves my problem!

    I created the uploads folder manually with my ftp client, and set it to 777. In settings->misc., I set the upload directory name to “uploads” (no slash anywhere)
    Note that I get an error if I check the checkbox “organize my files in year and month folders” (or something like that, I have the french WP version!)

    I’m not sure if I broke something by moving the upload folder or if it’s more dangerous for security, what do you think?

    Hope this helps!
    Sebastien

    Hi
    My picture uploader in wordpress is not uploading pictures. What might be the problem?
    i get only box whit a red x in ther left corner

    *NOTE: If you don’t want to read through all of this babble, skip down to the bottom to see what worked for me. ;-)*

    ****
    I hate to bring this one up again, but I figured it was a central post that everyone refers back to, so it would be a good spot for someone like me who had exhausted all their possible options on this one.

    I had poured through almost every post here regarding this issue, and had tried every suggestion, checking back daily for weeks. Every plug in, .htaccess workaround, permission set, hack, you name it…nothing worked.

    Today, I was setting up a new blog on the same host package, the same domain, the same DB server, and I decided to see if it too had the same upload error issue as I was having on my main photoblog site. Right out of the box, I uploaded a 1024×768 500k image…no problem at all. The best I was able to currently upload on my photoblog (that was having the HTTP upload issue) was about 800x600p and around 200k. I decided to spend some time going through all of my plugins, half at a time to see if I could narrow it down to a plugin on a 50/50 basis. As soon as I deactivated 1/2 of them…the issue was gone. Seeing that, I reactivated 1/2 of the previously deactivated ones and then tried again. The issue came back first shot with the same file. From there, I just kept playing the 50/50 game until I found the plugin that was causing it for me. I toggled it back and forth, and sure enough, it was the one that was causing me the headaches.

    WP-SpamFree 1.9.6.6

    Now, granted, I did not go back through all of the settings for WP-SpamFree yet, so there *may* be a way to get it to play nice. I was more concerned about being able to use WP to upload the photo sizes that I was able to prior to 2.5 or 2.6…whichever started tossing me the errors. I will report back if I find a setting or workaround for still using the plugin without the issue.

    So if you are reading this, and had gone through all of the steps on the first 4 pages without any luck, check what I’ve mentioned above.

    Good luck!

    This is an excellent troubleshoot method – it reminds me of the early days of Mac OS 9! LOL! Well done.

    More importantly, for me anyway, was that it worked. 😉

Viewing 10 replies - 136 through 145 (of 145 total)
  • The topic ‘2.5 image upload’ is closed to new replies.