WordPress.org

Support

Support » Alpha/Beta » 2.5 image upload

2.5 image upload

  • ok i have chmod’d my directories and blah blah. anytime i try and upload an image from my computer to insert in a post i get this error.

    “http error”

    and then it says in the image uploader “An error occurred in the upload. Please try again later.”

    i am lost as to why this is happening. i have been using wordpress since the early days of 1 and i have never had this problem. it is also a fresh install of 2.5.

Viewing 15 replies - 1 through 15 (of 145 total)
  • anyone?

    knightlore
    Member

    @knightlore

    i have the same problem have tried everything to get it to work

    Sounds like an apache-related problem to me? I could be wrong, though. For me… I don’t seem to have the problem at all, works fine 🙂

    sheikstanza
    Member

    @sheikstanza

    None of the uploads seem to work to me. everytime it fails at the moment that the message that it’s chunching the file appears (making a thumbnail and cannot write to the server maybe?) My host is also running apache…

    sheikstanza
    Member

    @sheikstanza

    Here is the error log while i tried to post a picture on my weblog:

    [Fri Mar 21 10:37:00 2008] [error] [client 62.131.44.82] mod_security: Access denied with code 406. Error processing request body: Multipart: final boundary missing [severity “EMERGENCY”] [hostname “momento.stanzafoto.nl”] [uri “/wp-admin/async-upload.php”] [unique_id “OZX2lcGKnSYAACWrb04AAAAU”]

    Some people out here who can do anything with this information?

    beautyadvice
    Member

    @beautyadvice

    the same problem ^_^

    I was having this same problem. For me, it got fixed when I went to the Settings -> Miscellaneous page and entered “Full URL path to files (optional)” (even though it was the same directory as “Store uploads in this folder.”)

    For some reason, having the full URL to the upload directory seemed to help.

    This worked for me. Your mileage may vary. 😉

    I get the same error on RC1. Using Len’s solution didn’t work, although I could have done something wrong.

    I found this link, which may explain why some are having issues, but there is no solution presented.

    My domain is technically an add-on domain of an existing domain if that helps anyone debugging.

    My apologies for bumping this thread. Found the solution in the bug tracker.

    http://trac.wordpress.org/ticket/6278

    I added this line to my .htaccess (assuming your WP installation is at the root):

    SetEnvIfNoCase Request_URI ^/wp-admin/async-upload.php$ MODSEC_ENABLE=Off

    These solutions did not work for me

    Any other suggestions?

    Thanks

    I am getting the same error.

    As ronalfy pointed out above, my wordpress is hosted on an add-on domain as well. Could that be a problem?

    In the next post, ronalfy points out the solution that (probably) worked for him. However, it is not working for my site. It’s still giving me that error.

    Any solution?

    WP 2.5RC1

    Oh and one clarification: I was trying to upload an audio file (not an image file). So it probably is giving error for uploading of any media type (through the new media uploading interface).

    RobTucker11
    Member

    @robtucker11

    I have tried the solutions listed above, however they are not providing a solution. Here is some other information that might be pertinant.

    I am running apache version 2.
    I have a feeling that the mod_security solution has just been working for apache 1.x users.

    I have tried setting the absolute upload path as well.

    My wordpress installation is in /wordpress/
    user.domain.com/wordpress/

    I have chmoded 777 and chowned appropriately just for testing purposes and have seen no difference.

    Can someone tell me how to disable the flash uploader just temporarily until this is resolved? Or even better offer up a working solution! Thanks!

    RobTucker11
    Member

    @robtucker11

    I ran another test and it resolved the issue for me.

    I rearranged the dns of my site so instead of the url being a sub domain it is now top level and the upload is working.
    Old url was user.domain.com now it is just domain.com . It is actually a flaw with the flash uploader and not word press. Hopefully this can help others having the same problem.

    Hey guys, I got it to work!!

    Add this to your .htaccess file

    <IfModule mod_security.c>
    SetEnvIfNoCase Content-Type \
    “^multipart/form-data;” “MODSEC_NOPOSTBUFFERING=Do not buffer file uploads”
    </IfModule>

    <IfModule mod_gzip.c>
    mod_gzip_on No
    </IfModule>

    Thanks a lot to Phil. http://permalink.gmane.org/gmane.comp.web.wordpress.testers/6706

Viewing 15 replies - 1 through 15 (of 145 total)
  • The topic ‘2.5 image upload’ is closed to new replies.