Support » How-To and Troubleshooting » 2.5 HTTP error when uploading Images from my computer

2.5 HTTP error when uploading Images from my computer

  • I have not been able to upload any images since installing 2.5. I get an HTTP ERROR and the the message ‘To try again later’ in the ‘crunching section of the upload window.

    What have I done wrong or need to do? I had NO problems uploading with any of the earlier versions of WP.

Viewing 15 replies - 1 through 15 (of 30 total)
  • I’m having the exact same problem!! Have you figured it out yet? Anyone know how to fix? My blog is attached to my domain.

    I had this problem a while back, and the only way I got it resolved was to install the no-flash-uploader plugin, which works like a charm, but removes some of the nice flash interfaces in the admin area. however I found it not to be a big deal at all. it still allows you to publish just the same as before. it is the perfect solution.

    Thanks mate, it works. Not ideal but good for now.

    I found that this works, but it’s definitely not ideal, it doesn’t allow for multi-uploading as the other one did.
    The funny thing is, it worked perfectly for me up until I moved to hostgator, suggesting that it could be a host problem, but with the no-flash uploader, it works seamlessly. Strange, eh?

    I submitted a ticket to my host about it, they gave me the following :
    The security department will need to update the security filter for this to work. The user agent supplied by this plugin was left as the default user agent, and this will cause issues.

    If that’s any help 🙂

    just to add to the mystery…I have 3 WordPress sites running from the same web server and only one of them has the above problem.

    I’ve deactivated all my plugins in turn with no joy.

    Maybe it is permissions related – specific to the site? htaccess?

    Anyone figure this out yet? I use hostgator and get the same error.

    Weird, im also on hostgator and having same problems,, i installed no flsh plugin and it works now. but when i click on write post or loginto my dash board my computer goes

    The no-flash-uploader solved the problem! Dont loose time , just use it!

    I was pissed off… already using the next-gen gallery to upload pictures b4 writting posts (not bad at all, but…)…

    Thank you very much tronicscribe,

    Best regards, Joao, from Brazil

    I am also on Hostgator so I tried their support to get the problem fixed. They disabled mod security rules thinking that was the issue but the HTTP Error persists.

    At the end they said the problem is with the uploader and I should go back to the WordPress community. So it looks like we’re back to square 1.

    I’d still prefer to get that thing working than revert to the no-flash plugin……waiting and hoping…..

    “The solution for me was to edit the .htaccess file in the root directory of my webserver (the directory where WordPress is installed). Add the following to the the .htaccess file after the “END WordPress”:

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    If you are having the problem of your .htaccess file losing its changes, you have most likely put something inside the WordPress block of the .htaccess file. Keep any custom changes outside of that block or they will be overwritten.”

    Compliments of:

    If there isn’t a .htaccess file in there just create one

    I am also on Hostgator and was having the same HTTP problem trying to upload a single JPEG on a post. I did step 6 from http://wordpress.org/support/topic/164999?replies=1 which is as e-bony describes above, but in a separate .htaccess file in the wp-admin directory. It solved the problem.

    My question is though, does disabling mod_security like this leave your site open to hacking etc?

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    My question is though, does disabling mod_security like this leave your site open to hacking etc?

    No, and if you did as described in that post, mod_security is only disabled for that one async-upload.php file, not for all the other files.

    Thanks Otto42. Yes, I did as described in the post and copy/pasted the code as given into a new .htaccess file. I’m a WordPress newbie, and am probably stating the obvious, but when I first created the file in notepad it didn’t work until I renamed it without the “.txt” extension – just in case anyone else hasn’t yet done that.

    I had a similar problem with my blog. Was fine until I upgraded to 2.5.
    If you have exhausted all other avenues, I would contact your host. My host (Hostgator) was blocking the upload of images for security. I had to tell them the location of all of my blogs so that they could remove the security feature. This worked perfectly.

    When I was getting the problem I was just getting “http error”, but I know some people got “crunching” instead.

    It seems that the server was logging this message: mod_security: Access denied with code 403. Pattern match “^Shockwave Flash” at HEADER(“USER-AGENT”) [id “***MY ID”][rev “1”] [msg “SpamBot UA”] [severity “CRITICAL”] [hostname “***MY-DOMAIN***”] [uri “/testing/blog/wp-admin/async-upload.php”]

    Hope this helps you guys. I spent hours trying sugegsted fixes. I never would have guessed that it was a security issue with my host. After contacting them it was fixed within the hour.
    At first they argued that it was 3rd party software, but I told them that I had a test blog and I also had blogs on 2 servers and it was the same on all of them. They referred me to their higher level support and they fixed it within an hour.

    Let me know the outcome. dave@isnigh.com

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘2.5 HTTP error when uploading Images from my computer’ is closed to new replies.