WordPress.org

Support

Support » How-To and Troubleshooting » 2.5 – How to insert images in posts/pages?

2.5 – How to insert images in posts/pages?

  • Hi.
    I’ve upgraded to the 2.5 release but it seems I can no longer insert images in my posts and pages.
    I able to upload them into my gallery, and also see all the images stored in my nextgen gallery when I hit the insert images button on top of the editor.

    However, when I try to hit the “show”-link nothing happens and it doesnt seem to be any way to insert the image into the blog…

    I might be stupid here however I dont find any solutions, please help me if you know anything about it.

Viewing 15 replies - 1 through 15 (of 26 total)
  • guess it’s an issue for a lot of people. this might help…

    http://wordpress.org/support/topic/140107?replies=11

    also this…

    http://wordpress.org/support/topic/164999?replies=1

    I agree, something’s wrong here. But, what I do is click the insert image icon in the toolbar of the visual editor and type in the URL of the image file I want to use (You can get the URL by looking up the image on the control panel of your server). This works and doesn’t require too much effort.

    Hope this helps somebody.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Did you actually try the solutions posted here?

    http://wordpress.org/support/topic/164999

    Hi.
    I’ve tried to follow all the steps and cant seem to get it working.
    The error message says “HTTP-error” and below the status bar the message reads “An error occured in the upload. Please try again later”.

    The files seems to upload normally, it’s after the “crunching” process in the end of the upload it all seems to go wrong.

    Please help me out.

    Did you actually try the solutions posted here?

    http://wordpress.org/support/topic/164999

    Yeah dude! Everything on there, almost. the IE fix is a little problematic though.

    I am killing myself trying to get it onto my machine as SP2 won’t let me get close to the files within the ZIP. Any ideas?

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Use WinZip to work with that file. http://winzip.com

    Windows ZIP implementation does not like ZIP files produced by the bug tracker for some reason.

    Hey, Otto42! The no-flash-uploader plugin worked on my WordPress 2.5 like a charm. Now I can access my Media and upload or browse uploaded pics, and insert them in my posts again. It now pulls up a popup panel instead of a flash that doesn’t work.

    thanks, much for your ‘Sticky on Image/Media Upload problems’

    I’m too chicken to try a manual upload. I’m afraid that deleting files will kill the blog, just a mental block. I’m a bad Fantastico dependent.

    René

    Updating Bad-Behavior did the trick for me, thank you!!

    ReneODeay, can you post a link to the actual plugin? Can’t find the one you’re talking about.

    Does anyone have the same problem as me with the HTTP Error?

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    ReneODeay, can you post a link to the actual plugin? Can’t find the one you’re talking about.

    Once again, I’m forced to ask, did you *really* read this thread?

    Link: http://wordpress.org/support/topic/164999

    Read it. Closely.

    I have tried all of the alleged fixes. Nothing works. The lesson I have learned from this is to ignore the invitations to upgrade and W-A-I-T for at least a month until all these annoying bugs have been worked out. If 2.5 was so heavily tested, how could something so obvious as this slip through? I found it within one hour of upgrading.

    When will 2.5.1 be available? Not soon enough for me.

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    If 2.5 was so heavily tested, how could something so obvious as this slip through?

    It didn’t “slip through”. You’re assuming that everybody has the same problems as you. This is not the case, the image uploader works great for me and all the sites I’ve upgraded (upwards of 40 now).

    by my calculation, it works about 85% of the time. I do still occasionally get a blank window when I click on “insert into post” even though I change nothing in between. I also never logout.

    have never had a problem uploading.

    just upgraded to 2.5.1 and on initial attempt to insert image into post, I was asked to login (even though I was already logged in) and when I did so, I got the blank window.

    congrats 2.5.1, you’re now working 0% of the time.

    anyone know why I would be told that I need to login when I’m already logged in?

    second and third tests…

    image uploader causing my ff browser to freeze. am gonna install no-flash-uploader. this was never a problem in 2.5

    so far for me, 2.5.1 has more problems than 2.5

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘2.5 – How to insert images in posts/pages?’ is closed to new replies.