2.5 font size

  • I’m using WP2.5 and have a bunch of text formating options except for font size…

    Any hints on how to change font size??

Viewing 9 replies - 1 through 9 (of 9 total)
  • You will have to edit the site’s style (CSS file).


    Thanks but that’s not what I meant. I meant if I’m writing a post and want different font sizes within the given post, do I have to (can I) edit via html (as opposed to visual) editor?

    Wow, I didn’t even notice there’s no button for font size in the editor, oh well, you will just have to do it the old school way.

    <span style="font-size:10pt">YOUR TEXT HERE</span>

    Of course, you can also edit the default configuration of the editor. Open /wp-includes/js/tinymce/tiny_mce_config.php with a text editor, find $mce_buttons and add fontsizeselect into the array.

    $mce_buttons = apply_filters('mce_buttons', array('bold', 'italic', 'strikethrough', 'fontsizeselect', '|', 'bullist', 'numlist', 'blockquote', '|', 'justifyleft', 'justifycenter', 'justifyright', '|', 'link', 'unlink', 'image', 'wp_more', '|', 'spellchecker', 'fullscreen', 'wp_adv' ));

    (the above code placed the font size selector after the strike through button)

    There’s a list of buttons you can add to the editor, and you can find the list on TinyMCE’s website here.

    thanks a lot for your help haochi, should try asap.

    Take a closer look at your Write panel. The last button says (if you hover) Show/Hide Kitchen Sink.
    Click it – and a second row of buttons will be revealed 🙂

    thanks moshu, did that but there’s no font size button… paragraph, font color, paste from word etc etc… but no font size. also followed haochi’s advice but nothing happened. :/

    Have you tried Haochi’s span suggestion with something other than 10 pt? That may be too close to default size, so you aren’t seeing anything. Try 15 point and see if you notice anything.

    i’m sure span suggestion will work but i’d really prefer to have a simple button.. i edited the tiny_mce_config.php file as suggested but nothing changed in the editor.

    Are you sure? I edited mine and it worked.
    You probably need to clear out your js_cache in /wp-content/uploads

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘2.5 font size’ is closed to new replies.