WordPress.org

Support

Support » Installation » 2.5 database upgrade loop

2.5 database upgrade loop

  • hey all

    tried searching for this particular issue, but came up with nothing. all apologies in advance if i missed something.

    when manually upgrading from 2.3.3 to 2.5 i get the database needs upgrading which then after hitting the upgrade button it takes me directly back to the initial page of the database needs upgrading. so, its just an infinite loop. i disabled all plugins before attempting to upgrade. thoughts/advice would be greatly appreciated. dont know if you need the site but its captainsdead.com.

    i had this issue six months ago, and for the life of me cant remember how i fixed it.

Viewing 15 replies - 1 through 15 (of 16 total)
  • man i am now getting this same problem, did you happen to find any fixes for this?

    nope, no fixes thus far. i have tried everything i know how to do, but alas nothing seems to work. stuck on 2.3 for now.

    if i figure it out, i will report back and fill ya in. please do the same.

    i’ll def. keep you updated, thanks for the reply. i’m actually trying to install 2.5, not 2.3. i wonder if I can still try installing 2.3 after trying to do an update with 2.5? i think the update wrote a bunch of stuff to my db cause my backup of my blog isn’t working now either = (

    I have the same problem.

    I have backed up my 2.3 db, then deleted all files.

    I installed 2.5 files, then restored old db using phpmyadmin.

    When trying to access wp-admin I was asked to upgrade database. I hit upgrade database… the message said the upgrade was successful. ( I checked the database and the table names have not changed – perhaps that’s an indicator that permissions are not right or something of WP vs the db ).
    I go to wp-admin again, I then get the upgrade db wizard again.

    Would love some help on this one too.

    If anyone is still looking for a solution to this problem, I have fixed mine at least:

    I have these two plugins installed:
    http://wordpress.org/extend/plugins/replace-wp-version/
    http://wordpress.org/extend/plugins/wp-security-scan/

    I had uninstalled them both, but somehow one of them was causing my wordpress version to change even after uninstalling. I deleted the folders from the plugins directory… then backed up my db… then installed wp 2.5, restored db, ran the upgrade wizard and it worked.

    I hope this helps you guys.

    Yes – I have the same problem upgrading from 2.3 to 2.5.1. Even removing all plugins fails to resolve it.

    Help!

    I’m having the same problem and the loop is preventing me from accessing the admin area of my site, so I can’t activate plug-ins or anything. I’m absolutely stuck and can’t do anything until I get this fixed.

    Anyone found a solution to this yet? I have removed all my plugins but still i’m stuck in the loop of wordpress death

    im dead. i got the same problem, and i did not back up my blog! how do i get my entries back?

    i have yet to figure this out and after more than a dozen or so failed attempts i have stopped worrying about it. anyone figure this out?

    @doubter, mkassian, and BUST4 – if deleting the WordPress files, then reuploading, per Steps 7 and 8 in Upgrading_WordPress_Extended does not solve the problem, restore your 2.3.3 database, check/rebuild your tables in phpMyAdmin, backup your wp-content/plugins folder, then delete the plugins folder. Then delete the WordPress files, and reupload them per Steps 7 and 8 in Upgrading_WordPress_Extended. Login to your blog as admin to complete the upgrade, restore any plugin files to wp-plugins folder, then visit the Plugins tab in your admin panel and update your plugins.

    @funnyumbrella – Backup your database NOW. Then I’d consider deleting the WordPress files, then reupload, per Steps 7 and 8 in Upgrading_WordPress_Extended.

    thanks, michael, but alas that didnt work either. again, thanks though. maybe some one can let me know if this looks correct though. right now when i do the upgrade i get this

    http://www.captainsdead.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2Fpost-new.php

    that doesnt look correct to me, but i may be wrong, of course.

    hello everybody, i had the same problem, and got it solved today:
    the problem was the database. When analysing the tables in phpMyAdmin, I was informed that several tables were set to read-only. the tech-support of my provider fixed it then by checking the db-user privilegies.

    hope this helps, shusha

    bastischubert

    @bastischubert

    hi there,

    i had a db update loop caused by my custom cache configuration.
    i use memcached as object cache and the cached object for wp_db_version had’nt expired. so wordpress was told it still uses an old db version (-:

    after “kicking” memcached the loop was broken 🙂

    wp upgrade from 2.6 to 2.6.1

    cheers
    basti

    jamalli

    @jamalli

    I faced the same issue. Deactivated plugins, then were able to upgrade DB.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘2.5 database upgrade loop’ is closed to new replies.