Support » How-To and Troubleshooting » [Resolved] 2.5 Automatic Plugin Upgrade – PCLZip error

[Resolved] 2.5 Automatic Plugin Upgrade – PCLZip error

  • When I try to upgrade plugins automatically in the latest version of WordPress (is this the first 2.5 problem on the forums?! Woo!) I get this error:

    Fatal error: Cannot redeclare class pclzip in /usr/local/psa/home/vhosts/xxx.xxx/httpdocs/wordpress/wp-admin/includes/class-pclzip.php on line 162

    Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)
  • I got the same thing. It happens because another plugin has pclzip activated and running already — likely WordPress Automatic Upgrade. Just deactivate that plugin and it should work fine.

    I deactivated all plugins and it worked but it will be a pain to do it every time i need to update just one plugin.

    If you update WordPress Automatic Upgrade to their latest version it appears to play nice with 2.5’s plugin updating! 🙂

    Thanks all – it WAS WordPress Automatic Upgrade. I deactivated it, updated it automatically, and reactivated. All updates now work. Thanks!

    Thanks for posting here guys, I was trying to investigate why my “add media” button was missing, so i wanted to update all my plugins and came across this error. Upgrading WPAU allowed me to upgrade the other plugins and determine that the plugin causing my “add media” buttons to go away was WP-Amazon. Deactivated that, and pow, “add media” is back:)

    Hey Mathew,

    Thanx…I did deactivate the WP Auto Upgrade plugin and it works. Looks like there’s a bug with this issue.

    Best regards.

    Yes the same as above, thx~

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] 2.5 Automatic Plugin Upgrade – PCLZip error’ is closed to new replies.