Support » How-To and Troubleshooting » [Resolved] 2.5 and TinyMCE not working in visual mode

[Resolved] 2.5 and TinyMCE not working in visual mode

  • First, I’ve got to say the responses that have been posted when people have tried to report this have been poor. The responses have just been a simple repetition of the same “solutions” which have been nothing of the sort.

    Second, there’s clearly a whole class of problems here and I’m focussed on the one I have for obvious reasons.

    So, how to verify you’ve the same problem. Use some sort of debugger tool like firebug etc, Peter Hengl gives a nice description here : http://wordpress.org/support/topic/164990

    The first thing to establish is that it’s not a cache problem, at least not in the way that keeps getting posted. For a start, browser and network caches don’t work like that. What I did find was that different files were returned using different clients, any browser (opera, safari, firefox) over three OS’es (Mac OSX, XP, Linux) returned a “cached” file that didn’t reflect debugging changes I made on the server, it was instantly obvious from a network trace that this wasn’t held in any browser cache. However, curl and wget instantly reflected the debug code, someone should have tried that before blaming caching as it’s obvious when you look at the code in tiny_mce_config.php why that’s going to be different. In fact, looking at the code I’d guess this would also work correctly (this far) in IE5.

    To fix this, remove the files from wp-content/uploads/js_cache and you’ll start getting an up to date copy of the mce code. NOTE, not everyone will have this issue as such, the cache code is broken in a way I’ve not fully analysed so this is a nuisance rather than the root cause.

    Next, to the source of the real problem. The debugger instantly spots this, it’s related to some I18n code and follows back to the get_locale function. The function is weak and used weakly in places which is why there’s a problem. This problem will most likely effect people not using 100% English language environments like Peter who’s German or me with Swiss/French locale, in fact, Peter’s nationality already made me guess the I18n code was broken.

    The simple fix is to go to your wp-config file and set the WPLANG variable to something suitable. For me, “en” is fine.

Viewing 15 replies - 16 through 30 (of 38 total)
  • Maybe if this thread were posted elsewhere it might do some good: Have you looked at this url?


    Tried everything suggest here. None of it worked unfortunately.

    I don’t even have a js_cache folder — and I’d love to know why and what that means if I don’t have one.

    The I tried the solution from bonheddwr over on another thread (here) just above here by about two comments.

    I had this problem, and tried everything suggested above, then noticed that chmod for the following file was 644 instead of 755 wp-includes/js/tinymce/tiny_mce_config.php

    This was the answer for me
    THIS WORKED… Nice… which I tried that first.

    Thanks heaps to everyone that has posted their replies to this thread. Team work works.

    If You’re on Godaddy’s servers and using the free hosting, don’t expect the visual editor to work. You’ll need to upgrade to paid hosting to remove the banner ads that interfere with the tinymce javascript.

    hi,Azselendor. i am using godaddy free, are u sure thats is the main problem? i have try everything, Nothing work. are using free hosting too?


    I have two budget clients that insist upon godaddy as their hosting (ugh…) and neither worked until one of them upgraded to paid hosting

    Error “tinyMCEPreInit.start not a function” in FF3, firebug. WordPress 2.6.2, fresh install, on php 4.4.8.

    My problem was a known bug with PHP’s realpath() (bugs.php.net/bug.php?id=34552), called in wp-includes/js/tinymce/tiny_mce_config.php:20.

    Realpath will output a null string if any ancestor directory of the file is not readable — so folks running out of home directories – this is likely your case.

    My fix – change tiny_mce_config.php:17

    function getFileContents($path) {
    //	if ( function_exists('realpath') )
    //		$path = realpath($path);
    	$path = dirname(__FILE__) . "/" . $path;

    (please forgive multiple postings)



    I have solved this problem for myself after hours and I just want to share this in case it helps someone:


    Edited file tiny_mce_config.php
    ‘compress’ => true
    compress’ => false.

    Still didn’t work. I then realised that /wp-includes/js/tinymce/tiny_mce_config.php
    had some header errors that pointed to the wp-config.php file. All that had happened was that the wp-config.php file ended with two extra lines after ?>.

    Got rid of the two extra lines and ta-da! visual editor works. I don’t think I put the two extra lines in, so perhaps this problem is more universal? let me know!



    I hunted through all the posts to fix this and it was the en WPLANG variable that did it for me in the wp-config file

    Thanks for the help – by the way this problem was also in version 2.6.2

    The original solution of ian_spare helped me about two weeks ago, but I experienced the same issue this week and were unable to get WYSIWYG to work following any of the instructions in this thread and other threads considering the issue.

    I tried to disable installed plugins one-by-one and managed to solve my problem. The plugin that caused it was “XHTML to HTML” plugin.

    So, if you have the same issue and none of advices helps, check if this plugin is installed and try to disable it.






    i just want to say THANK YOU!!! i had just made a post about this regarding my website organic makeup blog. all I did was clear out the js_cache folder & now it works!

    Am I supposed to put some kind of replacement file in there now? looks like the same one re-appeared after deleting old file, getting out, & then going back in. I apologize, but I am no coder.

    OK, it worked, but only for awhile. It went right back to doing the same thing again. It works if I keep clearing out that js_cache file. So, I checked my wp_config.php file & sure enough, there was no WPLANG set, so I set it to “en”. Logged back into my blog & editor still wasn’t working.

    deactiveated all plugins & started working again. Then I went back in & cleared teh js_cache again, just because I have no clue WTF I’m doing. Now i have to activate plugins one by one to see if one of them is still causing the problem. I don’t have the “XHTML to HTML” plugin, so it must be another one. I’ll let people know if I find anything.

    I have lost my Visual editor buttons since upgrading to 2.6.3 and cannot find any solution when I view source code for my /wp-admin/post-new.php I get this come up in the code.
    <script type=’text/javascript’>
    /* <![CDATA[ */
    wpAjax = {
    noPerm: “You do not have permission to do that.”,
    broken: “An unidentified error has occurred.”
    /* ]]> */

    I have tried all of the above has anyone got any good ideas what this could be as it is driving me INSANE…..

    Thank you! It worked for me.

    I don’t have js_cache file or a /wp-includes/js/tinymce/tiny_mce_config.php file. I changed th ewplang in wp-config to “en” and the site wouldn’t open so I tried ‘en’ and it opens but no visual editor.

    please help!!

Viewing 15 replies - 16 through 30 (of 38 total)
  • The topic ‘[Resolved] 2.5 and TinyMCE not working in visual mode’ is closed to new replies.