[resolved] 2.5 and TinyMCE not working in visual mode (39 posts)

  1. bergie812
    Posted 7 years ago #

    I don't have js_cache file or a /wp-includes/js/tinymce/tiny_mce_config.php file. I changed th ewplang in wp-config to "en" and the site wouldn't open so I tried 'en' and it opens but no visual editor.

    please help!!

  2. timclark
    Posted 7 years ago #

    I would not worry if you could not find your cache as I have deleted mine and all works fine still no wysiwyg tools though.

    With your wp-config file I put en.js in there and it works so it will read like this, define ('WPLANG', 'en.js'); but still no tools I think that sugestion might work for some issues but not for me.

    I am starting to have the assumption that there is either no one really has a clue about this issue or they are all at a coding convention some where in Iceland for the winter.

    HELP PLEASE......

  3. noeticvirtuoso
    Posted 7 years ago #

    I had the same problem, thankfully i got the answer from this thread.

    my /wp-includes/js/tinymce/tiny_mce_config.php had a file attribution 664 i changed it to 755, worked for me.


  4. _cornelius_
    Posted 7 years ago #

    It's possible to get the visual editor working with GoDaddy's free hosting. The fix involves a slight alteration to WordPress's script-loader.php.

    I've outlined the steps to do it here:


  5. nicadmin75
    Posted 7 years ago #

    i did the 755 instead of 644
    i did the 'en' instead of WLANG = ' '
    i did the clear cache stuff

    it shows visual, html is now clickable.. but when i click 'html' the textbox where you write your post disappears... i have 0 plugins installed (installed 2.6.5 from stratch, made a fresh new database, deleted the old wp folder, fresh install) and i still get this error!

    tried everything possible and still can't make it work! why aren't the wp creators looking into this? seems like a serious problem!

    please, somebody, help me! i'm very frustrated now knowing what to do and not being able to find the answer.

  6. ratpatrol2
    Posted 7 years ago #

    Finally got my visual editor to appear and thus unsticking the html mode !!

    After trying everything suggested in this thread and numerous others, I was about to give up when I was looking for the /wp-includes/js/tinymce/tiny_mce_config.php file and like bergie812 mentioned as I think someone else also mention,,I noticed I did not have a tinymce folder !!!! When I opened wp_includes/js there were only a few files there and NO folders and this is after deleting the wp_admin AND wp_includes folders and uploading fresh twice !

    I uploaded the missing folders, (logged out of WP, cleared cache just in case) and then presto chango the visual editor appeared !!! However despite installing the tinymce advanced plug in, it does not seem to work as I see the regular visual editor instead, but I am so happy to see it that I will not complain !!

    I will most likely uninstall that. If any issues arise I will post them.

    Thanks to all for working on this issue.


  7. pronto
    Posted 7 years ago #

    Hi, my solution lied within the wp-config file, in case you want to know more, check http://www.csnotes.net/?p=15

  8. pronto
    Posted 7 years ago #

    sorry, the correct link is http://www.csnotes.net/?p=31

  9. moris
    Posted 7 years ago #

    does not open the page (
    Server Not Found,

Topic Closed

This topic has been closed to new replies.

About this Topic